No announcement yet.

Raspian OS on Asus eee

  • Filter
  • Time
  • Show
Clear All
new posts

  • Raspian OS on Asus eee

    Dear all,
    I am a fr24 feeder since few years. I have been feeding the system via windows, when my computer was on till now. I want to create a stand alone solution using an old Asus eee box, instead of buying a raspberry pi. I've installed raspian OS on this small computer and try to configure the USB dongle installing the fr24feed. I try to install the repo via command line
    PHP Code:
    sudo bash -"$(wget -O -" 
    but it seems it cannot find the fr24feed software. So I downloaded the .tgz package and I did uncompressed it, but if I double click on the fr24feed the command line open up and close again very fast that I cannot see what's going on. Someone can help me? Thanks a lot in advance

  • #2
    With Raspbian OS, the best way is to install by .deb package, as it performs all necessary configuration also.

    The standard Raspbian OS is for CPU architecture armhf. What is the CPU of your Ausus eee?

    Seems you have installed Raspbian Desktop for PC & Mac (Raspbian Stretch x86 rpd), which is for x64 & x86.

    For cpu architecture x64 & x86, try this

    sudo apt update
    sudo apt install wget libc6 libstdc++6 zlib1g libusb-1.0-0  libudev1 dirmngr
    sudo wget  
    sudo dpkg -i  fr24feed_1.0.18-5_i386.deb
    If above fails, give following commands:

    sudo apt --fix-broken install  
    sudo dpkg -i  fr24feed_1.0.18-5_i386.deb
    Last edited by abcd567; 2018-12-25, 04:14.


    • #3
      Thanks very much for your quick answer. It looks like the first solution works. Now I'm trying to configure the small usb stick, can you just give me few more tips to get to the end? I'm not a master using linux and I don't know what's next. thanks again and merry christmas2018-12-25-100825_1920x1080_scrot.jpg


      • #4
        You chose MicroADSB.

        It's not a microADSB stick. You have a DVBT stick.
        Posts not to be taken as official support representation - Just a helpful uploader who tinkers


        • #5
          Oh yes, that's right. I haven't seen it because it was on the top This is what I have done, but it told me the email was wrong, but I never inserted the email address in the configuration process, I do I check the status of the fr24feed after I start the service? thanks2018-12-25-105848_1920x1080_scrot.jpg
          Last edited by Luwolfu; 2018-12-25, 12:35.


          • #6
            in the status window it gives me this issue


            • #7
              Open file fr24feed.ini for editing.
              sudo nano /etc/fr24feed.ini
              Delete whatever is in this file (except the feeder key, if it is there)
              Copy-paste following into the file fr24feed.ini.
              replace xxxxxxxxxxxxxxxx by your actual feeder key.
              Your actual feeder key is saved in fr24 windows feeder's fr24feed.ini file

              After copy-paste, Save (Ctrl+o) and Close (Ctrl+x)
              Then restart fr24feed
              sudo systemctl restart fr24feed

              GET YOUR KEY FROM HERE
              fr24 windows ini file.png
              Last edited by abcd567; 2018-12-25, 13:52.


              • #8
                this is the error I get now2018-12-25-150228_1920x1080_scrot.jpg


                • #9
                  This shows that you have NOT installed any DECODER (dump1090-mr or dump1090-mutability or dump1090-fa or modeSDeco2 etc).
                  You have two ways to do that:

                  METHOD - A

                  (1) Open file "/etc/fr24feed.ini" for editing
                  sudo nano /etc/fr24feed.ini
                  (2) Change

                  (3) Save (Ctrl+o) and Close (Ctrl+x) the file

                  (4) Restart fr24feed
                  sudo systemctl restart fr24feed
                  Setting receiver=dvbt will cause fr24feeder to install dump1090-mutability.

                  METHOD - B
                  Leave the setting at receiver="beast-tcp"
                  Manually install dump1090-mutability by method given here:

                  How to Install dump1090-mutability_1.15~dev on RPi.
                  Last edited by abcd567; 2018-12-25, 18:02.


                  • #10
                    ok, thanks for your patience and answers. I've been trying the dump1090 solution, this what I get 2018-12-25-202004_1920x1080_scrot.jpg

                    back at the first solution, the one with "dvbt" this is the error the status page show me 2018-12-25-202136_1920x1080_scrot.jpg


                    • #11
                      Go to following addresses in web browser of Raspbian on Ausus eee:





                      What do you see?


                      • #13
                        THe FR24FEED is OK
                        The problem is clearly with dump1090 as shown by:
                        (1) Yellow Warning rectangle at bottom of Map.
                        (2) "unknown version" instead of "v1.15~dev" just below the "Last Update" clock.

                        dump1090-mut problem 1.png . dump1090-mut problem 2.png

                        Try this:
                        Clear Browser Cache (Ctrl+Shift+Delete), then Browser Reload (Ctrl+F5)

                        If above does not work then probably you missed the "BUG FIX" in Step (7). Try it:

                        sudo wget -O /etc/udev/rules.d/rtl-sdr.rules "" 
                        sudo reboot
                        Clear Browser Cache (Ctrl+Shift+Delete), then Browser Reload (Ctrl+F5)



                        • #14
                          I'm pretty sure I've done the bug fixing procedure at step 7 at first. Anyhow I've done it again but still it doesn't work(unknown version is still shown). What if I try setting up "dvbt" without using the dump1090? Can you tell me the procedure to remove the dump1090 actually installed and try to reinstall it again?....I haven't gone after step 7, I tought the rest was already done or useless...
                          Last edited by Luwolfu; 2018-12-26, 19:46.


                          • #15
                            Originally posted by Luwolfu View Post
                            What if I try setting up "dvbt" without using the dump1090?
                            You already have dump1090 installed. If you choose "receiver=dvbt", fr24feed will install dump1090-mutability v1.14 over it, and may cause problems and conflicts. The very first thing you have to do is to remove (rather purge) the current installation of dump1090-mutability ver1.15~dev.

                            By the way do you have a Google Key?. The fr24feeder installs dump1090-mutability version 1.14, which has a google map, and needs Google Key. On the other hand version 1.15~dev has open street map and does NOT require Google Key.

                            Most likely during current install of dump1090-mutability, some files got corrupted, or some package did not get downloaded, or in Step(2) you missed one or two of the 11 package installation, causing this failure.

                            It is good idea to reinstall dump1090-mutability. I recommend that you first purge the existing one, and then try again the version 1.15~dev. Take care that you install ALL 11 packages in Step (2).

                            After completing step(2), give these two commands. These will show which of the packages have been installed, and if some are missing, It will try to install it, and ask your permission [yes/no].

                            sudo apt-get install git build-essential debhelper rtl-sdr librtlsdr-dev libusb-1.0-0-dev    
                            sudo apt-get install pkg-config fakeroot curl cron lighttpd

                            Originally posted by Luwolfu View Post
                            Can you tell me the procedure to remove the dump1090 actually installed and try to reinstall it again?

                            To remove dump1090-mutability fully, use "dpkg --purge" command. Do not use "dpkg --remove" command, as it does NOT remove configuration files.
                            sudo dpkg --purge dump1090-mutability
                            sudo rm -rf /usr/share/dump1090-mutability
                            sudo rm -rf ~/build-dump-mut

                            Originally posted by Luwolfu View Post
                            ....actually I haven't gone after step 7, do I have to do everything till down the list?
                            No, only upto step (7) is essential for installing dump1090-mutability. Rest of the steps are optional.
                            Last edited by abcd567; 2018-12-26, 20:27.