No announcement yet.

100% Uptime, 100% Offline, Range = 0, Possibility to check hardware?

  • Filter
  • Time
  • Show
Clear All
new posts

  • 100% Uptime, 100% Offline, Range = 0, Possibility to check hardware?

    Hi guys!

    I am new to feeding to FR24.
    I just received all my hardware and set it the last couple days.

    Hardware used:

    RPi 3+, DVB-T USB Dongle with small antenna, Wifi / Cable Ethernet

    So the situation is the following:

    If I check the status of my feed everything seems to be ok (except MLAT but this should not be a problem).
    If I log into the FR24 and feeding website my uptime is 100% but I am always shown as offline.
    Also the range of my antenna shows 0 nm in all directions even though it has a good position outside on my balcony.
    Here are not that many planes flying but at least some of them I should be able to track.
    Unfortunately my counter of tracked planes is 0 over the last 3 days.

    I contacted the support of FR24 and this was the answer:

    "Check the log file please. You can use this command to do that: tail -f /var/log/fr24feed/fr24feed.log

    If you see only pings, it would mean the antenna is not receiving any signal. Try placing your antenna in a better spot."

    When I try the command there are only Pings as described and I tried to rearange the antenna but nothing changes.

    So now the most important question:

    Is there any way to find out if my hardware is propper working how it is installed and should the data on FR24 not at least show some nautical miles as a range of my antenna?

    I also tried to reinstall the image of my Pi but nothing at all changes.

    Please let me know which additional infomation you may Need to find out what is wrong here because I am kind of out of ideas!

    Thanks a lot in advance.

    Best regards

  • #2
    (1) Do you see planes in the map at following address in your Desktop/Laptop Browser?


    ip-of-pi is the local ip of your Pi on which you SSH to it, and can find it from your router if you dont know it.
    My Pi's ip-of-pi is, so yours should be similar, but not identical.

    (2) Also see status on following page. What do you see?
    Last edited by abcd567; 2018-11-24, 20:31.


    • #3
      If you see planes at ip-of-pi/dump1090/gmap.html, and are still getting ping messages in fr24feed log, this may be because of IPv6 issue.

      To solve this, you have to disable IPv6. This can be done by following command.
      Note: Every time you reboot the PI, you have to issue this command.

      sudo sysctl -w net.ipv6.conf.all.disable_ipv6=1
      An alternative and better method, which does NOT block IPv6, but changes preference to IPv4 is as follows. This method has also the advantage that you have to do it only once, and dont repeat it at every reboot.

      Open file gai.conf for editing
      sudo nano /etc/gai.conf
      In above file, find the following line:

      #precedence ::ffff:0:0/96 100
      Uncomment this line (i.e remove # from the start of line), so it looks like:
      precedence ::ffff:0:0/96 100
      Save file (Ctrl+o) and Close File (Ctrl+x)

      Your Pi will now prefer IPv4 over IPv6 without disabling IPv6.
      Last edited by abcd567; 2018-11-24, 21:50.


      • #4
        Hi abcd567,

        thanks for your answers already!

        To sum it up: I don't see any planes on any screens unfortunately.

        The following screenshots show my status of the feed and the :8754, :dump1090

        In my eyes it seems to be fine what I set up but unfortunately no planes.

        I also set up my Pi new yesterday through this:

        Even the MLAT seems to work now but nothing appears.

        So any advices how to find out what is wrong?
        I guess it is not because of the IPv6 issue as I don't see anything.

        Thanks in advance!






        • #5
          sudo fr24feed stop
          sudo dump1090-mutability

          sudo rtl_test

          Does it report a 820T, or Fitpower/struggle to tune.

          only 500 data hits and - contacts is either not enough, or not able to tune correctly
          Posts not to be taken as official support representation - Just a helpful uploader who tinkers


          • #6
            Hi Oblivian,

            I tried both.

            Here are some screenshots:




            I see there are some errors I just don't know what the tell me or how to solve them.

            Do you have any idea?


            • #7
              Oh you have 1.15 and fr24 ontop

              You will need to stop that too

              sudo dump1090-mutability stop

              systemctl stop dump1090-mutability / rtl_test
              Posts not to be taken as official support representation - Just a helpful uploader who tinkers


              • #8
                This is what I get:

                sudo dump1090-mutability stop:


                systemctl stop dump1090-mutability and after rtl_test:


                What does this show?


                • #9
                  Yep there it is

                  Fitpower FC0012 tuner.

                  Won't work for aircraft.

                  Posts not to be taken as official support representation - Just a helpful uploader who tinkers


                  • #10
                    Hi Oblivian,

                    thanks for the help!
                    I just ordered another Dongle with which it should work proper!
                    I’m gonna try it again as soon as it is here!

                    Gesendet von iPhone mit Tapatalk


                    • #11

                      Hi guys!
                      Got my new hardware now!
                      Can you guys tell me if this one should work with aircraft I mean if it has the right chipset?

                      Gesendet von iPhone mit Tapatalk


                      • #12
                        The rtl_test results sre perfect! The test shows it has right chipset:

                        RTL2838 + R820T tuner

                        It should work ok with fr24feed / dump1090
                        Last edited by abcd567; 2018-11-27, 18:50.


                        • #13
                          100% Uptime, 100% Offline, Range = 0, Possibility to check hardware?

                          The line with “Msg” and “Sync” what exactly is it telling and what would be good here?

                          Gesendet von iPhone mit Tapatalk


                          • #14
                            Do you see any planes on the map?


                            • #15
                              No not yet but it may is because in the night here are nearly no planes and the antenna is not perfectly placed yet!

                              I will update you as soon as I tried this!

                              Or can I somehow else make sure everything is set up right?

                              Gesendet von iPhone mit Tapatalk