Announcement

Collapse
No announcement yet.

Debain Stretch (x64) Install

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Debain Stretch (x64) Install

    I run a Debian Stretch (amd64) server 24/7 to which I'd like to add a DVB-T stick and start contributing data.

    On the download page the only Debian-specific download is i386 so I assume I should download the distro agnostic amd64.tgz file instead and install that? I'd prefer .deb but comfortable either way.

    Also I've searched ebay (UK) for some suitable USB sticks and found one called a "AUZEUNER TV Digital DVB-T Receiver USB2.0 RTL2832U+R820T Stick SDR+DAB+FM Tuner" I assume this will do the trick? As this is my first post to the forum, I can't post links.

    Thanks in advance

  • #2
    Hi, FlightAware have a good range of kit designed for ADSB. (I'm not on commission, honest )

    Comment


    • #3
      thanks, think I will go for the stick above and upgrade in the future if I can get it working

      Comment


      • #4
        .
        INSTALLING FR24FEED ON DEBIAN 9.5 (STRETCH) AMD64

        ATTEMPT-1
        Code:
        abcd@debian:~$ sudo wget https://repo-feed.flightradar24.com/linux_x86_binaries/fr24feed_1.0.18-5_i386.deb
        .........
        2018-11-05 11:39:42 (4.66 MB/s) - ‘fr24feed_1.0.18-5_i386.deb’ saved [478596/478596]
        
        abcd@debian:~$ sudo dpkg -i fr24feed_1.0.18-5_i386.deb
        dpkg: error processing archive fr24feed_1.0.18-5_i386.deb (--install):
         package architecture (i386) does not match system (amd64)
        Errors were encountered while processing:
         fr24feed_1.0.18-5_i386.deb

        ATTEMPT-2
        Code:
        abcd@debian:~$ sudo wget https://repo-feed.flightradar24.com/linux_x86_64_binaries/fr24feed_1.0.18-5_amd64.tgz
        ........
        2018-11-05 11:42:39 (4.70 MB/s) - ‘fr24feed_1.0.18-5_amd64.tgz’ saved [301153/301153]
        
        
        abcd@debian:~$ sudo tar -xzf fr24feed_1.0.18-5_amd64.tgz
        
        abcd@debian:~$ ls
        build-dump1090-fa  Downloads                    fr24feed_amd64  Public
        Desktop        fr24feed_1.0.18-5_amd64.tgz  Music           Templates
        Documents      fr24feed_1.0.18-5_i386.deb   Pictures        Videos
        
        abcd@debian:~$ cd fr24feed_amd64
        abcd@debian:~/fr24feed_amd64$ ls
        fr24feed  LICENSE.fr24feed  version.txt
        
        
        abcd@debian:~/fr24feed_amd64$ sudo ./fr24feed --signup
        ..................
        ...................
        Saving settings to /etc/fr24feed.ini...OK
        Settings saved, please run "sudo service fr24feed restart" to use new configuration.
        
        abcd@debian:~/fr24feed_amd64$ sudo systemctl restart fr24feed
        Failed to restart fr24feed.service: Unit fr24feed.service not found.

        MANUAL CONFIGURATION OF FR24 SERVICE (ENABLES FR24FEED AUTO-START AT BOOT)

        (1) Copied executeable binary "fr24feed" to folder /usr/bin
        Code:
        abcd@debian:~$ sudo cp ~/fr24feed_amd64/fr24feed /usr/bin/
        (2) Added system user fr24 to run the binary through fr24feed.service
        Code:
        abcd@debian:~$ sudo adduser --system fr24
        (3) Created new blank file fr24feed.service
        Code:
        abcd@debian:~$  sudo nano /lib/systemd/system/fr24feed.service
        (4) Copy-pasted following code in the new blank file fr24feed.service.
        Code:
        [Unit]
        Description=Flightradar24 Decoder & Feeder
        After=network-online.target
        
        [Service]
        Type=simple
        Restart=always
        LimitCORE=infinity
        RuntimeDirectory=fr24feed
        RuntimeDirectoryMode=0755
        ExecStart=/usr/bin/fr24feed
        User=fr24
        PermissionsStartOnly=true
        StandardOutput=null
        
        [Install]
        WantedBy=multi-user.target
        (5) Saved file (Ctrl+o) and Closed it (Ctrl+x)


        (6) Enabled fr24feed.service by following command
        Code:
        abcd@debian:~$ sudo systemctl enable fr24feed
        Created symlink /etc/systemd/system/multi-user.target.wants/fr24feed.service → /lib/systemd/system/fr24feed.service.
        
        abcd@debian:~$ sudo reboot
        
        abcd@debian:~$ sudo systemctl status fr24feed
        
         fr24feed.service - Flightradar24 Decoder & Feeder
           Loaded: loaded (/lib/systemd/system/fr24feed.service; enabled; vendor preset: enabled)
           Active: active (running) since Mon 2018-11-05 13:41:26 EST; 13s ago
         Main PID: 27794 (fr24feed)
            Tasks: 9 (limit: 4915)
           CGroup: /system.slice/fr24feed.service
                   └─27794 /usr/bin/fr24feed
        
        Nov 05 13:41:26 debian systemd[1]: Started Flightradar24 Decoder & Feeder.




        .
        .

        You will also need to install on your x64 machine, either:

        dump1090-mutability (Click Here for detailed steps)

        OR

        dump1090-fa (Click Here for detailed steps) .

        I already had dump1090-fa installed on my Desktop / Debian 9.5 (stretch), amd64, so I straightaway attempted to install fr24feed.





        Code:
        abcd@debian:~$ sudo systemctl status dump1090-fa
        ● dump1090-fa.service - dump1090 ADS-B receiver (FlightAware customization)
           Loaded: loaded (/lib/systemd/system/dump1090-fa.service; enabled; vendor preset: enabled)
           Active: active (running) since Mon 2018-11-05 13:04:30 EST; 6min ago
             Docs: https://flightaware.com/adsb/piaware/
         Main PID: 352 (dump1090-fa)
            Tasks: 3 (limit: 4915)
           CGroup: /system.slice/dump1090-fa.service
                   └─352 /usr/bin/dump1090-fa --device-index 0 --gain -10 --lat 43.xxxx --lon -79.xxxx --ppm 0 --net-bo-po
        
        Nov 05 13:04:30 debian systemd[1]: Started dump1090 ADS-B receiver (FlightAware customization).
        Nov 05 13:04:30 debian dump1090-fa[352]: Mon Nov  5 13:04:30 2018 EST  dump1090-fa 3.6.3 starting up.
        Nov 05 13:04:30 debian dump1090-fa[352]: rtlsdr: using device #0: Generic RTL2832U (Realtek, RTL2832UFA, SN 000000
        Nov 05 13:04:30 debian dump1090-fa[352]: Detached kernel driver
        Nov 05 13:04:31 debian dump1090-fa[352]: Found Rafael Micro R820T tuner
        Nov 05 13:04:32 debian dump1090-fa[352]: rtlsdr: enabling tuner AGC
        Last edited by abcd567; 2018-11-06, 17:40.

        Comment


        • #5
          @abcd567 many thanks for that, certainly more complicated than I was expecting and you've saved me a few hours of hassle later this week.

          Quick question: I thought fr24feed came with an implementation of dump109 built in/packaged (or is that only with the .deb?), but you're suggesting that I need to set this up first?

          Comment


          • #6
            Many thanks for this, it will save me a lot of hassle, I can tell!

            Quick question though, I thought fr24feed came with it's own dump1090 - are you suggesting that I need to set that up first/separately?

            Comment


            • #7
              sarkscouser

              The .deb package installs fr24feed and also a script to install dump1090-mutability on-demand. If it detects no dump1090 present, OR if you choose setting "Receiver = DVBT", it runs this script and installs dump1090-mutability.

              I am not sure about generic .tgz. The unzipped folder of "fr24feed_1.0.18-5_amd64.tgz" does not have any script to install dump1090-mutability. I dont know if it is in-built into the binary. I already had dump1090-fa which was detected by the binary and it did not attempt or offer to install dump1090.

              I suggest you do NOT install any dump1090. First run the executable binary by command "sudo ./fr24feed --signup", and in "Step 4.1 - Receiver selection", select "1 - DVBT Stick (USB)", and see if it installs dump1090. If it does not, then go ahead with manual installation of dump1090 (mutability or fa)

              When I ran the binary, I got this message
              Code:
              abcd@debian:~/fr24feed_amd64$ sudo ./fr24feed --signup
              .........
              Step 1.1 - Enter your email address (username@domain.tld)
              $:xxxx@yyyy.com
              
              Step 1.2 - If you used to feed FR24 with ADS-B data before enter your sharing key.
              If you don't remember your sharing key, pelase use the retrival form:
              http://feed.flightradar24.com/forgotten_key.php
              
              Otherwise leave this field empty and continue.
              $:xxxxxxxxxxxxxxx
              
              Verifying sharing key...OK
              
              We have detected that you already have a dump1090 instance running. We can therefore automatically configure the FR24 feeder to use existing receiver configuration, or you can manually configure all the parameters.
              
              Would you like to use autoconfig (*yes*/no)$: yes
              .........
              .........
              Saving settings to /etc/fr24feed.ini...OK
              Last edited by abcd567; 2018-11-06, 18:14.

              Comment


              • #8
                OK, thanks, I'm a bit stuck until my DVB stick arrives and I'm away next week so probably a job for 2 weeks time at this rate...

                Comment


                • #9
                  I always answer "no" to the Autoconfig question and then I manually select the IP (127.0.0.1 for example) and the port: BeastTCP 30005.

                  Comment


                  • #10
                    SoNic67

                    Yes, in my opinion also "Beast, 127.0.0.1:30005" is better than "AVR, 127.0.0.1:30002", but Flightradar24 has chosen AVR as the default for reason unknown to me.

                    The file /etc/fr24feed.ini has following content by default:

                    receiver="avr-tcp"
                    host="127.0.0.1:30002"
                    fr24key="xxxxxxxxxxxxxxxx"

                    bs="no"
                    raw="no"
                    logmode="0"
                    windowmode="0"
                    mpx="no"
                    mlat="yes"


                    I prefer the first two lines to be

                    receiver="beast-tcp"
                    host="127.0.0.1:30005"

                    .
                    Last edited by abcd567; 2018-11-08, 22:11.

                    Comment


                    • #11
                      Mode-S Beast seems to contain more data, but probably it's not needed by FR24 servers?
                      http://wiki.modesbeast.com/Mode-S_Be...Output_Formats
                      The AVR format, which is a ASCII hexdump of the raw frame contents with some variances
                      The Mode-S Beast binary format, which is an escaped transparent binary protocol, always contains time and signal level information

                      Comment


                      • #12
                        Well, my DVB stick arrived today so I've just had my first crack at this.

                        I've got everything working apart from ligthttpd which I couldn't get working after various tweaks so I've removed that. I went with dump1090-fa and got that working but not the web server it would just not start with the dump1090-fa config in place.

                        I'll look into that another time (but if you have any tips..... :-) )

                        Comment


                        • #13
                          To answer my own question and for anyone else who already has other service listening on standard web ports (8080 in this case) I eventually found the fix via this page:

                          http://www.justinscholz.com/wp/conve...09-mutability/

                          Change the port from 8080 to something like 8081 in the file "/etc/lighttpd/conf-available/89-dump1090.conf"

                          Comment

                          Working...
                          X