Announcement

Collapse
No announcement yet.

Data transmission interrupted intermittently

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Data transmission interrupted intermittently

    Hello, since several days I have noticed that my data transmission is regularly interrupted.

    I don't understand what's going on, everything seems ok for me... Is it a displaying problem or does my receiver have a problem?

    receiver FR24.JPG

    Thank you !

  • #2
    https://forum.flightradar24.com/showthread.php?t=12215

    https://forum.flightradar24.com/showthread.php?t=12223

    Sent from my XT1092 using Tapatalk
    Posts not to be taken as official support representation - Just a helpful uploader who tinkers

    Comment


    • #3
      Same problem here.

      2018-11-07 21_27_06-Window.png

      Comment


      • #4
        No problem 'down under' so its a limited regional or local issue.
        traffic.JPG

        Comment


        • #5
          This problem is still present. When will it be solved?

          Comment


          • #6
            Add the following two parameters to /etc/fr24feed.ini, save and restart your Pis. This will fix it.

            use-http=yes
            http-timeout=10
            --

            Comment


            • #7
              FR24 should push this as an automatic update to their clients. I cant do this at my own. I have no any linux knowledge.

              Comment


              • #8
                Khan, tnx for the info.....worked perfectly.
                Last edited by luckylindy; 2018-12-14, 19:10. Reason: typo
                de WA4CHQ/qrp 99% cw since 1972. Linux using SLACKWARE since 2000

                Comment


                • #9
                  Originally posted by Khan View Post
                  Add the following two parameters to /etc/fr24feed.ini, save and restart your Pis. This will fix it.

                  use-http=yes
                  http-timeout=10


                  Originally posted by vqr View Post
                  FR24 should push this as an automatic update to their clients. I cant do this at my own. I have no any linux knowledge.

                  @vqr:
                  You dont need to know linux, just following two commands:

                  Code:
                  sudo nano /etc/fr24feed.ini 
                  
                  sudo reboot

                  STEP 1 of 2 - Installing PuTTY on Windows Computer

                  The most important thing is that you are able to access files on your RPi. To do this you have to install a software called "PuTTY" on your Windows Desktop/Laptop. If you use Mac, then its Terminal can be used to access the RPi and you dont need to install PuTTy.


                  1.1 - Click this link to download PuTTY windows installer

                  Download Page:
                  https://www.chiark.greenend.org.uk/~...ty/latest.html

                  1.2 - Doble click downloaded installer to install the PuTTY.

                  1.3 - After installation is complete, open PuTTY. It will be like screenshot below




                  1.4 - Enter your Pi's Local IP you found from your router (it is same IP which you use for viewing dump1090 map or status/settings page). Make sure SSH is selected and port is 22. Click Open button. (The IP address 192.168.0.21 in screenshot below is given only as an example).





                  1.5 - You will get a warning. Click Yes button





                  1.6 - A SSH Console window will open with one line Login as . Type pi and press enter. Then it will ask password . Type password raspberry (the typed password will not be visible to you). Press Enter key, and you are ready to start using commands.





                  .

                  .


                  STEP 2 of 2 - Adding two lines to file /etc/fr24feed.ini

                  2.1 - Type sudo nano /etc/fr24feed.ini and press Enter key.




                  2.2 - Above command will open file fr24feed.ini for editing.
                  Add two lines as shown in red below
                  After adding two red lines, Save file by simultaneously pressing Ctrl+o keys, then Close file by simultaneously pressing Ctrl+x buttons.

                  Code:
                  receiver="avr-tcp"
                  fr24key="xxxxxxxxxxxx"
                  host="127.0.0.1:30002"
                  bs="no"
                  raw="no"
                  logmode="0"
                  windowmode="0"
                  mpx="no"
                  mlat="yes"
                  mlat-without-gps="yes"
                  use-http=yes
                  http-timeout=10

                  2.3 - Reboot Pi by typing sudo reboot in PuTTY, and pressing Enter key:

                  Code:
                  pi@raspberrypi:~ $ sudo reboot
                  .
                  Last edited by abcd567; 2018-12-14, 23:32.

                  Comment


                  • #10
                    Thanks, it works perfectly now

                    Comment


                    • #11
                      Running into a new issue... that fix works, but my edits seem to be erased after changing anything within my setup on my Pi. Even though I save it and reboot every time. Any ideas as to why my edits don't persist? Does the FR24 auto-update revert the .ini files to their original form?

                      Comment


                      • #12
                        Can you post the output of
                        Code:
                        ls /boot
                        ls -l /etc/fr24feed.ini
                        mount | grep mmcblk

                        If you are on a fr24 sd-card image then it seems the main partition is read-only.
                        Not sure why. Maybe if there is a config file in /boot you can change the setting there.

                        Comment


                        • #13
                          Code:
                          sudo chmod a+rw /etc/fr24feed.ini
                          Last edited by abcd567; 2019-02-06, 22:39.

                          Comment


                          • #14
                            Originally posted by abcd567 View Post
                            Code:
                            sudo chmod a+x /etc/fr24feed.ini
                            Making it executable won't help with making it writeable.
                            Making it writable would be this:
                            Code:
                            sudo chmod a+w /etc/fr24feed.ini
                            Anyhow if the main partition is mounted read only which seems to be the case with the current fr24 sd-card image, then this won't work.

                            Comment


                            • #15
                              Oops, instead of a+rw, I wrote a+x.
                              Corrected it now.

                              Comment

                              Working...
                              X