Announcement

Collapse
No announcement yet.

Data transmission interrupted intermittently

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • #16
    From fr24feed installation script:
    Code:
    # Run the signup wizard
    if [ $AUTO_SIGNUP -eq 0 ]; then
        fr24feed --signup
        chmod a+rw /etc/fr24feed.ini
        
        # Restart the feeder software
        systemctl restart fr24feed
    fi

    Comment


    • #17
      Originally posted by wiedehopf View Post
      Can you post the output of
      Code:
      ls /boot
      ls -l /etc/fr24feed.ini
      mount | grep mmcblk

      If you are on a fr24 sd-card image then it seems the main partition is read-only.
      Not sure why. Maybe if there is a config file in /boot you can change the setting there.
      I'm not on a fr24 sd-card image, I built it from scratch (stretch). Here's a screenshot of the outputs of all three of those commands:

      IMG_7742.jpg

      Looks to me like the file is read/write? I'm at work right now so I can't dig into it too much but let me know if anything jumps out.

      Comment


      • #18
        After saving and exiting, can you open the file again and check if the changes are still present?

        Maybe you are not actually saving it? (Not sure what else it could be, i don't think the automatic update is messing with the config file at least i would hope it is not)

        Comment


        • #19
          Yeah, the changes are still there after I save, exit, and re-open. I'll try to replicate the problem tonight. FWIW, I did just re-install the FlightAware feeder, which required a reboot, and that's when I noticed that the data transmission was intermittent again. So either the reboot caused the change, or somehow the installation of the FlightAware feeder changed something, which would be surprising.

          Comment


          • #20
            Did you run through the signup dialogue?

            That probably overwrites the settings file with the information you entered.

            Comment


            • #21
              I installed the FlightAware feeder, not the FlightRadar24 feeder. The FlightAware installation didn't ask for any new information - I just re-configured the receiver, the TCP port, and the IP address. I don't see how one feeder's configuration could have changed the other's?

              Comment


              • #22
                The "Save" button on Web page "ip-of-pi:8754/settings.html" saves to file "/etc/fr24feed.ini" all the values currently displayed in all the fields of the "settings.html" page.

                To test, make some changes in settings on the "settings.html" page. After clicking "Save" button, click "Restart" button, then check the "settings.html" page again. If the modified settings are displayed, then these are saved in file "/etc/fr24feed.ini".

                Comment


                • #23
                  so you switched to
                  beast
                  and
                  127.0.0.1:30005
                  ?

                  Hopefully all working good now.

                  (Regarding my question in regard to signup: i thought you re-ran the fr24 install, didn't read properly)

                  Comment


                  • #24
                    Originally posted by abcd567 View Post
                    The "Save" button on Web page "ip-of-pi:8754/settings.html" saves to file "/etc/fr24feed.ini" all the values currently displayed in all the fields of the "settings.html" page.

                    To test, make some changes in settings on the "settings.html" page. After clicking "Save" button, click "Restart" button, then check the "settings.html" page again. If the modified settings are displayed, then these are saved in file "/etc/fr24feed.ini".
                    This did the trick. I went into the FR24 settings, clicked "save", clicked "reboot", and then checked the .ini file. The changes had been erased. Thanks for the insight!

                    Comment


                    • #25
                      Originally posted by wiedehopf View Post
                      so you switched to
                      beast
                      and
                      127.0.0.1:30005
                      ?

                      Hopefully all working good now.

                      (Regarding my question in regard to signup: i thought you re-ran the fr24 install, didn't read properly)
                      Yep, that's exactly right - and no worries! I got it all working now, thanks for your help!

                      Comment

                      Working...
                      X