Announcement

Collapse
No announcement yet.

pi24 and reduced coverage

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • pi24 and reduced coverage

    G'day all,
    have been feeding fr24 for 4 years, via linux the box thats circa 2003, its been fine until recently, all it does is fr24, GSM stuff, and media streaming, lately its had a few problems, USB ports cant provide much current, it gets upset with the dongle and gsm unit both plugged in, so i grabbed a spare pi 3b doing nothing but collecting dust for 2 years, with little spare time at present I decided on the pi24 image, that all seems to have worked well, no problems, quick and painless, but -

    Since moving the dongle onto the rpi, the coverage has been, frankly, shit.

    Used to average 130 nm, not much I know, but if you saw whats grown around the antenna in past 4 years you'd be shocked it does that well since the move to the pi several days ago, it averages a mere 52nm, has anyone else experienced reduction in range after such an install?


    Also of note:

    Tried a second dongle I use with my laptop to watch TV on another pc and it averages the same.

    The dongle connects by a secured 2 foot usb cable, so initially the dongle and therefor antenna connections were not (could not be) moved, just cable out of linux box and into the pi in the same rack next to it, also put usb cable on a tester and its tests fine, dongles test fine averaging 100mAh (no led) and 112mAh (dongle with led) - the same as per the ol linux box and both average 5.07v.

    Due to the failing nature of and refusal to work with with GSM unit in place (which can not be removed) on the old box I'm not really able to try it back there again. nly real time I can do that is after 1am, and theres bugger all fights around here at that time of day

  • #2
    Each device has its own interference and capabilities to handle the data on the USB port.

    Every time its changed to a new device. You need to re calibrate the software gain rates to the particular install

    https://forum.flightradar24.com/thre...ization-Script

    Also make sure you have an external power adaptor. Not powering via USB or a <1.2A supply.

    And Pi24.. doesn't work on Pi 3B+

    Should be doing raw raspbian and manual install if its a + model
    Posts not to be taken as official support representation - Just a helpful uploader who tinkers

    Comment


    • #3
      Originally posted by Oblivian View Post
      Each device has its own interference and capabilities to handle the data on the USB port.

      Every time its changed to a new device. You need to re calibrate the software gain rates to the particular install
      original dump1090 did this, pretty much always using max gain, being 49 on this device, why should it be any different here... I guess i'm missing something, or I've just been lucky all these years.

      That script seems to do nothing more than tell you what dump1090 always told me, the default file is already set to max, but ive changed it to 49 to see if it does anything different, it also requires 1.15, pi24 only have 1.14

      Originally posted by Oblivian View Post
      Also make sure you have an external power adaptor. Not powering via USB or a <1.2A supply.

      And Pi24.. doesn't work on Pi 3B+

      Should be doing raw raspbian and manual install if its a + model
      No its a 3b not 3b+, Ive read it wont work on 3b+ though not exactly why it wont... and its using a 2.5 Ah supply, plenty of grunt left in it.

      Only 2 errors I see, neither of which will affect range

      2018-09-20 21:23:03 | [w]Detected --net argument for dump1090, disabling internal RAW feed!
      2018-09-20 21:23:03 | [w]Detected --net argument for dump1090, disabling internal BS feed!

      Comment


      • #4
        It is reporting using max gain already so need need to mess with that I think

        from strace fr24feed
        018-09-20 22:17:55 | [reader][i]Connected to the receiver, configuring
        2018-09-20 22:17:55 | [reader][i]Configured, processing messages
        Thu Sep 20 22:17:55 2018 AEST dump1090-mutability v1.14 starting up.
        Found 1 device(s):
        0: Generic, RTL2832U, SN: 77771111153705700 (currently selected)
        Found Rafael Micro R820T tuner
        Max available gain is: 49.60 dB
        Setting gain to: 49.60 dB
        Exact sample rate is: 2000000.052982 Hz
        2018-09-20 22:17:56 | [time][i]Synchronizing time via NTP
        Gain reported by device: 49.60 dB
        2018-09-20 22:18:26 | [time][i]Time synchronized correctly, offset +0.0001 seconds
        2018-09-20 22:18:26 | [main][i]Feed Network client started
        2018-09-20 22:18:26 | [main][i]RAW data server started
        2018-09-20 22:18:26 | [raw][i]Initializing server

        Comment


        • #5
          Ressy

          Gain Optimization Script will NOT work on PI24's dump1090-mutabilty, as unlike dump1090-mutability ver 1.15~dev, it is NOT controlled by it's configuration file "/etc/default/dump1090-mutability", nor it is started by its startup file "/etc/init.d/dump1090-mutability". It is totally controlled by fr24feeder: start, stop, settings.

          By default, the gain setting is "max" i.e. 49.6.
          To change setting of gain, go to "Settings" page at following address in your browser

          IP-OF-PI:8754/settings.html

          In the field "Process Arguments", add --gain xx.x (replace xx.x by actual gain value you desire to set).
          Click "Save" button, then "Restart" button. Both buttons are at bottom-right of settings page.
          Please see screenshot below.
          In this screenshot, in addition to gain, I have added my latitude and longitude in decimal degrees (--lat xx.xxxx --lon yy.yyyy). Adding lat & lon activates display of (1) a marker showing location of your station (2) Three range circles at distance of 100nm, 150nm and 200 nm.

          PI24 Gain Setting.png

          Comment


          • #6
            Thanks, but I'm aware of pretty much everything you said (except adding lat/long in procps didnt know that one - Thanks!), I have verified the gain is using 49.6 when the pi starts it as per my very last post which was the same gain the stick used in the slackware box, it why i'm almost at a loss to explain it, since it shouldnt be any different to before, but its near only 1/3 the coverage so there is an issue somewhere... I might queue teh gsm stuff for 3 minutes and yank it and put the stick back in slackware box and see if ranges jump ... unfortunately i cant leave gsm disabled for too long since its mid morning in business hours right now.

            Comment


            • #7
              also adding lat lon doesnt take in pi24 , upon save, it refreshes returning without those settings - but thats neither here nor there at the moment. I can set them from config.js
              Last edited by Ressy; 2018-09-21, 00:06.

              Comment


              • #8
                Err.

                So if all the suggestions we have given are basically already been tried, and you already knew/know how to do them in deeper detail etc. I'm not sure there is much more that us other mere mortal users can do to help.

                Most of us are responding to "has anyone else experienced reduction in range after such an install?" with the likely causes/fixes that fix it in most cases for the others who have asked a similar question never to be heard from again.

                However if already versed in how to drive SSH and the commands around fr24feed Pi edition, despite time restraints I wouldn't have jumped on the pi24 - it's more designed for the safe but sure 1-hit wonder user that doesn't know how to drive linux/raspberry Pi and most likely wouldn't notice a change in range from a different setup or be bothered with fixing it if it gave them a business account regardless

                Fairly obvious (by how its not compatible across all platforms) how limited it is against Mutability 1.15/-dev or similar which in most cases has an automatic hit rate higher than the bundled version. And given you have exhausted yourself with it thus far. I don't see a solution short of a staged install you can actually tweak.
                Posts not to be taken as official support representation - Just a helpful uploader who tinkers

                Comment


                • #9
                  Originally posted by Oblivian View Post
                  Err.

                  I'm not sure there is much more that us other mere mortal users can do to help.
                  so the title of super moderator permits you to be an anally retentive sarcastic prick?

                  forget I asked the question, you can close the thread, if i have issues in future i wont be returning here for advice.

                  Comment


                  • #10
                    I wasn't being sarcastic. At least 2 of us have given suggestions that usually fix it. And as you state you have tried them all and it hasn't. There's not a lot more that we can suggest may fix what you are seeing over trying the non imaged version.?!?!

                    Sent from my XT1092 using Tapatalk
                    Posts not to be taken as official support representation - Just a helpful uploader who tinkers

                    Comment


                    • #11
                      Hi, recently my pi build has been automatically upgraded to software Linux/generic/static_armel/1.0.23-7

                      However I am noticing a quite reduced range... in the last few weeks my max was around 349Nm.. in these few days it is only 260Nm... I checked my hardware etc and everything is ok... antenna still pointing vertical (checked with spirit level etc)

                      Did someone noticed this lately ?

                      Comment


                      • #12
                        Any updates?

                        Comment


                        • #13
                          Mine auto updated and the coverage seems about the same... (not sure that's helpful?)

                          Comment


                          • #14
                            Originally posted by lodervsm View Post
                            Hi, recently my pi build has been automatically upgraded to software Linux/generic/static_armel/1.0.23-7

                            However I am noticing a quite reduced range... in the last few weeks my max was around 349Nm.. in these few days it is only 260Nm... I checked my hardware etc and everything is ok... antenna still pointing vertical (checked with spirit level etc)

                            Did someone noticed this lately ?
                            fr24feed and 1090 mutability dont play nice together
                            setting gain to 49 which is max, and is reported by fr24feed, is actually false
                            I fixed my problem by /etc/fr24feed.ini adding procargs="--gain -10"
                            this was suggested by someone in Germany who had similar problem and fixed his range, as it has fixed mine, now i'm back to normal, avg of 90nm all directions and out to 150nm northeast, though fr24 seems to think my max range is only 80nm, another service I feed reports 151nm, which matches my 150nm range plot

                            Comment


                            • #15
                              Hi, I reduced the gain to 37.2 and seems to be working normally.. or even better. Seems that wind direction affects receiving range in my position. South winds seems to improve my receiving distance.

                              Comment

                              Working...
                              X