Announcement

Collapse
No announcement yet.

MLAT Not Running

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • MLAT Not Running

    Hi there,

    Today I received my ADS-B dongle and ariel. Set up FR24 Feed on my Raspberry Pi. I have various challenges, including the IPv6 issue not allowing initial validation of my email address/location and the an error with DUMP1090 not working. I have, with the helpof this forum overcome all of these issues. I am now down to my last problem with MLAT. When I run sudo fr24feed-status I get the following:

    [ ok ] FR24 Feeder/Decoder Process: running.
    [ ok ] FR24 Stats Timestamp: 2018-09-15 07:41:34.
    [ ok ] FR24 Link: connected [UDP].
    [ ok ] FR24 Radar: T-YPPH91.
    [ ok ] FR24 Tracked AC:.
    [ ok ] Receiver: connected (0 MSGS/0 SYNC).
    [FAIL] FR24 MLAT: not running ... failed!

    I have stopped and started fr24feed and it occasionally works. But only brielfy when it does. I can use localhost and dump1090...gmap.html to view tracked aircraft when it does connect and occasionally it shows me online via the FR24 app on my iPad.

    What have I done/missing to get MLAT working? I am fairly new to the Raspberry Pi so it could be something obvious!

    Thank you in advance.

    Richard.

  • #2
    I believe I have solved this. I post this as it may help others as previous posts hinted at my solution in the end.

    I "logged" on to the DVBT Stick via the HTTP interface (IP of the Raspberry Pi:8754) and went to Settings.

    Setting Live setting
    Sharing key: Some letters and numbers!
    Receiver: dvbt
    Host/IP:
    COM/DEV/PATH:
    Process arguments: --net --net-http-port 8080
    Baudrate: Default
    RAW data (30002/30334): no
    SBS Feed (10001): no
    Decoded data (30003): yes
    Logfile mode: 1
    Log file location: /var/log/fr24feed
    Window mode: 0
    MLAT: yes

    I needed to add the process arguments and then everything "worked",,,,been up and running for about an hour now, aircraft come and go and all seems OK.

    Hope this may help others...

    Comment


    • #3
      The "Process arguments: --net --net-http-port 8080" has nothing to do with MLAT, or Tracked A/C or Uploded A/C.

      It is for the dump1090 map.
      Even for map, only "--net" is needed.
      You can then see map at

      IP of Pi/dump1090/gmap.html

      .

      Comment


      • #4
        Thanks for the input. Odd. Not sure how to respond other than that was the only change I made and then everything was ok. Perhaps it refreshed the dongle?

        Comment


        • #5
          After making and saving changes in setting, you restarted the fr24feeder by clicking Restart button. Seems restart solved your problem

          Comment


          • #6
            If you add your latitude and longitude to Process arguments, making it like this:
            (Replace xx.xxxx and yy.yyyy by your actual latitude and longitude in decimal)

            Process arguments: --net --lat xx.xxxx --lon yy.yyyy

            Clear browser cache and reload map.

            Your map will start showing a marker at your location, with 3 corcles at 100 nm, 160 nm, and 200 nm from receiver location

            Comment


            • #7
              Thanks for that. Will do.

              Comment

              Working...
              X