Announcement

Collapse
No announcement yet.

Raspbian Stretch: [FAIL] FR24 MLAT: not running ... failed!

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Raspbian Stretch: [FAIL] FR24 MLAT: not running ... failed!

    Hello,

    i have installed flightradar on my raspberry Pi with raspbian stretch. Unfortunately, I always get the following error message by the fr24feed-status command:

    Code:
    [FAIL] FR24 MLAT: not running ... failed!
    I have been trying to fix the problem for more than 2 days.

    Unfortunately without success. I use the official FR24 image! This should work out of the box in my opinion after registering the radar. But do not do it! I'll install Debian 8 "jessie" for a test to see if it works with it.

    IP.of.the.pi:8754 says:

    Code:
    FR24 Link:	Connected via UDP
    FR24 Radar Code:	
    Local IP(s):	192.168.178.20
    Aircraft Tracked:
    (ModeS & ADS-B)	0
    Aircraft Uploaded:	N/A
    Receiver:	dvbt, Connected
    MLAT running:	NO

  • #2
    Can you check if MLAT is enabled from settings?

    192.168.178.29:8754 -> Settings.
    --

    Comment


    • #3
      Yes it is! Can my Raspberry Pi Zero W be to blame? I hope not
      Last edited by StartedFromTheBottom; 2018-09-13, 18:57.

      Comment


      • #4
        You'll also need contacts active for it to enable I believe. You have 0 at present.

        Sent from my XT1092 using Tapatalk
        Posts not to be taken as official support representation - Just a helpful uploader who tinkers

        Comment


        • #5
          Originally posted by Oblivian View Post
          You'll also need contacts active for it to enable I believe. You have 0 at present.

          Sent from my XT1092 using Tapatalk
          Please describe in more detail what is meant

          Comment


          • #6
            Aircraft Tracked:

            (ModeS & ADS-B)0

            Aircraft Uploaded:N/A


            Vs mine and a working install

            Aircraft Tracked:
            (ModeS & ADS-B)16Aircraft Uploaded:12

            It can't calculate mlat if there are no planed received either.

            Sent from my XT1092 using Tapatalk
            Posts not to be taken as official support representation - Just a helpful uploader who tinkers

            Comment


            • #7
              Actually, a number of aircraft should have been tracked, but that did not happen. Blame is in my opinion MLAT because this is not working. The antenna is on the roof

              Comment


              • #8
                Err. Other way around.

                Mlat can only happen when there are a. contacts b. Correct configuration, c. Server responding as expected.

                It can't stop you receiving planes

                No planes, no way to calculate mlat.

                You may also need to apply the IPv6 patch to allow correct server name lookup

                But you appear to have a root cause for no data being captured.

                Sent from my XT1092 using Tapatalk
                Posts not to be taken as official support representation - Just a helpful uploader who tinkers

                Comment


                • #9
                  Ok, I have IPv6 now disabled.

                  Code:
                  sudo nano etc/sysctl.conf
                  And write into this conf
                  Code:
                  net.ipv6.conf.all.disable_ipv6 = 1
                  Attached my settings, maybe that helps

                  fr24-1.jpgfr24-2.jpg
                  Last edited by StartedFromTheBottom; 2018-09-13, 20:39.

                  Comment


                  • #10
                    For a start, you have enabled both --net AND told the software to force open the RAW out settings of 30002 + 30003.

                    That is what happens when you select them if using DVBT.. --net is added. So that's now twice. Look in your 2nd screenshot

                    https://forum.flightradar24.com/thre...ll=1#post74836

                    Process arguments
                    For devices that use Dump1090 (DVBT/AVR USB) that FR24feed launches - Process arguments field can be used
                    Eg: -- NET, --NET-HTTP-PORT, --NET-BEAST

                    RAW data Yes/No *note
                    Open server port 30334
                    - For Beast and other hardware
                    Open server port 30002
                    - For DVBT*

                    *Note = DO NOT USE IN CONJUNCTION WITH --NET DUMP1090 OPTIONS ENABLED!!
                    I suggest you make those changes and test. If still the same. Do the manual output checks to see what is erroring or why not being received

                    Stop the feeder, Run the commandline version in window without 'service'

                    https://forum.flightradar24.com/thre...ll=1#post74851
                    Posts not to be taken as official support representation - Just a helpful uploader who tinkers

                    Comment


                    • #11
                      I hope the settings now are right

                      fr24settings.jpg

                      Comment


                      • #12
                        Still does not work

                        Comment


                        • #13
                          What is the output of command:
                          fr24feed-status

                          What this page displays:
                          IP-of-Pi:8754

                          Comment


                          • #14
                            (1) Unplug and then Replug your dongle firmly into RPi, and reboot Pi.

                            (2) If you are using a USB cable to connect dongle to RPi, remove it and plug dongle directly into RPi.

                            (3) If above does not solve the problem, then check your dongle:
                            .
                            Is My DVB-T RTL SDR Dongle Healthy?

                            Go to OPTION-2: Dongle plugged into RPi
                            Last edited by abcd567; 2018-09-16, 20:42.

                            Comment


                            • #15
                              I've put it all over again, with the official image (!), The settings made as recommended and ... it still does not work! The strange thing is that the settings that I had in my second screenshot work for others! See https://intux.de/2016/12/flightradar/ (<- In German, sixth picture). I have to manually stop fr24-feed and dump1090 so that fr24-feed can access the dongle. The stick works, is connected via microUSB to USB-A with the Raspberry Pi Zero W. The Raspberry Pi 3 B and 3 B+ does not find the WLAN, the Zero W finds it and connects without problems

                              Maybe I'll try this again sometime

                              Comment

                              Working...
                              X