Announcement

Collapse
No announcement yet.

Feed showing offline

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Feed showing offline

    So my feed has been showing offline however it is not, I haven't changed a thing, dump1090 map works but I'm showing status offline .... am I missing something?

  • #2
    Hmmm a bit more information about your feeder station and configuration would help.

    When you log into your account, does the first "My Data Sharing" screen show your last upload as within the last 2 minutes or so ? When you go to your statistics screen, does the Daily Availability graph show you are connected ? and does the Hits and Positions Reported Graph show you are uploading data for the current day/UTC hour? Could be that you can see the dump1090 map locally but its not going anywhere.

    ylis

    Comment


    • #3
      Originally posted by ylis View Post
      Hmmm a bit more information about your feeder station and configuration would help.

      When you log into your account, does the first "My Data Sharing" screen show your last upload as within the last 2 minutes or so ? When you go to your statistics screen, does the Daily Availability graph show you are connected ? and does the Hits and Positions Reported Graph show you are uploading data for the current day/UTC hour? Could be that you can see the dump1090 map locally but its not going anywhere.
      No it is not within 2 minutes from what I remember.
      In the last few days I show:
      Tuesday out at 15:44 back at 17:20
      Wednesday out at 17:16
      Back on at 07:13 Thursday, and back out at 18:43
      Back on at 07:16 Friday and so far it's still online.
      I can see the map locally on Dump1090 but for some reason it's showing me offline when it should be online. I use the same connection for my weather station upload and that shows 100% online.
      I have not touched the Raspberry Pi at all except for a reboot Wednesday when it was showing offline more than 2 hours, which did not help show it back online.

      Comment


      • #4
        What is output of following command?

        fr24feed-status

        Comment


        • #5
          Currently it hasn't dropped back offline since it came back after I started this thread, I will be sure to check next time it drops offline.
          Right now it's working and showing this:

          ~ $ fr24feed-status
          [ ok ] FR24 Feeder/Decoder Process: running.
          [ ok ] FR24 Stats Timestamp: 2018-09-08 01:57:53.
          [ ok ] FR24 Link: connected [UDP].
          [ ok ] FR24 Radar: T-KHND9.
          [ ok ] FR24 Tracked AC: 38.
          [ ok ] Receiver: connected (8709860 MSGS/0 SYNC).
          [ ok ] FR24 MLAT: ok [UDP].
          [ ok ] FR24 MLAT AC seen: 33.

          Comment


          • #6
            71sbeetle

            The output of command fr24feed-status shows that your station is up and running and feeding data to FR24. Nothing wrong at your end. The FR24 server which compiles and displays stats is lagging.

            Just as double check, what following web page shows?

            IP-OF-PI:8754
            Last edited by abcd567; 2018-09-08, 02:27.

            Comment


            • #7
              Originally posted by abcd567 View Post
              71sbeetle

              The output of command fr24feed-status shows that your station is up and running and feeding data to FR24. Nothing wrong at your end. The FR24 server which compiles and displays stats is lagging.

              Just as double check, what following web page shows?

              IP-OF-PI:8754
              The 8754 page was showing an error message, something like cannot connect or cannot reach error. Right now it's working fine though

              Linux/generic/static_arm/1.0.19-15
              Updated: 02:23:59 GMT-0700 (Pacific Daylight Time)
              FR24 Link: Connected via UDP
              FR24 Radar Code: T-KHND9
              Local IP(s): 192.168.0.150
              Aircraft Tracked:
              (ModeS & ADS-B) 6
              Aircraft Uploaded: 3
              Receiver: beast-tcp, Connected
              MLAT running: YES
              Actions:
              Settings
              Restart software
              Terminate software
              Show tracked aircraft list

              Comment


              • #8
                If the local status page is not loading. FR24feed likely isn't working. And also will show offline

                Dump1090 can still work independantly of this. And given you are in TCP mode this almost confirms that setup.

                You'll need to watch either the logs, (enable them first) or the status command rather than rely on online stats pages.
                Posts not to be taken as official support representation - Just a helpful uploader who tinkers

                Comment


                • #9
                  Originally posted by Oblivian View Post
                  If the local status page is not loading. FR24feed likely isn't working. And also will show offline

                  Dump1090 can still work independantly of this. And given you are in TCP mode this almost confirms that setup.

                  You'll need to watch either the logs, (enable them first) or the status command rather than rely on online stats pages.
                  Thank you!
                  I have a couple of questions:
                  - What would be a possible reason for my FR24feed to stop working and then start working again on its own?
                  - How do I enable the logs, I have been trying to figure it out but ended up giving up trying.

                  If it helps, I used this guide to install/setup my station as I know absolutely nothing about coding lol
                  https://forum.flightradar24.com/thre...-15-dev-on-RPi

                  Comment


                  • #10
                    Originally posted by 71sbeetle View Post
                    Thank you!
                    I have a couple of questions:
                    - What would be a possible reason for my FR24feed to stop working and then start working again on its own?
                    - How do I enable the logs, I have been trying to figure it out but ended up giving up trying.

                    If it helps, I used this guide to install/setup my station as I know absolutely nothing about coding lol
                    https://forum.flightradar24.com/thre...-15-dev-on-RPi
                    If you can still get the FR24 status webpage select "settings" and choose from the dropdown options for "Logfile mode"
                    Then click "save" followed by "restart"

                    Comment


                    • #11
                      Originally posted by jackthom View Post
                      If you can still get the FR24 status webpage select "settings" and choose from the dropdown options for "Logfile mode"
                      Then click "save" followed by "restart"
                      Perfect, I did that. What do I enter for logfile location? Or do I leave it blank? Also, how do I see the logfile? Thank you for the help!

                      Comment


                      • #12
                        Nevermind found the following:

                        Originally posted by abcd567 View Post
                        1. The settings seem OK for feeding data to FR24.
                          The problem may be in connection to FR24. You have to enable log to find problems.
                          First change
                          "Logfile Mode" to "keep upto 48 hrs..."
                          "Log file location" to /var/log/
                          After making changes, click "Save" and "Restart" buttons at bottom-right of settings page.

                          Wait for 10 minutes for log to build-up, then SSH to Pi, and give following command to check the log:
                          Code:
                          cat /var/log/fr24feed.log
                        2. If "process arguments" is blank, you wont see a map with planes at ip-of-pi:8080 (try it).
                          Add --net in the process argument, and you will see the map at ip-of-pi:8080 (try it after adding --net)
                          NOTE: After adding --net, click "Save" and "Restart" buttons at bottom-right of settings page.

                        3. "RAW data" is "YES", "Decoded Data" is "YES" is not required. better change these to NO

                        Comment


                        • #13
                          It's down right now.
                          8754 page:
                          This site can’t be reached
                          192.168.0.150 refused to connect.
                          Search Google for 192 168 150 8754 index
                          ERR_CONNECTION_REFUSED

                          fr24feed-status
                          [FAIL] FR24 Feeder/Decoder Process ... failed!

                          hmmmm ...... what could that be?

                          Comment


                          • #14
                            And the output from the log you just enabled is....

                            Sent from my XT1092 using Tapatalk
                            Posts not to be taken as official support representation - Just a helpful uploader who tinkers

                            Comment


                            • #15
                              Originally posted by Oblivian View Post
                              And the output from the log you just enabled is....

                              Sent from my XT1092 using Tapatalk
                              cat /var/log/fr24feed.log
                              cat: /var/log/fr24feed.log: No such file or directory

                              Comment

                              Working...
                              X