Announcement

Collapse
No announcement yet.

Pi24 Fails on startup.

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Pi24 Fails on startup.

    I just bought the Pi 3 B+ and followed the instructions to the T from flightradar24's webpage. I wrote the iso to the sd card and placed it in the Pi then plugged in the receiver, ethernet cable and micro usb power cable. The red light comes on for a second then goes off. The green light comes on then starts randomly flashing. The lights on the ethernet port fail to turn on and the light on the receiver fail to operate as well. At first I thought this was just a corrupted iso file so I reformatted the SD card (FAT32) and re-downloaded Pi24 and followed the same instructions with the same result. I then thought maybe the Pi is damaged somehow. I reformatted the SD card again and this time installed the raspberry pi software Raspbian and everything now seems to work so I know the Pi is fine and that it seems to be the Pi24 OS. I also tried plugging in the HDMI cable when I tried the Pi24 OS and not knowing if its suppose to show anything or not and I got a multi colored screen that was blank.

    I am doing all of this thru my MAC. Any suggestions on why the Pi24 OS isnt working for me??

    Thanks everyone!
    Last edited by wx4tcc; 2018-09-02, 17:56.

  • #2
    https://forum.flightradar24.com/showthread.php?p=107044

    https://forum.flightradar24.com/thre...e-Requirements

    Sent from my XT1092 using Tapatalk
    Last edited by Oblivian; 2018-09-02, 19:34.
    Posts not to be taken as official support representation - Just a helpful uploader who tinkers

    Comment


    • #3
      I have installed FR24 on Raspbian and so far and connected the internet and dongle. I tried checking the status of FR24 by typing in
      sudo fr24feed-status which returned "FR24 Feeder/Decoder Process...failed!"

      Comment


      • #4
        I have uninstalled fr24 and am currently installing dump1090-mutability_1.15~dev manually then will reinstall fr24.

        Comment


        • #5
          Remember dont select 'dvbt' in fr24feed.


          And may need to apply IPv6 fixes

          Sent from my XT1092 using Tapatalk
          Posts not to be taken as official support representation - Just a helpful uploader who tinkers

          Comment


          • #6
            I am on step 8 section D and when I type in the following command
            Code:
            sudo /etc/init.d/dump1090-mutability restart
            the response is "command not found"

            Comment


            • #7
              I wasnt able to find a command to restart dump1090 but loaded the webpage anyway and it worked just fine with data flowing. Before I added fr24 I wanted to make sure everything was still working after a fresh restart of Pi and now when I load the webpage back up i get an AJAX call failed error not found message. I have tried the one step solution and it also gives me command not found and i have tried the blacklist solution and says it cant open file to write when i try to save.

              EDIT: looks like this is related to a permission denied type event. I tried creating the rules file manually and adding the file to the folder using the file manager and was rejected due to permissions.
              Last edited by wx4tcc; 2018-09-02, 22:56.

              Comment


              • #8
                You need to run all commands as SUDO

                Including edit/moves and so on. If you are using the GUI for filemanager, not sure. As generally its too much demand on the device so GUI isnt used
                Posts not to be taken as official support representation - Just a helpful uploader who tinkers

                Comment


                • #9
                  Few days ago I faced permissions issue. Any file I wanted to edit, a notice was shown "the file system is read only".

                  Rebooting Pi resolved it.
                  Last edited by abcd567; 2018-09-03, 00:34.

                  Comment


                  • #10
                    I was not able to resolve the issue on the Pi but I was able to get around it by shutting down the Pi and placing the SD card in my MAC and creating the file on my own and placing in the correct folder and restart Pi. It worked and so far I have gotten FR24 and dump1090 working....until now when I restarted the Pi since this would be the first restart after both systems were working and I see that dump1090 starts automatically but I am getting the following error on the status page of fr24feed...

                    BOTH should start on boot-up, correct? and yes I did have to disable ipv6.

                    FR24 Link: Disconnected (connection error)
                    FR24 Radar Code: N/A
                    Local IP(s): 192.168.0.13 2600:8803:a200:4fb0:50ce:5ed7:3405:67cb
                    Aircraft Tracked:
                    (ModeS & ADS-B) 14
                    Aircraft Uploaded: N/A
                    Receiver: avr-tcp, Connected
                    MLAT running: NO



                    EDIT:: After re-running the command to disable ipv6 and running the fr24feed restart command its working....is there a way to permanently disable ipv6??
                    Last edited by wx4tcc; 2018-09-03, 00:58.

                    Comment


                    • #11
                      Fix #1
                      As a temporary measure, FR24 admin suggested to block IPv6 by giving this command

                      Code:
                      sudo sysctl -w net.ipv6.conf.all.disable_ipv6=1
                      However this command is to be re-issued at every reboot of Pi.

                      .
                      Fix #2
                      A FR24 forum member JohnnyBravo gave a better solution. Instead of totally blocking IPv6, he suggested following method to change preference to IPv4.

                      It has advantage that it is not lost on reboot. I have tested it, and it works fine. Here is this method:


                      Code:
                      sudo nano /etc/gai.conf
                      In this file scroll down to find following line:

                      #precedence ::ffff:0:0/96 100

                      Uncomment this line so it looks like:

                      precedence ::ffff:0:0/96 100

                      Save file. Now Pi will prefer IPv4

                      Reboot Pi

                      Code:
                      sudo reboot
                      Last edited by abcd567; 2018-09-03, 01:24.

                      Comment


                      • #12
                        That worked, thanks!

                        Comment


                        • #13
                          Originally posted by wx4tcc View Post
                          That worked, thanks!
                          Glad to know it works now.

                          As regards to your permissions problem, did it get resolved by rebooting the Pi?

                          If not, then run following command to see if you have any issues related to the filesystem / journaling system itself.
                          Code:
                          dmesg | grep "EXT4-fs error"
                          To see what is status
                          Code:
                          dmesg | grep "EXT4-fs"
                          
                          
                          #Above command gave following output on my Raspbian Stretch
                          
                          [    2.353718] EXT4-fs (mmcblk0p2): mounted filesystem with ordered data mode. Opts: (null)
                          [    5.726176] EXT4-fs (mmcblk0p2): re-mounted. Opts: (null)
                          To list your drives/partitions
                          Code:
                          lsblk
                          
                          #Above command gave following output on my Raspbian Stretch
                          
                          NAME      MAJ:MIN RM  SIZE RO TYPE MOUNTPOINT
                          mmcblk0   179:0    0  7.4G  0 disk
                          ├─mmcblk0p1
                          │         179:1    0 43.2M  0 part /boot└─mmcblk0p2
                                    179:2    0  7.4G  0 part /
                          Last edited by abcd567; 2018-09-03, 04:15.

                          Comment


                          • #14
                            I discovered I never logged in as the root user so I logged out and logged in with the default username and password tho I currently dont have anything I need to fix or add to see if I have root access.

                            Does dump1090 happen to also decode data from 978mhz? Of course after I bought my parts I see there is a Stratux dual band receiver and wonder if I should swap. Thankfully these arent expensive.

                            I purchases the NooElec NESDR Mini 2+ 0.5PPM TCXO RTL-SDR & ADS-B USB Receiver but I cant tell if it picks up 978mhz transmissions.

                            Comment


                            • #15
                              Originally posted by wx4tcc View Post
                              I discovered I never logged in as the root user so I logged out and logged in with the default username and password tho I currently dont have anything I need to fix or add to see if I have root access.
                              If you login as default user pi, then this user already has sudo powers, and will do most of the jobs needed like editing, deleting, creating, copying and moving files and folders, as well as changing file and folder permissions. The only thing you have to do is to start commands with word sudo.


                              Originally posted by wx4tcc View Post
                              Does dump1090 happen to also decode data from 978mhz? Of course after I bought my parts I see there is a Stratux dual band receiver and wonder if I should swap. Thankfully these arent expensive.

                              I purchases the NooElec NESDR Mini 2+ 0.5PPM TCXO RTL-SDR & ADS-B USB Receiver but I cant tell if it picks up 978mhz transmissions.
                              The dump1090 picks and decodes only 1090 mhz signals. To pick and decode 978 mhz signals, you need dump978.

                              Please see this thread for installing dump978. This method can install dump1090, dump978, FR24 feeder, Flightsware feeder, Planefinder feeder and Web Portal/Performance Graphs. As you already have everything you need, say NO to all options, and say OK to dump978 only.

                              Automated Installation of Dump1090-Mutability, Data Feeders, and Performance Graphs

                              NOTE:
                              (1) To run dump1090+dump978 on same Pi, you will need two dongles, one for dump1090 other for dump978.

                              (2) The Nooelec bundle for Stratux has 2 dongles, one serialized and marked for 1090 and other serialized and marked for 978.

                              (3) If you use any other dongle, these have all same serial number by default. In this case you will need to serialize the two dongles yourself, so that ech dump uses only the dongle+antenna assigned to it. Please see following post for how to serialize:


                              Is My DVB-T RTL SDR Dongle Healthy? >> Post #3: How to Change Serial Number of Dongle
                              Last edited by abcd567; 2018-09-03, 17:17.

                              Comment

                              Working...
                              X