Announcement

Collapse
No announcement yet.

Beginner: feed both FR24 und FA with Raspberry Pi 3 Model B+, FlightAware Pro Stick+

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Beginner: feed both FR24 und FA with Raspberry Pi 3 Model B+, FlightAware Pro Stick+

    I am new to Raspberry, Linux and ADS-B, but I know much about IT, programming etc., so I hope you can speak to me in IT-language most of the time. :-)

    I have:

    - Raspberry Pi 3 Model B+ with Wifi and original poweradapter
    - FlightAware Pro Stick Plus (newest edition)
    - FlightAware 1090MHz ADS-B N-Type Antenne 5.5dBi
    - Bluetooth keyboard and mouse
    - working WLan

    First I tried it with a guide for Flightaware (piaware 3.5.3 & Co). It worked, so I have no hardwareproblem. But I was not able to find a solution to add flightradar24.

    I found another guide from 2017, how to install both with dump1090-mutability v1.15. So I deleted the SD-card, put a new image from Raspbian to the SD-card and installed the compontens as mentioned.
    Before I installed the components for FA and FR24, I tested by putting in a browser the IP, subfolder "dump1090" subfolder "gmap" with extension "html" (I am not allowed to post links here).
    The card was drawn, but I got the error-message

    "Problem fetching data from dump1090.
    AJAX call failed (timeout: timeout). Maybe dump1090 is no longer running?
    The displayed map data will be out of date."

    So even the base-installation does not work.

    Has it to do with my Raspberry or the stick to new?

    I don't think so, because the first installation with piaware worked.
    Of course I did a reboot and checked if dump1090 was running.

    Does someone has a guide how to do the above in a working way? :-)

    I would like to do it before I put the antenna to the roof. :-)

  • #2
    Originally posted by mibock View Post
    I don't think so, because the first installation with piaware worked.
    Of course I did a reboot and checked if dump1090 was running.

    Does someone has a guide how to do the above in a working way? :-)
    There are various ways to feed multiple sites.

    The easiest for a new person is your original one: Piaware SD card image + FR24 feeder install by bash script.
    I will detail it for you
    1. First download Piaware SD Card image and write it to your microSD card using etcher or win32diskimager.
      Instruction page: https://flightaware.com/adsb/piaware/build
      Download link for Piaware image: http://piaware.flightcdn.com/piaware...-3.5.3.img.zip

    2. After writing the Piaware image to microSD card, and while your card is still in card reader of your Desktop/Laptop, click open the its drive (it will show as "piaware"). When it opens, in it right click and creat a new text file named either ssh or ssh.txt. This will enable you to connect to your Pi from your Desktop/Laptop using SSH software like PuTTY.

    3. Plug your ProStick to RPi

    4. Keep your antenna near a window or outer wall and connect it to the ProStick

    5. Power up RPi and check that the dongle is working by two methods
      (a) In RPi's browser, check Map at localhost/dump1090-fa/
      (b) open Pi's terminal console (or ssh using PuTTY) and give following commands:
      Code:
      sudo systemctl status dump1090-fa
      sudo systemctl status piaware
      cat /var/log/piaware.log
    6. If all is working OK, install FR24 feeder by following command in terminal console (or ssh using PuTTY)
      Code:
      sudo bash -c "$(wget -O - https://repo-feed.flightradar24.com/install_fr24_rpi.sh)"
    7. Now comes the most important step: Configuring fr24feed. NEVER SELECT RECEIVER = DVB-T.
      If you make a mistake of selecting Receiver DVB-T in FR24 settings, it will install dump1090-mutability v1.14, which will conflict with Flightaware's dump1090-fa and system will fail.

      Select as follows

      At the end of fr24feed install when signing up starts, choose values shown in red

      Code:
      Step 4.1 - Receiver selection (in order to run MLAT please use DVB-T stick with dump1090 utility bundled with fr24feed):
      
       1 - DVBT Stick (USB)
       -----------------------------------------------------
       2 - SBS1/SBS1er (USB/Network)
       3 - SBS3 (USB/Network)
       4 - ModeS Beast (USB/Network)
       5 - AVR Compatible (DVBT over network, etc)
       6 - microADSB (USB/Network)
       7 - SBSx via Basestation (localhost:30006)
      
      
      Enter your receiver type (1-7)$: 4
      
      Step 4.2 - Please select connection type:
      
       1 - Network connection
       2 - USB directly to this computer
      
      Enter your connection type (1-2)$: 1
      
      Step 4.3A - Please enter your receiver's IP address/hostname
      $: 127.0.0.1
      
      Step 4.3B - Please enter your receiver's data port number
      $: 30005
      
      Step 5.1 - Would you like to enable RAW data feed on port 30334 (yes/no)$: no
      
      Step 5.2 - Would you like to enable Basestation data feed on port 30003 (yes/no)$: no

      If you make settings using browser (IP-of-PI:8754/settings.html) choose following
      "Receiver: ModeS Beast (TCP)"
      "HOST/IP: 127.0.0.1:30005"

      See screenshot below.
      FR24 Settings with dump1090-fa or mut for multiple feed by Pi.png

    Comment


    • #3
      Thank you for your guide. :-)

      "[*]First download Piaware SD Card image and write it to your microSD card using etcher or win32diskimager."

      I get the rainbow-screen with voltage-symbol. In another thread it is explanied that the software(image) is too old for the hardware. Surely it is not that I use an bad poweradapter. :-)

      I now try to install the piaware it first run with and then try to use your guide from that point.

      Yours, Michael

      Comment


      • #4
        The first install (I think and hope) was not with piaware (as I wrote before), it was with RaspBian-stretch and putting piware after that. Hopefully I find a way. The red light blinks with 4 long and 4 short.

        Comment


        • #5
          The red light flashing is either due to:

          (1) Power issue
          OR
          (2) Wrong/outdated Operating System Image

          Piaware 3.5.3 SD Card image is not compatible with RPi 3B+
          Please see screenshot below from Flightaware page:

          RPi 3 B+ Piaware SD card image not supported.png


          Please do following:
          1. Download and write to your microSD card, the latest version of Raspbian image:
            Raspbian Stretch Lite
            Release date: 2018-06-27

            Download page: https://www.raspberrypi.org/downloads/raspbian/

            Direct download link: https://downloads.raspberrypi.org/raspbian_lite_latest

          2. Go to this page and install PiAware feeder and dump1090-fa
            https://flightaware.com/adsb/piaware/install

          3. Check if all is working OK, and you can see SkyView map at IP-OF-PI/dump1090-fa/
            Also check status
            Code:
            sudo systemctl status dump1090-fa -l  
            sudo systemctl status piaware -l
          4. Install FR24 feeder by bash script
            Code:
            sudo bash -c "$(wget -O - https://repo-feed.flightradar24.com/install_fr24_rpi.sh)"
          5. Near the end of fr24feed installation, a signup and configuration will start. DO NOT SELECT RECEIVER DVBT. See my post above for configuration details.


          DO NOT SELECT RECEIVER DVBT

          DO NOT SELECT RECEIVER DVBT

          DO NOT SELECT RECEIVER DVBT
          Last edited by abcd567; 2018-07-01, 17:42.

          Comment


          • #6
            DO NOT SELECT RECEIVER DVBT

            Can you explain why not the normal DVBT? :-)

            I will try it the next days, I hope. Thank you for all the guides and hints!

            Yours, Michael

            Comment


            • #7
              Originally posted by mibock View Post
              DO NOT SELECT RECEIVER DVBT
              Can you explain why not the normal DVBT? :-)
              If you select Receiver DVBT in FR24 settings, fr24feed will automatically install dump1090-mutability v1.14.
              This is OK if you have not already installed any other version of dump1090.

              If you have already installed any other version of dump1090, this will result in following mess:
              • If you have already installed dump1090-mutability v1.15~dev, it will be downgraded to v1.14.
              • If you have already installed dump1090-fa, these two dumps (fa and mut v1.14) will conflict and system will fail.

              Comment


              • #8
                Install error

                Hello,

                I have the same system as the OP. RPi 3 B+, successfully configured to feed Flightaware. I run my Pi over a wired connection.

                I have followed both the install script on the FR24 website, and the instructions in this thread. But I get an error after Step 6B:

                Code:
                Step 6B - Please enter desired logfile path (/var/log/fr24feed):
                $:/var/log/fr24feed
                
                Submitting form data...ERROR
                
                Could not insert new feed into database, please contact service support!
                E2:DELETE command denied to user 'update_rw'@'10.1.20.12' for table 'feeds'
                
                Would you like to try again?
                
                Saving settings to /etc/fr24feed.ini...OK
                Installation and configuration completed!
                Is there something I'm doing wrong, or perhaps something I need to do beforehand?

                Thanks for all help in advance.

                Comment


                • #9
                  Originally posted by callaghn View Post
                  Hello,

                  I have the same system as the OP. RPi 3 B+, successfully configured to feed Flightaware. I run my Pi over a wired connection.

                  I have followed both the install script on the FR24 website, and the instructions in this thread. But I get an error after Step 6B:

                  Code:
                  Step 6B - Please enter desired logfile path (/var/log/fr24feed):
                  $:/var/log/fr24feed
                  
                  Submitting form data...ERROR
                  
                  Could not insert new feed into database, please contact service support!
                  E2:DELETE command denied to user 'update_rw'@'10.1.20.12' for table 'feeds'
                  
                  Would you like to try again?
                  
                  Saving settings to /etc/fr24feed.ini...OK
                  Installation and configuration completed!
                  Is there something I'm doing wrong, or perhaps something I need to do beforehand?

                  Thanks for all help in advance.
                  Server Side issue likely. Should reach support via email as it suggests
                  Posts not to be taken as official support representation - Just a helpful uploader who tinkers

                  Comment


                  • #10
                    I have a Raspberry PI 3 Model B+ - I tried to load a fresh FR24 image BUT I get 5 short then 3 long flashes of the green light with the red led off. Increasing the voltage from 5 to 5.2 volts (measured at the card) makes no difference. The checksum of the downloaded image was perfect. Loading a fresh image onto an older PI works fine - (a doulble check that the Downloaded image is good). THe only way I could get the 3 B+ to work was load Raspian then the 'sudo bash -c "$(wget -O - ' etc etc then after inputing email and key etc, using ' sudo systemctl restart fr24feed' - everything is running - Radar ID T-EGVF40 - Thus the Image downloaded is good, the Pi is good, my ability to follow instructions is good, BUT the fr24-raspberry-pi-latest.img and the new RPI Model 3 B+ are incompatible - in my opinion. - I'm not really interested in watching what the system can see, just feeding data with MLAT information, But I would like to know if VF40 is feeding mlat data to the system.
                    Last edited by mem0tap; 2018-07-08, 19:26. Reason: omission of important information.

                    Comment


                    • #11
                      Originally posted by mem0tap View Post
                      .....BUT the fr24-raspberry-pi-latest.img and the new RPI Model 3 B+ are incompatible - in my opinion.
                      The FlightRadar24's Pi24 image and FlightAware's Piaware image are both not (yet) compatible to RPI 3 B+
                      You have done the right thing: Install Raspbian Stretch, then install the FR24 feeder by bash script.


                      Originally posted by mem0tap View Post
                      .....But I would like to know if VF40 is feeding mlat data to the system.
                      Try this command
                      Code:
                      fr24feed-status

                      If all is well, it will give output similar to what I got below.
                      The last line shows that MLAT is working OK for my receiver.
                      Code:
                      pi@raspberrypi:~ $ fr24feed-status
                      [ ok ] FR24 Feeder/Decoder Process: running.
                      [ ok ] FR24 Stats Timestamp: 2018-07-08 20:49:39.
                      [ ok ] FR24 Link: connected [UDP].
                      [ ok ] FR24 Radar: T-CYYZ9.
                      [ ok ] FR24 Tracked AC: 74.
                      [ ok ] Receiver: connected (17252594 MSGS/0 SYNC).
                      [ ok ] FR24 MLAT: ok [UDP].
                      [ ok ] FR24 MLAT AC seen: 73.

                      Comment


                      • #12
                        Thankyou, yes everything is looking good, Nice to be working with UNix again after a 35 year break!

                        Comment


                        • #13
                          Thank you very much for your help. The Flightaware-antenna is on the roof and I now feed as T-EDDH218 to Flightradar.

                          @abcd567: the moment I asked why not DVBT it was allready too late. :-) But I did not install anything before, so it seems to work.

                          To the north I can see 300km (141NM), to the south about 150 km. The antenna is 20m above sealevel and can see in all directions. Maybe the high trees to the south and west in about 100m distance block a bit of the sky.

                          But I seem to have this doughnut-effect I have read somewhere: I do not see the airplanes I can "touch by hand" and even can see landing and starting through my base-floor-window.

                          It seems I have to fine-tune something. Any ideas?

                          I have (initial post):

                          - Raspberry Pi 3 Model B+ with Wifi and original poweradapter
                          - FlightAware Pro Stick Plus (newest edition)
                          - FlightAware 1090MHz ADS-B N-Type Antenne 5.5dBi (seeing in all directions from the roof 20m above sealevel.
                          - Bluetooth keyboard and mouse
                          - working WLan

                          Yours, Michael

                          In this picture you see my place (arrow) and the area where I do not get a signal.
                          Anflug.jpg

                          Comment


                          • #14
                            @ signs. AGAIN
                            Posts not to be taken as official support representation - Just a helpful uploader who tinkers

                            Comment


                            • #15
                              @Oblivian: I don't understand your answer. I hope it was not kind of rolling your eyes, because as a beginner it creates frustration. I also have searched the forum about it, but in my case I do not understand it.

                              The planes pass about 500 metres to the north my place with clear sight. If they are landing they have an angle of about 35-40 degress to the ground, so they are already in low heigth. So they are not above me, but should be in this circle around my antenna.

                              If I compare it to another plain flying east from me in about 6km distance and a heigth of 36000 feet (12km) then the angle is much more worse for my antenna, but most of the time I can see the plane (black line to the right of the screenshot).

                              I just want to understand what I can do or not (gain etc.).

                              Ueberflug_.jpg

                              Comment

                              Working...
                              X