Announcement

Collapse
No announcement yet.

Problem installing on Raspberry Pi 3 b+

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • #16
    Originally posted by abcd567 View Post
    @cmgam
    The fr24feed auto-starts at boot. You dont have to do any thing.
    Hi
    Thanks.

    cmg

    Comment


    • #17
      Hi
      My FR24 on a rasp. pi, after a long period of working ok, has an error:" fr24 Link: unknown... faillled".
      Why and what to do.
      Thanks in advance
      Regards

      cmg

      Comment


      • #18
        Originally posted by cmgam View Post
        Hi
        My FR24 on a rasp. pi, after a long period of working ok, has an error:" fr24 Link: unknown... faillled".
        Why and what to do.
        Thanks in advance
        Regards

        cmg
        This seems to be caused by bug in FR24 feeder which causes its failure to connect to FR24 server if it tries IPv6 address. This is totally due to some bug in their servers. I am not sure if it is solved or still there.

        If you face an error message of failure to connect, try any one of the 2 bug-fixes given below:


        Fix #1
        As a temporary measure, FR24 admin suggested to block IPv6 by giving this command

        Code:
        sudo sysctl -w net.ipv6.conf.all.disable_ipv6=1
        However this command is to be re-issued after every reboot of the Pi.



        Fix #2
        A FR24 forum member gave a better solution. Instead of totally blocking IPv6, he suggested following method to change preference to IPv4. I have tested it, and it works fine. Here is this method:

        Code:
        sudo nano /etc/gai.conf
        In this file scroll down to find following line:

        #precedence ::ffff:0:0/96 100

        Uncomment this line so it looks like:

        precedence ::ffff:0:0/96 100

        Now Pi will prefer IPv4

        Save file (Ctrl+o) and close file (Ctrl+x)

        Restart fr24feed

        Code:
        sudo systemctl restart fr24feed
        Last edited by abcd567; 2018-08-18, 20:25.

        Comment


        • #19
          Originally posted by abcd567 View Post
          This seems to be caused by bug in FR24 feeder which causes its failure to connect to FR24 server if it tries IPv6 address. This is totally due to some bug in their servers. I am not sure if it is solved or still there.

          If you face an error message of failure to connect, try any one of the 2 bug-fixes given below:


          Fix #1
          As a temporary measure, FR24 admin suggested to block IPv6 by giving this command

          Code:
          sudo sysctl -w net.ipv6.conf.all.disable_ipv6=1
          However this command is to be re-issued after every reboot of the Pi.



          Fix #2
          A FR24 forum member gave a better solution. Instead of totally blocking IPv6, he suggested following method to change preference to IPv4. I have tested it, and it works fine. Here is this method:

          Code:
          sudo nano /etc/gai.conf
          In this file scroll down to find following line:

          #precedence ::ffff:0:0/96 100

          Uncomment this line so it looks like:

          precedence ::ffff:0:0/96 100

          Now Pi will prefer IPv4

          Save file (Ctrl+o) and close file (Ctrl+x)

          Restart fr24feed

          Code:
          sudo systemctl restart fr24feed
          Hi
          After to edit the indicated file, everything is fine (so far).
          Thanks
          Regards

          cmg

          Comment


          • #20
            [crossposting also in this Raspi-related thread, as IMHO I have a better solution to the IPv6 connection issue]

            FYI, I too have run into connection issues, which might be related to IPv6, which is strange as I have a full IPv6-enabled network at home, and the connection would work the same via IPv4 or IPv6. Go figure.

            Nonetheless, it was clear that the issue was related to IPv6 when I decided to create a simple hack which would force IPv4-only connections, of a very different kind than blocking completely IPv6 (which I DON'T want to do!) and neither changing the configuration of the getaddrinfo config file /etc/gai.conf.

            The hack consists of fixing the IP address of the initial connection to feed.flightradar24.com and its CloudFlare counterpart to a fixed IPv4 address, which will take precedence over a DNS-resolved IP address.

            Here is what I added in /etc/hosts:

            # hack to fix the IPv6 issue with feed.flightradar24.com.cdn.cloudflare.net (104.20.0.101) - solved on 2018-08-25

            104.20.0.101 feed.flightradar24.com
            104.20.0.101 feed.flightradar24.com.cdn.cloudflare.net


            Obviously I now have a fixed IP address and not a dynamic one out of a pool, and if FR24 someday decides to change the IP address of the feed, I will need to modify it by hand.

            By doing this I was able to make my newly refreshed RasPi 3, which used to run Jessie and now runs Stretch, work again after the dist-upgrade which crippled fr24feed.

            Bye, Luca

            Comment


            • #21
              One of my feeders has a similar problem, after about 20 hours fr24feed loses connection to the network. All other services runs fine.

              I have tried the gai.conf ipV6 fix to see if that helps.

              2018-09-04 12:03:42 | [time][i]Synchronizing time via NTP
              2018-09-04 12:03:42 | [time][e]Failed to synchronize time
              2018-09-04 12:03:44 | [feed][i]Downloading configuration
              2018-09-04 12:03:44 | [e]Socket is not valid, errno: 24
              2018-09-04 12:03:44 | ERROR
              2018-09-04 12:03:44 | [e]Could not retrieve configuration from Flightradar24
              2018-09-04 12:03:44 | [feed][i]Failed, Sleeping 30 seconds
              2018-09-04 12:03:44 | [time][i]Synchronizing time via NTP


              /M
              F-ESDF1, F-ESGG1, F-ESGP1, F-ESNK1, F-ESNV2, F-ESNV3 F-ESSL4, F-LFMN3
              P-ESGR, P-ESIA, P-ESIB, P-ESGF
              mrmac (a) fastest.cc

              Comment

              Working...
              X