Announcement

Collapse
No announcement yet.

Raspberry Pi running but not feeding

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Raspberry Pi running but not feeding

    I am trying to feed with a Raspberry Pi and DVT stick, which has been working for about the last two years.

    It stopped feeding about a month ago and I came to the conclusion that the memory card had failed so I fitted a new sd card and re-installed everything. Now the system appears to be running, but it is not feeding FR24.

    I should point out that I don't fully understand what I am doing with a Pi, but having read and followed some of the posts on this forum I managed to get it running. It is running, but according to FR24, I am not online. I ran the fr24feed-status command and the following messages came up:
    OK. FR24 Feeder/decoder process running
    OK. FR24 Stats timestamp: time and date
    OK. FR24 Link: connected (TCP).
    OK. FR24 Radar: T-EGGP12 (my radar ID)
    OK. FR24 tracked AC.
    FAIL Receiver: down...failed!
    FAIL FR24 MLAT: not running ... failed!

    Can anybody tell me what I need to do to breath life back into my feed please?

  • #2
    +1 on this problem. But I seem to be online but the pi doesn't scan for planes, not even locally. Eventually it shuts down do that just the red and green led is on with a steady shine.

    Comment


    • #3
      Originally posted by AMdinSTratus View Post
      +1 on this problem. But I seem to be online but the pi doesn't scan for planes, not even locally. Eventually it shuts down do that just the red and green led is on with a steady shine.
      Is your Dongle Healthy?
      I test my Dongle this way:
      Code:
      sudo apt-get update
      sudo apt-get install rtl-sdr
      sudo systemctl stop dump1090-mutability
      
      rtl_test -t
      If Dongle is healthy, the command rtl-test -t gives following output:
      Code:
      Found 1 device(s):
        0:  Realtek, RTL2832U, SN: 00000001
      
      Using device 0: Generic RTL2832U
      Found Rafael Micro R820T tuner
      Supported gain values (29): 0.0 0.9 1.4 2.7 3.7 7.7 8.7 12.5 14.4 15.7 16.6 19.7 20.7 22.9 25.4 28.0 29.7 32.8 33.8 36.4 37.2 38.6 40.2 42.1 43.4 43.9 44.5 48.0 49.6
      [R82XX] PLL not locked!
      Sampling at 2048000 S/s.
      No E4000 tuner found, aborting.

      Comment


      • #4
        If Dongle is healthy, the command rtl-test -t gives following output:
        Code:
        Found 1 device(s):
          0:  Realtek, RTL2832U, SN: 00000001
        
        Using device 0: Generic RTL2832U
        Found Rafael Micro R820T tuner
        Supported gain values (29): 0.0 0.9 1.4 2.7 3.7 7.7 8.7 12.5 14.4 15.7 16.6 19.7 20.7 22.9 25.4 28.0 29.7 32.8 33.8 36.4 37.2 38.6 40.2 42.1 43.4 43.9 44.5 48.0 49.6
        [R82XX] PLL not locked!
        Sampling at 2048000 S/s.
        No E4000 tuner found, aborting.
        [/QUOTE]




        That is what I get too, but it still isn't working
        Last edited by savideo; 2018-02-10, 13:01.

        Comment


        • #5
          I am not sure if it is relevant, but when I ran the command "sudo systemctl stop dump1090-mutability" the response was:
          Failed to stop dump1090-mutability.service: Unit dump1090-mutability.service not loaded.

          I have seen the error message before that dump1090 is not present. Is this a problem?

          Comment


          • #6
            @savideo

            Give this command and post output

            apt-cache policy fr24feed

            Comment


            • #7
              Hi

              I am having the same problem. I have been running fr24 on my raspbery pi for last 2 years and then it stopped working couple weeks ago. Today I did a brand new install of Raspbian and then ran sudo bash -c "$(wget -O - URL /install_fr24_rpi.sh)"

              When I run fr24feed-status I get:

              [ ok ] FR24 Feeder/Decoder Process: running.
              [ ok ] FR24 Stats Timestamp: 2018-02-10 20:14:20.
              [ ok ] FR24 Link: connected [UDP].
              [ ok ] FR24 Radar: T-KAFF1.
              [ ok ] FR24 Tracked AC:.
              [FAIL] Receiver: down ... failed!
              [FAIL] FR24 MLAT: not running ... failed!

              When I open my ip:8754 I get:


              FR24 Link: Connected via UDP
              FR24 Radar Code: T-KAFF1
              Local IP(s): 192.168.1.167
              Aircraft Tracked:
              (ModeS & ADS-B) 0
              Aircraft Uploaded: N/A
              Receiver: dvbt, Connected
              MLAT running: NO


              When I log in to f24 website I am showing status OFFLINE


              Running apt-cache policy fr24feed returns:

              fr24feed:
              Installed: 1.0.19-15
              Candidate: 1.0.19-15
              Version table:
              *** 1.0.19-15 500
              500 URL flightradar24/raspberrypi-stable armhf Packages
              100 /var/lib/dpkg/status

              Thanks!

              Comment


              • #8
                @gulo

                Reboot the Pi, wait for 10 minutes, and then check to see if this has fixed your problem.

                If the problem still persists, and you have written Raspbian STRETCH, then try this workaround:

                https://forum.flightradar24.com/thre...ll=1#post96279

                Code:
                sudo wget -O  /etc/udev/rules.d/rtl-sdr.rules "https://raw.githubusercontent.com/osmocom/rtl-sdr/master/rtl-sdr.rules"
                
                sudo reboot
                Last edited by abcd567; 2018-02-10, 21:10.

                Comment


                • #9
                  Originally posted by abcd567 View Post
                  @gulo

                  Reboot the Pi, wait for 10 minutes, and then check to see if this has fixed your problem.

                  If the problem still persists, and you have written Raspbian STRETCH, then try this workaround:


                  sudo reboot
                  [/code]

                  Rebooting pi and waiting didn't fix it. I then ran the code you posted and rebooted again but still seeing the same error:

                  [FAIL] Receiver: down ... failed!
                  [FAIL] FR24 MLAT: not running ... failed!

                  Comment


                  • #10
                    Originally posted by abcd567 View Post
                    @savideo

                    Give this command and post output

                    apt-cache policy fr24feed
                    pi@raspberrypi:~ $ apt-cache policy fr24feed
                    fr24feed:
                    Installed: 1.0.19-15
                    Candidate: 1.0.19-15
                    Version table:
                    *** 1.0.19-15 0
                    500 http://repo.feed.flightradar24.com/ flightradar24/raspberrypi-stable armhf Packages
                    100 /var/lib/dpkg/status

                    Comment


                    • #11
                      What is shown in browser on following page?

                      ip-of-pi:8754

                      Comment


                      • #12
                        Originally posted by abcd567 View Post
                        What is shown in browser on following page?

                        ip-of-pi:8754
                        Do you mean my browser as in Google Chrome? If so, this is what I get:

                        This site can’t be reached
                        ip-of-pi’s server IP address could not be found.
                        Search Google for 8754
                        ERR_NAME_NOT_RESOLVED

                        If however I enter it into the Rpi, what I get is:
                        -bash: ip-of-pi:8754: command not found
                        Last edited by savideo; 2018-02-11, 12:22.

                        Comment


                        • #13
                          Browser as in Chrome yes, but you need to replace "ip-of-pi" with whatever the network address of your pi is - something like 192.168.xxx.xxx.

                          If you log into your pi and type "ifconfig" you should see something like the below. Then look for "wlan" if you connect wirelessly or I think it will be "eth0" if you're using a cable. Then you're looking for whatever address is after "inet", so in my case 192.168.123.142

                          Code:
                          pi@raspberrypi:~ $ ifconfig
                          lo: flags=73<UP,LOOPBACK,RUNNING>  mtu 65536
                                  inet 127.0.0.1  netmask 255.0.0.0
                                  inet6 ::1  prefixlen 128  scopeid 0x10<host>
                                  loop  txqueuelen 1  (Local Loopback)
                                  RX packets 151537075  bytes 50973273464 (47.4 GiB)
                                  RX errors 0  dropped 0  overruns 0  frame 0
                                  TX packets 151537075  bytes 50973273464 (47.4 GiB)
                                  TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0
                          
                          wlan0: flags=4163<UP,BROADCAST,RUNNING,MULTICAST>  mtu 1500
                                  inet 192.168.123.142  netmask 255.255.255.0  broadcast 192.168.123.255
                                  inet6 2001:8b0:fb4d:1::49  prefixlen 128  scopeid 0x0<global>
                                  inet6 2001:8b0:fb4d:1:7cd7:52aa:1080:41d5  prefixlen 64  scopeid 0x0<global>
                                  inet6 fe80::4e79:4e25:c4d7:7504  prefixlen 64  scopeid 0x20<link>
                                  ether b8:27:eb:66:32:4d  txqueuelen 1000  (Ethernet)
                                  RX packets 2712764  bytes 523676626 (499.4 MiB)
                                  RX errors 0  dropped 161  overruns 0  frame 0
                                  TX packets 4389236  bytes 2630798558 (2.4 GiB)
                                  TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

                          Comment


                          • #14
                            Oops! That is me being really dumb. Sorry about that.

                            Anyway, I have run that command and this is what I see

                            Linux/generic/static_arm/1.0.19-15
                            Updated: 13:46:57 GMT+0000 (GMT Standard Time)
                            FR24 Link: Connected via UDP
                            FR24 Radar Code: T-EGGP12
                            Local IP(s): 192.168.1.223
                            Aircraft Tracked:
                            (ModeS & ADS-B) 0
                            Aircraft Uploaded: N/A
                            Receiver: dvbt, Connected
                            MLAT running: NO

                            Actions:
                            Settings
                            Restart software
                            Terminate software
                            Show tracked aircraft list

                            Comment


                            • #15
                              Try this: https://forum.flightradar24.com/thre...l=1#post101305

                              Comment

                              Working...
                              X