Announcement

Collapse
No announcement yet.

Archived: Feed issues with 19-2

Collapse
This topic is closed.
X
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • @gabrielmagacho

    give following 3 commands and post heir output

    apt-cache policy dump1090-mutability

    apt-cache policy fr24feed

    fr24feed-status

    Comment


    • Originally posted by ylis View Post
      Has anyone had an broken RPi 'fixed' by the software updates alone ie from 1.0.18-9 to 1.0.19-8 ? Without any local human intervention or tinkering ?
      I have tried twice by re-imaging Pi24 (ver 1.0.18-9) and leaving it running for 24 hrs.
      In both cases:
      1. It automatically got upgraded to latest version available at that time (1.0.19-7 in first case and 1.0.19-8 in second case)
      2. The dump1090-mutability v 1.14 did NOT get installed.
        As a result fr24feed crashed and no map display.
      3. I had to manually run the script to install dump1090-mutability.
        After manual install as below, all started working ok
        Code:
        #First make sure settings are "Receiver DVBT". 
        #Without above setting, the script will NOT install dump1090-mutability
        
        cd /usr/lib/fr24/
        sudo ./install_dump1090.sh 
        
        #Reboot device
        sudo reboot
      4. Although lighttpd is installed, the map does not show on ip-of-pi/dump1090/gmap.html.
        It continues to show on ip-of-pi:8080 as before.


      EDIT 29.01.2018
      Correctd spelling of install in command
      sudo ./instal_dump1090.sh
      (install was misspelled as instal)
      .
      Last edited by abcd567; 2018-01-29, 21:08.

      Comment


      • Hi

        I have been trying to follow your advice but without success, but at the end of the manual install process I get this message:

        ERROR: The certificate of 'github.com' is not trusted.
        ERROR: The certificate of 'github.com' is not yet activated.
        The certificate has not yet been activated

        Could this be the problem?

        Comment


        • GOOD NEWS
          If in settings, latitude and longitudes of your receiver are added, then on your map you will see:
          1. Distance of an airplane from your station when you click that airplane.
          2. Three Site Circles at distance of 100, 150, and 200 nm from your receiver.
          3. A receiver marker.

          FR24 Map with procargs lat lon.png

          FR24 Settings procargs lat lon.png
          Code:
          sudo nano /etc/fr24feed.ini
          
          receiver="dvbt"
          fr24key="xxxxxxxxxxxxxxxxx"
          bs="no"
          raw="no"
          logmode="1"
          procargs="--net  --lat xx.xxxx  --lon yy.yyyy"
          windowmode="0"
          mpx="no"
          mlat="yes"
          mlat-without-gps="yes"
          Last edited by abcd567; 2018-01-27, 20:17.

          Comment


          • I actually wondered about that recently. How it was going to handle the lack of GPS data as it was only included when signing up for an automated account once feeding by server side config.

            As those sorts of things only appear when you aptreconfigure dump1090 or complete the config file with the details. Good to know.

            But more for people to mistype and ask why it's not going :/

            Sent from my XT1092 using Tapatalk
            Posts not to be taken as official support representation - Just a helpful uploader who tinkers

            Comment


            • Be nice if the first time fr24feed ran the location data as seen in the output during start was grepd and inline 'sed' into the config or dump1090 config file (if exists)

              Sent from my XT1092 using Tapatalk
              Posts not to be taken as official support representation - Just a helpful uploader who tinkers

              Comment


              • Thank you @abcd567 I didn't know that. I entered my coordinates and really: it works like magic :-)

                Sent from iPhone with Tapatalk
                Last edited by ahdigital; 2018-01-27, 20:47.

                Comment


                • Can someone help by answering previously asked questions, namely:

                  i) How do you create a fresh installation (ylis)
                  ii) can you turn off automatic updates (thehague)

                  I use a RPI with a USB TV stick, it's worked fine since Dec 2016 but stopped when these updates started.

                  I have a working 1.0.18-9 image I can revert to from April 2017 which works fine, but it updates and stops.

                  I'm struggling to keep up with some of the tech savvy replies :-)

                  Comment


                  • Originally posted by Gary Scott View Post
                    Can someone help by answering previously asked questions, namely:

                    i) How do you create a fresh installation (ylis)
                    ii) can you turn off automatic updates (thehague)

                    I use a RPI with a USB TV stick, it's worked fine since Dec 2016 but stopped when these updates started.

                    I have a working 1.0.18-9 image I can revert to from April 2017 which works fine, but it updates and stops.

                    I'm struggling to keep up with some of the tech savvy replies :-)
                    If you have nothing else on it other than previously being a PI24 image, just follow the wipe/reapply instructions on 'share your data'

                    And immediately do this before launching.

                    https://forum.flightradar24.com/showthread.php?p=98692

                    However abcd567 has discovered doing so, allowing the update and forcing the manual update script instead may actually fix it. And that is the stage you may now be at

                    Else there are purge commands on about pg2 to flush all the apps rather than reimage.
                    Sent from my XT1092 using Tapatalk
                    Posts not to be taken as official support representation - Just a helpful uploader who tinkers

                    Comment


                    • Strangely enough, that line in /etc/cron.d/fr24feed_updater is not commented out here - it looks to me as if it should run at 0700 daily - but I'm still on 1.0.18-9. This was a fresh install on 16th January when my Pi went down with may others. I just re-imaged and activated, found myself running 18-9 and it's been running ever since.

                      Since everything seems to be OK here, is there anything important to be gained by risking an update?

                      Comment


                      • Thanks Oblivian, my 1.0.18-9 working image is up and running with the update commented out, fingers crossed lets see.

                        Comment


                        • My Whish List

                          1. A new Pi24 image with fr24feed ver 1.0.19-8 and dump1090-mutability ver 1.14 pre-installed.

                          1. A new fr24feed.deb package which niether has integral receiver-decoder, nor installs it subsequently.

                          It is the user who should himself install the receiver-decoder software (such as dump1090 mr, dump1090-mutability, dump1090-fa, modeSDeco2, etc, etc).

                          Only commands (or a bash script) like below should be provided to guide inexperienced user to enable him to install dump1090-mutability ver 1.14, if he already does not have any receiver-decoder software installed.

                          Code:
                          sudo apt-get update
                          
                          #Install dependency
                          sudo apt-get install librtlsdr0
                          sudo apt-get install dirmngr
                          
                          #Install dump1090-mutability
                          wget https://github.com/mutability/dump1090/releases/download/v1.14/dump1090-mutability_1.14_armhf.deb
                          sudo dpkg -i dump1090-mutability_1.14_armhf.deb
                          
                          #Webserver installation
                          sudo apt-get install lighttpd
                          sudo lighty-enable-mod dump1090
                          sudo /etc/init.d/lighttpd force-reload
                          
                          #Post install configuration
                          sudo dpkg-reconfigure dump1090-mutability
                          
                          #Workaround for Raspbian Stretch
                          sudo wget -O /etc/udev/rules.d/rtl-sdr.rules "https://raw.githubusercontent.com/osmocom/rtl-sdr/master/rtl-sdr.rules"
                          sudo reboot
                          Last edited by abcd567; 2018-01-28, 08:35.

                          Comment


                          • I can only but imagine there was a request or requirement to no longer use -mr variant. And therefore to keep existing installs compliant and going the immediate thought was to revoke and replace it with .14 at the same foul swoop. But that doesn't appear to have taken into account custom installs and so on. So yes, an integrated message oe process kicked off stating what was being done and mediation steps after would probably been a little better received.

                            Even if it be forced shutdown (or purge), and a note on blog/website stating to run a separate install script customised to detect dump1090 and force reconfigure / detection and optional decoder install

                            Sent from my XT1092 using Tapatalk
                            Posts not to be taken as official support representation - Just a helpful uploader who tinkers

                            Comment


                            • Originally posted by Oblivian View Post
                              I can only but imagine there was a request or requirement to no longer use -mr variant. And therefore to keep existing installs compliant and going the immediate thought was to revoke and replace it with .14 at the same foul swoop. But that doesn't appear to have taken into account custom installs and so on. So yes, an integrated message oe process kicked off stating what was being done and mediation steps after would probably been a little better received.

                              Even if it be forced shutdown (or purge), and a note on blog/website stating to run a separate install script customised to detect dump1090 and force reconfigure / detection and optional decoder install

                              Sent from my XT1092 using Tapatalk
                              I think it is time to segregate feeder software and receiver-decoder software into two completely independent stand-alone packages. The feeder software should not attempt to install receiver-decoder software.

                              The users should be offered 3 independent software
                              1. feeder only
                              2. receiver-decoder only
                              3. plu-n-play Pi24 image i.e. OS+feeder+receiver-decoder.


                              This way:
                              • Those who have custom install (i.e. receiver-decoder software of their choice already installed), can install only feeder software which will use their pre-existing receiver-decoder.
                              • Those who dont already have a receiver-decoder software installed and are willing to install dump1090-mutability v1.14, installation commands (or a bash script) for installing dump1090-mutability v1.14 is offered.
                              • Those who dont know much of Linux, a plug-n-play Pi24 is very handy. The Pi24 should have both the stand-alone feeder software and stand-alone receiver-decoder software pre-installed.
                              Last edited by abcd567; 2018-01-28, 09:09.

                              Comment


                              • Originally posted by abcd567 View Post
                                @ davgooner
                                Reboot Pi and check after reboot
                                Code:
                                sudo reboot
                                
                                fr24feed-status
                                If rebooting does not fix problem, try this workaround:
                                Code:
                                sudo wget -O  /etc/udev/rules.d/rtl-sdr.rules "https://raw.githubusercontent.com/osmocom/rtl-sdr/master/rtl-sdr.rules"
                                
                                sudo reboot
                                
                                fr24feed-status
                                A big thank you!!!
                                You fixed my problem with my receiver down error!

                                Comment

                                Working...
                                X