Announcement

Collapse
No announcement yet.

Archived: Feed issues with 19-2

Collapse
This topic is closed.
X
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • #61
    Originally posted by vinnyspb View Post
    We've published a beta version 1.0.19-7. Feel free to give it a try. It should overcome "dpkg --configure" issue and will run from fr24:fr24 user instead of nobody:nogroup (as this seems to be causing problems to some installations). Your feedback is appreciated.

    To install beta version, edit file /etc/apt/sources.list and change "raspberrypi-stable" to "raspberrypi-beta".
    Then run:
    Done that but still the same problem for me even with fr24:fr24 user: Unable to connect to localhost, unable to synchronize time and unable to connect to feed.flightradar24.com. The only user that works on my system is root.

    I'll try to do a bit of digging and see if I can find a reason for that behaviour.
    T-EIKY1 | T-EICK1

    Comment


    • #62
      Originally posted by vinnyspb View Post
      That means your SD card is mounted in read only mode. To remount it, run:

      sudo mount -o remount,rw /
      Code:
      Flightradar24 Feeder/Decoder
      
      Linux/generic/static_arm/1.0.19-7
      
      Updated: 19:43:19 GMT+0100 (CET)
      
      FR24 Link:	Connected via UDP
      FR24 Radar Code:	T-EHLE86
      Aircraft Tracked (ModeS & ADS-B):	0
      Aircraft Uploaded:	N/A
      Receiver:	dvbt, Connected
      MLAT running:	NO

      Code:
      ac_map_size="3072"
      build_arch="static_arm"
      build_flavour="generic"
      build_os="Linux"
      build_revision="HEAD-407b76d.git"
      build_timetamp="Jan 24 2018 14:33:56"
      build_version="1.0.19-7"
      cfg_baudrate=""
      cfg_bs="yes"
      cfg_host=""
      cfg_mpx="no"
      cfg_path="/usr/lib/fr24/dump1090"
      cfg_raw="yes"
      cfg_receiver="dvbt"
      cfg_windowmode="0"
      d11_map_size="0"
      feed_alias="T-EHLE86"
      feed_configured_mode="UDP"
      feed_current_mode="UDP"
      feed_current_server="83.140.21.87"
      feed_last_attempt_time="1516819341"
      feed_last_config_attempt="1516819341"
      feed_last_config_info=""
      feed_last_config_result="success"
      feed_last_connected_time="1516819341"
      feed_status="connected"
      feed_status_message=""
      fr24key="Removed_My_Key"
      last_json_utc="1516819381"
      last_rx_connect_status="OK"
      last_rx_connect_time="1516819446"
      last_rx_connect_time_s="2018-01-24 18:44:06"
      mlat-ok="NO"
      mlat-started="YES"
      mlat_problem="no-config"
      msg_ring_full="0"
      msg_ring_length="0"
      offline-mode="no"
      rx_connected="0"
      shutdown="no"
      time_update_utc="1516819409"
      time_update_utc_s="2018-01-24 18:43:29"
      timing_is_valid="1"
      timing_last_drift="-0.0005"
      timing_last_offset="-0.0005"
      timing_last_result="success"
      timing_source="NTP"
      timing_time_last_attempt="1516819341"
      timing_time_last_success="1516819341"
      timing_time_since_last_success="1516819341"
      I cannot post link to pastebin yet...

      Comment


      • #63
        I’m not real technical but I’m reading all the post and trying to keep up.

        FR24 tech support had me run:
        sudo apt update
        sudo apt remove dump1090-mutability fr24feed
        sudo rm -f /etc/default/dump1090-mutability
        sudo rm -f /etc/udev/rules.d/rtl-sdr.rules
        sudo apt install fr24feed

        I’m feeding data to them but I lost my local access map Dump1090 and performance graphs.
        Not what I wanted to happen!
        Do I need to reimage and start again?

        Comment


        • #64
          Hi tried beta version 1.0.19-7, dump1090-mutability runs fine but fr24feed will only connect if i change user to root:root (edit in fr24feed.service).
          It does not connect with fr24:fr24

          Comment


          • #65
            Originally posted by RockRidge View Post
            Iím not real technical but Iím reading all the post and trying to keep up.

            FR24 tech support had me run:
            sudo apt update
            sudo apt remove dump1090-mutability fr24feed
            sudo rm -f /etc/default/dump1090-mutability
            sudo rm -f /etc/udev/rules.d/rtl-sdr.rules
            sudo apt install fr24feed

            Iím feeding data to them but I lost my local access map Dump1090 and performance graphs.
            Not what I wanted to happen!
            Do I need to reimage and start again?
            If dump1090-mutability is still installed and running (which I presume it is since you are feeding data), try
            Code:
            ~ $ sudo chown -R dump1090:nogroup /run/dump1090-mutability
            to fix local dump1090 map and performance graphs. Note that graphs won't come up straight away; they will need time to start building up again.
            T-EIKY1 | T-EICK1

            Comment


            • #66
              Originally posted by robddavies View Post
              Hi tried beta version 1.0.19-7, dump1090-mutability runs fine but fr24feed will only connect if i change user to root:root (edit in fr24feed.service).
              It does not connect with fr24:fr24
              I had same issue and traced it to a little bug in Raspian Jessie. To confirm, try this command:
              Code:
              ping localhost
              If you get "ping: icmp open socket: Operation not permitted" then you have this issue. To confirm further, run:
              Code:
              ~ $ ls -al /bin/ping
              -rwxr-xr-x 1 root root 38844 Feb 12  2014 /bin/ping
              If you have -rwxr-xr-x then this is an issue. To correct, do:
              Code:
              ~ $ sudo chmod 4755 /bin/ping
              Now you should see an 's' instead of 'x':
              Code:
              ~ $ ls -al /bin/ping
              -rwsr-xr-x 1 root root 38844 Feb 12  2014 /bin/ping
              And ping localhost should work like so:
              Code:
              ~ $ ping localhost
              PING 127.0.0.1 (127.0.0.1) 56(84) bytes of data.
              64 bytes from 127.0.0.1: icmp_seq=1 ttl=64 time=0.152 ms
              (press Ctrl-C to stop the pinging)

              Above solution was found on: https://discuss.pivotal.io/hc/en-us/...not-permitted-
              T-EIKY1 | T-EICK1

              Comment


              • #67
                Thanks

                That has fixed the problem, running beta version 1.0.19-7 with user fr24:fr24

                Comment


                • #68
                  So to add more spanners to the issue, looks like it's likely Jessie (any new users downloading raspian is dealt to now..)

                  And a localhost ping/resolve lockdown for non roots when the service runs that stops the connector working.

                  Which despite me not utilising dump1090 called from fr24feed (15 Dev service), is effected when in Avrtcp source as service.

                  Now to wait for Sweden to come back online for them to double check discovery.

                  Sent from my XT1092 using Tapatalk
                  Last edited by Oblivian; 2018-01-24, 20:29.
                  Posts not to be taken as official support representation - Just a helpful uploader who tinkers

                  Comment


                  • #69
                    Originally posted by vinnyspb View Post
                    Additionally to what Oblivian suggested, it would be very helpful to get output of the following commands please:

                    cat /etc/default/dump1090-mutability

                    fr24feed --version

                    cat /var/log/fr24feed/fr24feed.log

                    cat /dev/shm/decoder.txt

                    ls -al /var/log/fr24feed /run/fr24feed /dev/shm/decoder.txt /run/dump1090-mutability /usr/lib/fr24

                    cat /etc/fr24feed.ini | grep -v fr24key

                    ps aufx | grep -e fr24 -e dump1090

                    sudo systemctl status fr24feed

                    /usr/lib/fr24/dump1090 --help 2>&1 | grep dump1090

                    sudo grep -e fr24feed -e dump1090 /var/log/syslog
                    For what it is worth, following up from yesterday. (I am running standard dump1090 with Beast)

                    pi@raspnzaa4:~ $ cat /etc/default/dump1090-mutability
                    cat: /etc/default/dump1090-mutability: No such file or directory

                    pi@raspnzaa4:~ $ fr24feed --version
                    1.0.19-6

                    cat /var/log/fr24feed/fr24feed.log

                    2018-01-25 09:33:03 | [main][i]FR24 Feeder/Decoder
                    2018-01-25 09:33:03 | [main][i]Version: 1.0.19-6/generic
                    2018-01-25 09:33:03 | [main][i]Built on Jan 23 2018 08:17:49 (HEAD-635eb0b.git/Linux/static_arm)
                    2018-01-25 09:33:03 | [main][i]Copyright 2012-2018 Flightradar24 AB
                    2018-01-25 09:33:03 | [main][i]https://www.flightradar24.com
                    2018-01-25 09:33:03 | [main][i]DNS mode: PING
                    2018-01-25 09:33:03 | [main][i]Automatic updates are ENABLED
                    2018-01-25 09:33:03 | [httpd][i]Server started, listening on 0.0.0.0:8754
                    2018-01-25 09:33:03 | [main][i]Reader thread started
                    2018-01-25 09:33:03 | [time][i]Synchronizing time via NTP
                    2018-01-25 09:33:03 | [master][i]Starting processing thread
                    2018-01-25 09:33:03 | [reader][i]Initializing reader
                    2018-01-25 09:33:03 | [reader][i]Connecting to unknown receiver via (/dev/ttyUSB0@3000000)
                    2018-01-25 09:33:03 | [reader][e]Could not connect to /dev/ttyUSB0@3000000
                    2018-01-25 09:33:08 | [reader][i]Connecting to unknown receiver via (/dev/ttyUSB0@3000000)

                    pi@raspnzaa4:~ $ cat /dev/shm/decoder.txt
                    ac_map_size=3072
                    build_arch=static_arm
                    build_flavour=generic
                    build_os=Linux
                    build_revision=HEAD-635eb0b.git
                    build_timetamp=Jan 23 2018 08:17:49
                    build_version=1.0.19-6
                    cfg_baudrate=3000000
                    cfg_bs=no
                    cfg_host=
                    cfg_mpx=
                    cfg_path=/dev/ttyUSB0
                    cfg_raw=no
                    cfg_receiver=beast
                    cfg_windowmode=0
                    d11_map_size=0
                    feed_alias=T-NZAA4
                    feed_configured_mode=UDP
                    feed_current_mode=UDP
                    feed_current_server=83.140.21.112
                    feed_last_attempt_time=1516826004
                    feed_last_config_attempt=1516826003
                    feed_last_config_info=
                    feed_last_config_result=success
                    feed_last_connected_time=1516826004
                    feed_status=connected
                    feed_status_message=
                    fr24key=XXXXXXXXXXXXXXXXXXXXXX
                    last_json_utc=1516826951
                    last_rx_connect_status=E1
                    msg_ring_full=0
                    msg_ring_length=0
                    offline-mode=no
                    rx_connected=0
                    shutdown=no
                    time_update_utc=1516826983
                    time_update_utc_s=2018-01-24 20:49:43
                    timing_is_valid=1
                    timing_last_drift=+0.0010
                    timing_last_offset=+0.0001
                    timing_last_result=success
                    timing_source=NTP
                    timing_time_last_attempt=1516826615
                    timing_time_last_success=1516826615
                    timing_time_since_last_success=612


                    sudo systemctl status fr24feed
                    ● fr24feed.service - Flightradar24 Decoder & Feeder
                    Loaded: loaded (/etc/systemd/system/fr24feed.service; disabled)
                    Active: active (running) since Thu 2018-01-25 09:33:03 NZDT; 19min ago
                    Process: 1044 ExecStartPre=/bin/chmod a+rwx /run/dump1090-mutability (code=exited, status=0/SUCCESS)
                    Process: 1041 ExecStartPre=/bin/chown -R nobody:nogroup /var/log/fr24feed /run/fr24feed /dev/shm/decoder.txt (code=exited, status=0/SUCCESS)
                    Process: 1038 ExecStartPre=/bin/touch /dev/shm/decoder.txt (code=exited, status=0/SUCCESS)
                    Process: 1034 ExecStartPre=/bin/mkdir -p /run/dump1090-mutability /var/log/fr24feed /run/fr24feed /var/log/lighttpd (code=exited, status=0/SUCCESS)
                    Process: 1031 ExecStartPre=/usr/lib/fr24/install_dump1090.sh (code=exited, status=0/SUCCESS)
                    Main PID: 1048 (fr24feed)
                    CGroup: /system.slice/fr24feed.service
                    └─1048 /usr/bin/fr24feed


                    I hope this shows what is going wrong. If I run FR24feed without service it works without stopping. Currently it is running in this mode.

                    Comment


                    • #70
                      Thanks for diagnostics!

                      Networking issues are definitely related to changing to running fr24feed as non-privileged user starting from version 1.0.19-2 (as per many requests).
                      Looks like Jessie needs this command to allow networking activity:

                      sudo setcap cap_net_raw=ep /usr/bin/fr24feed
                      Could you please check if it helps and if yes I'll incorporate that into the fr24feed package tomorrow?


                      Regarding beast via serial port, I suspect this will be enough:

                      sudo usermod -a -G dialout fr24
                      Again, if you could verify that it works for you please(on the latest 1.0.19-7 beta), I'll incorporate this change to the package tomorrow.

                      fr24feed restart will be required after any of these commands.

                      Comment


                      • #71
                        Originally posted by JohnSunnyhills View Post
                        I hope this shows what is going wrong. If I run FR24feed without service it works without stopping. Currently it is running in this mode.
                        Permission to access USB port?

                        Try ;
                        adduser fr24 dialout
                        F-ESDF1, F-ESGG1, F-ESGP1, F-ESNK1, F-ESNV2, F-ESNV3 F-ESSL4, F-LFMN3
                        P-ESGR, P-ESIA, P-ESIB, P-ESGF
                        mrmac (a) fastest.cc

                        Comment


                        • #72
                          Originally posted by vinnyspb View Post
                          Networking issues are definitely related to changing to running fr24feed as non-privileged user starting from version 1.0.19-2 (as per many requests).
                          For me, on Jessie, this solved the issue of fr24feed failing to connect and synching time as non-privileged user:
                          Code:
                          ~ $ sudo chmod 4755 /bin/ping
                          See more details a few posts earlier. But perhaps there are also additional issues on other OS versions.
                          T-EIKY1 | T-EICK1

                          Comment


                          • #73
                            Still doesn't like something on ln8 going to 17-9

                            pi@raspberrypi:~ $ sudo /usr/lib/fr24/fr24feed_updater.sh
                            /usr/lib/fr24/fr24feed_updater.sh: line 8: /dev/mmcblk0p2: Permission denied

                            Installing new version of config file /etc/cron.d/fr24feed_updater ...
                            mount: / is busy

                            D1090 is stopped and out of the picture for now for me, hosting beast TCP off primary feed PC. It didn't want to poll home as service until I forced restart but tiz now

                            Hopefully others with non DVBT can report same
                            Posts not to be taken as official support representation - Just a helpful uploader who tinkers

                            Comment


                            • #74
                              Just to let everyone know :-

                              sudo chmod 4755 /bin/ping

                              Fixed it for me. Now running 1.0.19.7 with fr24feed using fr24 user. Prior to this fix I had to change the user in the fr24feed.service file to root.

                              Does anyone know why fr24feed is using 'ping' ?

                              Comment


                              • #75
                                Just published 1.0.19-8 into beta.

                                I would aim to release it to stable soon-ish if no unexpected issues come up.

                                Changes:

                                - binary permissions fixed according to user reports
                                - force dpkg to reconfigure bad state of fr24feed
                                - http://RECEIVER_IP:8754/diagnostics_dump.tgz will download archive with diagnostics which can be shared with Flightradar24 support in case of something not working to facilitate diagnostics

                                Comment

                                Working...
                                X