Announcement

Collapse
No announcement yet.

Archived: Feed issues with 19-2

Collapse
This topic is closed.
X
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Oblivian
    replied
    Originally posted by abcd567 View Post
    sudo bash -c "$(wget -O - http://repo.feed.flightradar24.com/install_fr24_rpi.sh)"

    It installs dump1090-mutability_1.14, instead of dump1090-mr
    Please scroll-down and see code lines in red below
    Well spotted.

    I wasn't sure how to show what the scripting was doing when using standard apt-get upgrade to see where it fell off

    Guess the new norm even for upgrading is to use the bash.

    Note theres a change in the status commandline now too
    sudo fr24feed-status


    Looks like traditionally did on stretch
    Last edited by Oblivian; 2018-01-16, 11:02.

    Leave a comment:


  • abcd567
    replied
    sudo bash -c "$(wget -O - http://repo.feed.flightradar24.com/install_fr24_rpi.sh)"

    It installs dump1090-mutability_1.14, instead of dump1090-mr
    Please scroll-down and see code lines in red below

    Code:
    pi@raspberrypi:~ $ wget  http://repo.feed.flightradar24.com/install_fr24_rpi.sh
    
    --2018-01-16 04:24:23--  http://repo.feed.flightradar24.com/install_fr24_rpi.sh
    Resolving repo.feed.flightradar24.com (repo.feed.flightradar24.com)... 52.216.97.133
    Connecting to repo.feed.flightradar24.com (repo.feed.flightradar24.com)|52.216.97.133|:80... connected.
    HTTP request sent, awaiting response... 200 OK
    Length: 1504 (1.5K) [application/x-sh]
    Saving to: ‘install_fr24_rpi.sh’
    
    install_fr24_rpi.sh 100%[=====================>]   1.47K  --.-KB/s   in 0s
    
    2018-01-16 04:24:23 (28.4 MB/s) - ‘install_fr24_rpi.sh’ saved [1504/1504]
    
    
    
    pi@raspberrypi:~$ cat install_fr24_rpi.sh
    
    #!/bin/bash
    
    # Stop on first error
    set -e
    
    # to skip any questions from APT
    export DEBIAN_FRONTEND=noninteractive
    
    AUTO_SIGNUP=0
    
    while getopts "a" opt; do
            case $opt in
            a)
                AUTO_SIGNUP=1
                ;;
            esac
    done
    
    if [ "$(id -u)" != "0" ]; then
       echo "This script must be run as root" 1>&2
       exit 1
    fi
    
    # Import GPG key for the APT repository
    # Use keys pool: https://sks-keyservers.net/overview-of-pools.php
    gpg --keyserver pool.sks-keyservers.net --recv-keys 40C430F5
    gpg --armor --export 40C430F5 | apt-key add -
    
    # Add APT repository to the config file, removing older entries if exist
    mv /etc/apt/sources.list /etc/apt/sources.list.bak
    grep -v flightradar24 /etc/apt/sources.list.bak > /etc/apt/sources.list || echo OK
    echo 'deb http://repo.feed.flightradar24.com flightradar24 raspberrypi-stable' >> /etc/apt/sources.list
    
    # Download and install dump1090-mr
    [COLOR="#FF0000"]wget -O /tmp/dump1090-mutability_1.14_armhf.deb https://github.com/mutability/dump1090/releases/download/v1.14/dump1090-mutability_1.14_armhf.deb
    dpkg -i /tmp/dump1090-mutability_1.14_armhf.deb
    rm -f /tmp/dump1090-mutability_1.14_armhf.deb[/COLOR]
    
    # Update APT cache and install feeder software
    apt-get update -y
    apt-get install fr24feed -y
    
    # Stop older instances if exist
    systemctl stop fr24feed || echo OK
    
    # Run the signup wizard
    if [ $AUTO_SIGNUP -eq 0 ]; then
        fr24feed --signup
        chmod a+rw /etc/fr24feed.ini
    
        # Restart the feeder software
        systemctl restart fr24feed
    fi
    
    echo "Installation and configuration completed!"
    Last edited by abcd567; 2018-01-16, 09:35.

    Leave a comment:


  • mbirth
    started a topic Archived: Feed issues with 19-2

    Archived: Feed issues with 19-2

    I just upgraded the fr24feed package on my RasPi from 1.0.18-9 to 1.0.19-2 and now dump1090 is missing in /usr/lib/fr24. Is this intentional?
Working...
X