Announcement

Collapse
No announcement yet.

Archived: Feed issues with 19-2

Collapse
This topic is closed.
X
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • @zebradidit
    As you dont have any dump installed, you have to decide which version you want, then install it.
    1. If you want dump1090-fa, follow steps on Flightaware site https://flightaware.com/adsb/piaware/install

    2. If you want dump1090-mutability v1.14, it will be automatically installed if you make settings Receiver: DVBT Stick (default)"

    3. To make the "Save" and "Restart" buttons available on page ip-of-pi:8754/settings.html, give following command, then reload/refresh your browser

      Code:
      sudo chmod a+rw /etc/fr24feed.ini  
      sudo systemctl restart fr24feed

    Comment


    • Thx for your attention.
      I finally got it working.
      1) I got rid of fr24feed:
      sudo dpkg --purge --force-remove-reinstreq fr24feed

      2) Re-installed fr24feed: (can't post links so fix the h t t p yourself)
      sudo bash -c "$(wget -O - h t t p://repo.feed.flightradar24.com/install_fr24_rpi.sh)"

      3) follow option3 here (can't post links so fix the h t t p s yourself)):
      h t t p s: //forum.flightradar24.com/threads/8591-Raspberry-Pi-How-To-Install-Raspian-OS-Dump1090-FR24-Data-Feeder

      4) sudo systemctl restart fr24feed
      Attached Files
      Last edited by zebradidit; 2018-03-26, 19:10.

      Comment


      • Originally posted by abcd567 View Post
        Even if you stop dump1090-fa by above command, the fr24feed will install, and then keep on trying to start dump1090-mutability v 1.14, IF in settings you have selected "Receiver: DVBT".
        I didn't want to go creating a new thread, so figured more meddling to our discoveries previously may as well be added to.

        /etc/systemd/system on Raspian/Jessie.. has .system files for scripts to run on start.

        systemctl list-unit-files | grep enabled

        Interesting to note the defaults which don't help advanced stuff I couldn't work out why I was ending up with a USB claim issue each time I rebooted after attempting to stop auto-starting of most apps and wanted to start a particular app that accessed SDR. Keeps flogging it each time.

        Code:
        [Service]
        Type=simple
        Restart=always
        LimitCORE=infinity
        ExecStartPre=-/usr/lib/fr24/install_dump1090.sh
        ExecStartPre=-/usr/lib/fr24/unregister_kernel_modules.sh
        ExecStartPre=-/usr/lib/fr24/create_missing_directories.sh
        ExecStart=/usr/bin/fr24feed
        If you want it gone gone, sudo systemctl disable fr24feed.service
        Last edited by Oblivian; 2018-05-31, 09:37.
        Posts not to be taken as official support representation - Just a helpful uploader who tinkers

        Comment

        Working...
        X