No announcement yet.

Archived: Feed issues with 19-2

This topic is closed.
  • Filter
  • Time
  • Show
Clear All
new posts

  • @raffav

    Just to replicate your case, I did following:

    1. Formatted microSD card

    2. Downloaded Raspbian Stretch Lite image (2017-11-29-raspbian-stretch-lite.img)

    3. Wrote (2017-11-29-raspbian-stretch-lite.img) on microSD card.

    4. Ran bash script: sudo bash -c "$(wget -O -"

    5. During signup provided email, fr24 sharing key, latitude & longitude etc

    6. During configuration selected option "1. DVB-T".

    7. Restarted fr24feed by sudo systemctl restart fr24feed

    This is what I got:

    At ip-of-pi:8754
    FR24FEED On Stretch With Dump Mut 1.14.png

    In SSH terminal
    FR24FEED On Stretch With Dump Mut 1.14 - B.png
    Last edited by abcd567; 2018-02-11, 05:47.


    • Thanks
      Tomorrow will get the version
      Now I inserted SD with rasbPBX(freepbx for raspberry) to work on voip
      I am using the script and still getting the error but I am online on site, and getting planes

      Enviado de meu XT1580 usando Tapatalk


      • @abcd567

        i have checked it all the same


        • Originally posted by abcd567 View Post

          Just to replicate your case, I did following:

          1. Formatted microSD card
          Why would you format the card if you are going to overwrite it all with an image?


          • Originally posted by barjac View Post
            Why would you format the card if you are going to overwrite it all with an image?
            Normally formatting is not necessary when overwriting with an image.

            My card has started giving trouble so I first did an overwrite formatting (overwrite entire card with zeros) to clear it. It took more than an hour to do so.


            • @fr24-pad

              Just for completeness of your advice, I wonder if you mind posting the contents of your clean fr24.service file (fr24feed.service-lgp).
              I do agree that disabling the updater and all the dump1090 hacks is a great idea. Too many different configs out there. Too easy to stuff up.


              • @Kemistry

                Description=Flightradar24 Decoder & Feeder

                #ExecStartPre=-/bin/mkdir -p /run/dump1090-mutability /var/log/fr24feed /run/fr24feed /var/log/lighttpd
                #ExecStartPre=-/bin/touch /dev/shm/decoder.txt
                #ExecStartPre=-/bin/chown -R fr24:fr24 /var/log/fr24feed /run/fr24feed /dev/shm/decoder.txt
                #ExecStartPre=-/bin/chmod a+rwx /run/dump1090-mutability



                • Thanks fr24-pad ... your hashed-out lines are as I would expect.
                  But just to prove there are many different configs in the wild, my fr24feed.service has 2 other lines that I think can also be disabled.
                  Anyone know why they were included and why they should stay?
                  I see you have disabled them in your safe-fr24-install script - but why should I even let them into the service?
                  Last edited by Kemistry; 2018-03-01, 11:26. Reason: update last line


                  • Those two additional lines were added after I created my clean version. They are tasks that were split out of the update script.


                    • Originally posted by fr24-pad View Post
                      ... They are tasks that were split out of the update script.
                      Thanks for quick response but I was really chasing if they are needed in the fr24feed.service config file?
                      Do you mean they were split out of the FR24 update script and put into service config?
                      Or maybe I have ended up with some trash lines in my .service file that should be disabled or deleted?


                      • My system works fine without them. Linux has mechanisms to determine which modules are required, and it loads them on demand (if this needs to be run at all, it only needs to be run at time of installation, not every time the service starts). The directory creation is for distributions that have /var/log on a volatile file system. Mine doesn't, so I don't need it.


                        • Originally posted by raffav View Post
                          i am new on the forum already tried to find a solution but nothing worked
                          i am getting this error
                          I experience the same thing.
                          I'm running dump1090 and when I kill that process, the dongle seems to work right again.
                          Problem is dump1090 relaunches and when I rtl_test it shows the error again.
                          So now I wonder what to do. I have dump1090-fa and I also run piaware along with fr24 on my raspberry pi.


                          • @zebradidit

                            You already have dump1090-fa, which starts and grabs the dvbt dongle. The rtl_test will fail unless you stop dump1090-fa
                            sudo systemctl stop dump1090-fa
                            Even if you stop dump1090-fa by above command, the fr24feed will install, and then keep on trying to start dump1090-mutability v 1.14, IF in settings you have selected "Receiver: DVBT".

                            Change it to "ModeS Beast" as follows:
                            1. Type following address in your browser

                              Where IP-of-Pi is the Local IP of Pi and will be something like
                              This will open FR24 Settings page in your browser.
                            2. Change field Receiver: DVBT to Receiver: ModeS Beast (TCP).
                            3. In the field Host/IP:, type
                            4. Click "Save" button, then click "Restart " button. Both buttons are at bottom-right of settings page.
                            Last edited by abcd567; 2018-03-16, 01:03.


                            • To check dump1090 versions installed:

                              apt-cache policy dump1090-fa
                              #If it is installed, above command will give following output
                                Installed: 3.5.3
                                Candidate: 3.5.3
                              apt-cache policy dump1090-mutability
                              #If it is installed, above command will give following output
                                Installed: 1.14
                                Candidate: 1.14


                              • Thanks for your attention and assistance.

                                Here's what I got:
                                $ apt-cache policy dump1090-fa
                                N: Unable to locate package dump1090-fa
                                $ apt-cache policy dump1090-mutability
                                N: Unable to locate package dump1090-mutability
                                I went to my FR24 feeder settings and I can't find the save or restart button anywhere.
                                Is there a config file or script where I can manually modify all this instead?