Announcement

Collapse
No announcement yet.

Archived: Feed issues with 19-2

Collapse
This topic is closed.
X
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Originally posted by Oblivian View Post
    How's it go, KISS. Keep it stupidly simple.
    1. From fr24feed, first purge/clean ALL components attempting to install and/or configure dump1090, and create a new version of fr24feed: fr24-data-feeder-only, which gets data from decoder either from port 30005 (beast) or port 30002 (raw/avr).

    2. Offer new design PI24 image - Raspbian with integral, but stand-alone apps fr24-data-feeder-only + dump1090-mutability

    3. Offer two bash scripts to user who want to use Raspbian image burned by them.
      • Bash Script 1: installs data-feeder-only software
      • Bash Script 2: (optional, if user does not have another decoder already installed) Installs dump1090-mutability v 1.14

    Comment


    • Khan/Vinnysp et-al

      Seems windows port is broken. From an earlier Rpi code? May be issues changing reading or input TCP modes after auto restart..

      https://forum.flightradar24.com/thre...out-30-Minutes
      Posts not to be taken as official support representation - Just a helpful uploader who tinkers

      Comment


      • Originally posted by Oblivian View Post
        Khan/Vinnysp et-al

        Seems windows port is broken. From an earlier Rpi code? May be issues changing reading or input TCP modes after auto restart..

        https://forum.flightradar24.com/thre...out-30-Minutes
        Thanks, issue is identified and the fix will be released soon.

        Comment


        • Auto Update 1.0.19-15 has just been installed on my RPi.

          ylis

          Comment


          • Originally posted by ylis View Post
            Auto Update 1.0.19-15 has just been installed on my RPi.
            And does it keep going after reboot..

            Sent from my XT1092 using Tapatalk
            Posts not to be taken as official support representation - Just a helpful uploader who tinkers

            Comment


            • Yes. Tested using "sudo reboot" and "sudo shutdown -r now" as well as the restart option within settings.

              ylis

              Comment


              • Originally posted by ylis View Post
                Auto Update 1.0.19-15 has just been installed on my RPi.
                Great!
                Hopefully my Pi has allso updated from 1.0.19-13 to 1.0.19-15. Will check when I return to home.

                Comment


                • Hmmm, got an update from 1.0.19-13 to 1.0.19-15 2.5H ago.
                  fr24feed_update.log show errors related to JVM:
                  Error: missing `server' JVM at `/usr/lib/jvm/java-8-openjdk-armhf/jre/lib/arm/server/libjvm.so'.
                  in fact 'server' directory is not present. Several other errors about java.
                  At the end it says it's restarting current version of feeder (so should be 1.0.19-13) but :8754 shows new version 1.0.19-15
                  see following image:
                  1.0.19-15.jpg
                  I'm correctly feeding, I rebooted and keep on feeding.

                  EDIT: After checking logs, I'm 99% this problem isn't related to fr24 update. I was able to fix this error doing the following:
                  sudo apt-get purge openjdk-8-jre-headless
                  sudo apt-get install openjdk-8-jre-headless
                  sudo apt-get install openjdk-8-jre

                  I'm almost sure it comes from my installation of dump1090-tools from tedsluis.
                  I ran automatic install and didn't realized some errors occured, even if the stats were showing correctly.
                  Probably something wrong with Stretch, but it's beyond my knowledge.
                  /EDIT

                  Another thing: why each time there's an update my sharing state show 16 minutes not feeding, that's really a severe punition!!!
                  I don't think the upgrade process need so much time, rebooting the Pi never show an interrupt.
                  Last edited by R6502; 2018-02-07, 21:52. Reason: errors not related to fr24 update

                  Comment


                  • Upgrade: ver 1.0.19-13 >>> 1.0.19-15 - ALL OK

                    pi@raspberrypi:~ $ cd /usr/lib/fr24
                    pi@raspberrypi:/usr/lib/fr24 $ sudo ./fr24feed_updater.sh
                    ...................
                    ...................
                    Unpacking fr24feed (1.0.19-15) over (1.0.19-13) ...
                    Setting up fr24feed (1.0.19-15) ...
                    Linking /usr/bin/dump1090-mutability to /usr/lib/fr24/dump1090
                    useradd: user 'fr24' already exists
                    mount: / is busy


                    pi@raspberrypi:~ $ apt-cache policy fr24feed
                    fr24feed:
                    Installed: 1.0.19-15
                    Candidate: 1.0.19-15

                    FR24 Auto-update 1.0.19-13 to 1.0.19-15.png

                    pi@raspberrypi:~ $ fr24feed-status
                    [ ok ] FR24 Feeder/Decoder Process: running.
                    [ ok ] FR24 Stats Timestamp: 2018-02-07 09:44:26.
                    [ ok ] FR24 Link: connected [UDP].
                    [ ok ] FR24 Radar: T-CYYZ9.
                    [ ok ] FR24 Tracked AC: 5.
                    [ ok ] Receiver: connected (4247 MSGS/0 SYNC).
                    [ ok ] FR24 MLAT: ok [UDP].
                    [ ok ] FR24 MLAT AC seen: 4.


                    pi@raspberrypi:~ $ sudo systemctl status piaware -l
                    ● piaware.service - FlightAware ADS-B uploader
                    Loaded: loaded (/lib/systemd/system/piaware.service; enabled; vendor preset: enabled)
                    Active: active (running) since Wed 2018-02-07 04:20:19 EST; 27min ago
                    ...................
                    ...................
                    Feb 07 04:40:56 raspberrypi piaware[450]: 582 msgs recv'd from dump1090-mutabi (104 in last 5m); 582 msgs sent to FlightAware
                    Feb 07 04:45:56 raspberrypi piaware[450]: 624 msgs recv'd from dump1090-mutabi (42 in last 5m); 624 msgs sent to FlightAware

                    Comment


                    • Today's auto-upgrade from 1.0.19-13 to 1.0.19-15 gave me a working fr24feed, even after a reboot; however,
                      errors were reported during the install. See below:

                      $ cat /var/log/apt/history.log
                      Start-Date: 2018-02-07 07:00:40
                      Commandline: apt-get -o Dpkg::Options::=--force-confdef -o Dpkg::Options::=--force-confold install -y fr24feed
                      Upgrade: fr24feed:armhf (1.0.19-13, 1.0.19-15)
                      End-Date: 2018-02-07 07:00:44

                      $ cat /var/log/apt/history.log
                      /usr/lib/fr24/fr24feed_updater.sh: line 8: /dev/mmcblk0p2: Permission denied
                      Get:1 http://archive.raspberrypi.org/debian stretch InRelease [25.3 kB]
                      Hit:2 http://flightaware.com/adsb/piaware/files/packages jessie InRelease
                      Hit:3 https://opensky-network.org/repos/debian opensky InRelease
                      Get:4 http://repo.feed.flightradar24.com flightradar24 InRelease [13.0 kB]
                      Get:5 http://archive.raspberrypi.org/debian stretch/main armhf Packages [139 kB]
                      Get:6 http://mirrordirector.raspbian.org/raspbian stretch InRelease [15.0 kB]
                      Get:7 http://repo.feed.flightradar24.com flightradar24/raspberrypi-stable armhf Packages [605 B]
                      Hit:8 https://apt.rb24.com rpi-stable InRelease
                      Fetched 193 kB in 16s (11.5 kB/s)
                      Reading package lists...
                      Installed version: 1.0.19-13
                      Latest available: 1.0.19-15
                      Upgrading fr24feed from 1.0.19-13 to 1.0.19-15...
                      Waiting for fr24feed to stop completely...
                      dpkg: error processing package fr24feed (--configure):
                      package fr24feed is already installed and configured
                      Errors were encountered while processing:
                      fr24feed
                      Reading package lists...
                      Building dependency tree...
                      Reading state information...
                      The following packages will be upgraded:
                      fr24feed
                      1 upgraded, 0 newly installed, 0 to remove and 1 not upgraded.
                      Need to get 1,214 kB of archives.
                      After this operation, 0 B of additional disk space will be used.
                      Get:1 http://repo.feed.flightradar24.com flightradar24/raspberrypi-stable armhf fr24feed armhf 1.0.19-15 [1,214 kB]
                      apt-listchanges: Reading changelogs...
                      debconf: unable to initialize frontend: Dialog
                      debconf: (TERM is not set, so the dialog frontend is not usable.)
                      debconf: falling back to frontend: Readline
                      debconf: unable to initialize frontend: Readline
                      debconf: (This frontend requires a controlling tty.)
                      debconf: falling back to frontend: Teletype
                      dpkg-preconfigure: unable to re-open stdin:
                      Fetched 1,214 kB in 1s (679 kB/s)
                      (Reading database ... 48667 files and directories currently installed.)
                      Preparing to unpack .../fr24feed_1.0.19-15_armhf.deb ...
                      Unpacking fr24feed (1.0.19-15) over (1.0.19-13) ...
                      Setting up fr24feed (1.0.19-15) ...
                      useradd: user 'fr24' already exists
                      mount: / is busy

                      Comment


                      • fr24feed_updater.sh is the worst idea ever, I prefer safe-fr24-install:

                        #!/bin/bash

                        BASE="$HOME/fr24-fix"
                        DATE=`date +%Y%m%d`

                        # install latest version of fr24
                        sudo apt-get install fr24feed

                        # stop fr24
                        sudo service fr24feed stop

                        # replace fr24feed.service with a clean version
                        sudo cp /etc/systemd/system/fr24feed.service $BASE/fr24feed.service-dist-$DATE
                        sudo cp $BASE/fr24feed.service-lgp /etc/systemd/system/fr24feed.service
                        sudo systemctl daemon-reload

                        # replace fr24feed.ini with a clean version
                        sudo cp /etc/fr24feed.ini $BASE/fr24feed.ini-dist-$DATE
                        sudo cp $BASE/fr24feed.ini-lgp /etc/fr24feed.ini

                        # remove fr24feed_updater crontab
                        sudo rm /etc/cron.d/fr24feed_updater

                        # never execute fr24 update scripts
                        sudo chmod 0 /usr/lib/fr24/fr24feed_updater.sh
                        sudo chmod 0 /usr/lib/fr24/install_dump1090.sh
                        sudo chmod 0 /usr/lib/fr24/unregister_kernel_modules.sh
                        sudo chmod 0 /usr/lib/fr24/create_missing_directories.sh
                        sudo chmod 0 /usr/lib/fr24/dump_diagnostics.sh

                        # remove extraneous directories created by fr24
                        sudo rm -fr /run/dump1090-mutability

                        # start fr24
                        sudo service fr24feed start

                        Comment


                        • @fr24-pad

                          Cannot find fr24-fix in my Pi.

                          Comment


                          • The script is my own and "fr24-fix" is a directory I created to hold the good copies of my config files.

                            Comment


                            • Hello
                              i am new on the forum already tried to find a solution but nothing worked
                              i am getting this error


                              Found 1 device(s):
                              0: Realtek, RTL2838UHIDIR, SN: 00000001 (currently selected)
                              usb_claim_interface error -6
                              Error opening the RTLSDR device: Device or resource busy

                              Comment


                              • Originally posted by raffav
                                Raspberry last version, and last version of fr24feed too

                                Enviado de meu XT1580 usando Tapatalk
                                1. Which one you have?
                                Raspbin Stretch Lite (2017-11-29-raspbian-stretch-lite.img)
                                OR
                                Raspbian Stretch Desktop (2017-11-29-raspbian-stretch.img)


                                2. Did you install FR24 by this script?
                                sudo bash -c "$(wget -O - https://repo-feed.flightradar24.com/install_fr24_rpi.sh)"

                                3. In ADDITION to above, have you installed any decoder such as dump1090-mutability or dump1090-fa?

                                .
                                Last edited by abcd567; 2018-02-11, 04:22.

                                Comment

                                Working...
                                X