Announcement

Collapse
No announcement yet.

Unable to re-start FR24 feed - others okay

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Unable to re-start FR24 feed - others okay

    My FR24 feed stopped working around midnight (local) a few days ago. Interestingly, the FA & ADSB Exchange feeds continue to function. Multiple power-cycles has not worked to re-initiate the FR24 feed.

    Installed on: Pi3b
    Installations in this order: FA / ADSB Exchange / FR24

    I can't SSH into the device as I seem to have forgotten the password, so I'll likely have to do a direct connect. I'm still a noob with Linux so I'm plugging along slowly. I'm wondering what I should do the 'kick-start' FR24? Will I have to do a re-installation?

    thanks
    Last edited by blacktop; 2017-12-31, 18:28. Reason: spelling

  • #2
    Originally posted by blacktop View Post
    I'm wondering what I should do the 'kick-start' FR24? Will I have to do a re-installation?
    In your browser's address bar type:
    ip-of-pi:8754

    On the page opened, at bottom-left, there are many links.
    Click link "Restart software".

    Please see screenshot below.
    (Click on image to see large size)
    Restart FR24.png
    Last edited by abcd567; 2018-01-01, 16:40.

    Comment


    • #3
      Hi abcd567,
      Thanks for that. I actually had two devices down and your solution worked perfect for one of them. The other keeps 'refusing connection'. It is on the device that I forgot the password for...but my experience with the other Pi leads me to believe that should make no difference.

      Any thoughts on why I would get a 'refuse connection' and the simplest resolve to fix and/or bypass? (Device is in attic and my knee replacement is slowing me down from going right up there)

      thanks again

      Comment


      • #4
        Refused is usually a sign of server down (or 2 running). So you would need to go commamdline and check the status using commands such as Sudo service fr24feed status/start/stop

        Sent from my XT1092 using Tapatalk
        Posts not to be taken as official support representation - Just a helpful uploader who tinkers

        Comment


        • #5
          Even if you forgot Pi's password, and the Pi refusese connection on SSH, you can still reach FR24 feeder and restart it from your web browser by method described in my above post.

          Comment


          • #6
            Hi again,
            Yes, I was trying the method that you suggested on the second pi (Pi local IP 192.168.10.101) by typing 192.168.10.101:8754 into the URL bar, but I keep getting:

            This site can’t be reached
            192.168.10.101 refused to connect.
            Search Google for 192 168 101 8754
            ERR_CONNECTION_REFUSED

            ...seems to me that it should be work. Computer ip is 192.168.10.103. Wireless network.

            ...just verified unit still feeding to FA....so device is alive...
            Last edited by blacktop; 2018-01-02, 00:30. Reason: added last line re:FA

            Comment


            • #7
              A brutal method below, but your Pi did not leave any other choice:

              Switch off the AC power to AC/DC adaptor of Pi, wait for 5 minutes, then turn on power again, and after 10 minutes, check status of FA & FR24.

              Comment


              • #8
                Well, I left it off for several hours, but when I applied power again, only FA re-started.

                Also, the other Pi3b WILL re-start, but after a time it just shuts down. I have to keep using your method, and sometimes I need to power cycle. After running so well for so long, I'm not sure what has changed. Is there something different at the server level, or is there a new build that I should put on the Pi's? Clearly, this is no good, so I may have to do full re-installs on both devices. Just not sure what is different....if anything.

                thanks again

                Comment


                • #9
                  Originally posted by blacktop View Post
                  ....Just not sure what is different....if anything.
                  This type of misbehavior is often caused by AC/DC power supply adapter gone bad, or a poor quality/long wire between DC adapter and Pi.

                  Try another large size adapter. My Pi2, which ran OK for a year or so, had started giving problems. After I changed AC/DC 5V 2000mA (2A) adapter by a new 3000mA (3A) adapter, it started working OK.

                  Often (but not always) a "power adaptor gone bad" results in Pi's red light either off or flickering (it should remain steadily lit all the time). Watch your Pi for a while for this symptom.

                  Comment


                  • #10
                    I've watched them for a while now. Both seem to have a nice steady burning LED. The power supplies are the Canakit branded supplies (2.5A). Do you have a recommended source for the 3A versions?

                    I don't see PM's enabled on the boards, so I guess that is not an option if public display of products for sale is frowned upon (?)

                    thanks again abcd567...appreciate all of the help...

                    A little more info:Blue FA Dongles. Power supplies plugged directly into outlet.
                    Last edited by blacktop; 2018-01-04, 19:44. Reason: last line - additional info

                    Comment


                    • #11
                      Originally posted by blacktop View Post
                      Both seem to have a nice steady burning LED.
                      GREAT!

                      The power supplies are the Canakit branded supplies (2.5A).
                      Canakit brand adaptors are good.

                      Do you have a recommended source for the 3A versions?
                      I purchased low priced Chinese make power supplies from eBay. I could get two 3A adaptors, in the price of one Canakit 2.5A adapter, but the delivery period was almost two months

                      https://www.ebay.ca/itm/172312291357

                      http://www.ebay.ca/itm/131813103356


                      I don't see PM's enabled on the boards, so I guess that is not an option if public display of products for sale is frowned upon (?)
                      No there is no PM in this forum, and no frowning upon as they understand we are trying to help/solve our problem, and not promoting any brand or product.


                      Blue FA Dongles.
                      FA dongles have built-in rf amplifier. By default, he gain is set to maximum value (49.6). Try reducing gain to different values such as 40, 35, 30 and see if it helps.

                      Also try gain -10, which is the only negative gain value accepted by the dongle, and switches the dongle to "automatic gain control" mode.

                      You can change setting of gain by typing in your browser address bar:

                      IP-of-Pi:8754/settings.html

                      Enter in field Process Arguments --gain xx, where xx is the gain value you want to set.

                      After entering gain as above, click "Save" button, then "Restart" button. Both buttons are at bottom-right corner of settings page.

                      Please see screenshot below.

                      FR24 settings - gain.png

                      Power supplies plugged directly into outlet.
                      The length of adaptor's AC chord does not make any difference on Pi's performance. The length of 5V DC wire between adaptor and Pi can affect Pi's performance if too long (say more than 2m or 6 ft) or is of poor quality with thin copper wires.
                      Last edited by abcd567; 2018-01-04, 23:16.

                      Comment


                      • #12
                        ^^ You may have misunderstood his first post/issue - above would apply if he was ONLY running FR24.

                        However as he has multiple feeders reporting as 'OK', It's possible one of those is doing the control of the USB stick (likely FA going by his install order) and FR24 is set to TCP...

                        In which case, pending any further info from him on the config page settings (not yet seen) one thing could be to adjust to 30005 from 30002
                        Posts not to be taken as official support representation - Just a helpful uploader who tinkers

                        Comment


                        • #13
                          @Oblivian: Thanks for pointing out that most likely he is not running Pi24 image. Sorry, I have missed that point.

                          @blacktop: The FR24 settings depends on the software installed. The screenshot I posted in my above post is applicable if you have installed Pi24 image, and did NOT install dump1090-fa or dump1090-mutability.

                          As rightly pointed out by Oblivian, you did not install Pi24 image. Can you please let us know
                          (1) Did you write on your microSD card the Raspbian image (downloaded from raspberrypi.org) or Piaware image (downloaded from flightaware.com)?

                          (2) If you have written Raspbian image (downloaded from raspberrypi.org), did you install dump1090-fa or dump1090-mutability?

                          (3) Please take a screenshot of your Pi's setting page (Ip-of-Pi:8754/settings.html) with cirrent settings, and post here. Remove your activation key from screenshot before posting.
                          Last edited by abcd567; 2018-01-05, 01:36.

                          Comment


                          • #14
                            FR24 FEEDER CONFIGURATION
                            If an external decoder (like dump1090-mutability, dump1090-fa) is installed, then select "Receiver: AVR(TCP)" and "HOST/IP: 127.0.0.1:30002". See screenshot below.

                            Settings page IP-of-Pi:8754/settings.html
                            FR24 Settings - external dump1090.jpg



                            If above settings dont solve problem of FR24 feed, try alternante settings
                            Receiver: ModeS Beast(TCP)" and "HOST/IP: 127.0.0.1:30005". See svreenshot below.

                            Settings page IP-of-Pi:8754/settings.html
                            FR24 Settings - Beast.jpg



                            NOTE:
                            After any changes made in settings, click "Save", and then "Restart" buttons. Both these buttons are located at bottom-right of settings page.




                            Status page IP-of-Pi:8754
                            FR24 Status - external dump1090.jpg
                            Last edited by abcd567; 2018-01-05, 02:38.

                            Comment

                            Working...
                            X