Announcement

Collapse
No announcement yet.

fr24feed suddenly terminating [BUG?]

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • #16
    Hi, I can also confirm with HNJAMeindersma that setting the ADS-B receiver to 'Beast-TCP' doesn't help with the crashing issue. In my case, it appeares to make it fail more often compared to 'AVR-TCP'.

    The best work-around I've found so far is to set the Pi to reboot each 24hours (at 4am) using the following steps:

    1. Login to the Pi via SSH
    2. Edit the crontab by typing: crontab -e
    3. Scroll to the bottom and on a new row, add the following: 0 4 * * * /sbin/shutdown -r now
    4. Save and exit the crontab and you're done.

    If any developer reads this - Fix the bugs in your software.

    Comment


    • #17
      What OS version and distribution are you running? Stretch?

      I have installed several feeders on a very lean distribution of jessie and never had this problem.

      (Not saying it doesn't need to be fixed, but narrowing down the problem would surely help the developers fix it...)

      /M
      F-ESDF1, F-ESGG1, F-ESGP1, F-ESNK1, F-ESNV2, F-ESNV3 F-ESSL4, F-LFMN3
      P-ESGR, P-ESIA, P-ESIB, P-ESGF
      mrmac (a) fastest.cc

      Comment


      • #18
        Hi MrMac,

        Thanks for your reply.

        To answer your question, I've tried both the FR24 Raspbian build and a vanilla Raspbian build with FRFEED24 installed - Both have the same issue with external avr-tcp receivers - They crash after a few hours/days.

        Comment


        • #19
          Here's a dump from my frfeed logs:

          2017-12-12 15:17:04 | [reader][i]Connection terminated
          2017-12-12 15:17:04 | [feed][n]disconnected
          2017-12-12 15:17:04 | [feed][n]waiting 24 seconds
          2017-12-12 15:17:09 | [reader][i]Connecting to AVR-TCP receiver via (avr-tcp://192.168.1.7:30005)
          2017-12-12 15:17:09 | [reader][i]Connected to the receiver, configuring
          2017-12-12 15:17:09 | [reader][i]Configured, processing messages
          2017-12-12 15:17:28 | [feed][n]YPCC1@83.140.21.85:8099/UDP
          2017-12-12 15:17:28 | [feed][n]connecting
          2017-12-12 15:17:49 | [feed][n]connected via TCP (fd -1)
          2017-12-12 15:17:49 | [feed][n]working
          2017-12-12 19:18:10 | [main][i]FR24 Feeder/Decoder <---------------------What happened to the last four hours?
          2017-12-12 19:18:10 | [main][i]Version: 1.0.18-9/generic
          2017-12-12 19:18:10 | [main][i]Built on Apr 20 2017 09:25:30 (T201704200925/Linux/static_arm)

          Comment


          • #20
            Hi, do you have a decent power supply - the stick uses a bit of power. I used abcd567's install process here and haven't had any problems with fr24feed exiting.

            Comment


            • #21
              I can confirm, I have the same problem. Please repair. Thank you

              Comment


              • #22
                Any chance of getting this fault acknowledge or fixed???

                Comment


                • #23
                  I have the same problem.
                  China Kunming
                  F-ZPPP1 T-ZPPP7

                  Comment


                  • #24
                    This is 3 months old. And has at least 2 different ( yet cannbe interpreted as similar) reported issues.

                    Replying 'i have same' does not pinpoint the exact individual findings. Nor supply anyone further information to compare setups for a possible causea or solution.

                    So do not be surprised if 'same problem' is not responded to.

                    Sent from my XT1092 using Tapatalk
                    Posts not to be taken as official support representation - Just a helpful uploader who tinkers

                    Comment


                    • #25
                      It'd be great if this wouldn't be 3 months old thread, and we had a solution already. My Pi also stops feeding everyday, at 7:02 AM exactly, local time. I have already a disk image that I restore everyday to get it running again quickly.

                      Imagen_21_1_18_11_00_pegada.jpg

                      I could attach logs, etc - but they're exactly the same as you can see in this thread. Changing settings, file permissions, apt-get upgrade & update, changing between dump1090 and -mutability version, setting different localhost, whatever... nothing works. It's just a normal Raspi 3, like the most common thing these days, and It's too tough to feed data to you guys. I also tried with another computer, and the same... so it's got to be something on FR's side.

                      Comment


                      • #26
                        For me this type of intermittent failure began to occur in January:

                        - The fr24feed log tail is always the same (such log already posted here)

                        - Html admin page on port 8754 is frozen with "FR24 Link: Disconnected"

                        - And fr24feed dies silently

                        Presently, for me the failure does not occur so often. Last times were:
                        Jan 18 20:03
                        Jan 20 18:55

                        To avoid big holes in my daily availability graph, I run a little script loop. It verifies every minute if fr24feed is still running. If not it traces the event in the syslog and relaunches fr24feed. The application resumes immediately.

                        while [ True ]
                        do
                        if ! pgrep fr24feed &>/dev/null ; then
                        logger "fr24mon >>>>>> fr24feed not running <<<<<<"
                        systemctl restart fr24feed
                        fi
                        sleep 60
                        done

                        My location: T-LFPC6

                        Comment


                        • #27
                          Hi Everyone,

                          There may be multiple issues that people are experiencing, but I encountered similar symptoms at some point and in my case I narrowed it down to being correlated with the timing of FR24's daily automatic update attempts. Given the recent troubles that scores of feeders are having as a result of two problematic updates beginning last week, I have revisited this matter. See /etc/cron.d/fr24feed_updater. Each day at 7am GMT (which is 2am in my local time), an update attempt gets made. Before last week, several months had gone by without any updates from FR24, but if I examine /var/log/apt/history.log I see two entries corresponding to FR24's recent update attempts:

                          Start-Date: 2018-01-16 07:00:56
                          Commandline: apt-get install -y fr24feed
                          Upgrade: fr24feed:armhf (1.0.18-9, 1.0.19-2)
                          Error: Sub-process /usr/bin/dpkg returned an error code (1)
                          End-Date: 2018-01-16 07:00:59

                          Start-Date: 2018-01-20 07:03:42
                          Commandline: apt-get install -y fr24feed
                          Upgrade: fr24feed:armhf (1.0.19-2, 1.0.19-5)
                          Error: Sub-process /usr/bin/dpkg returned an error code (1)
                          End-Date: 2018-01-20 07:03:44

                          Elsewhere on this forum, the very helpful gurus (e.g., Oblivian and abcd567) are recommending that people simply re-image the microSD cards and start afresh; however, this isn't a nice solution for those of us who attempt to operate a stable platform with multiple functions. In addition to FR24, my Raspberry Pi is also feeding to FlightAware, PlaneFinder, ADS-B Exchange, and RadarBox24. I see that others are similarly frustrated with FR24's track record and are contemplating dropping their support. In my case, I would prefer to disable the daily updater attempts at 0700Z in an effort to protect my platform from further surprise damage. Presumably one way to do this is to remove /etc/cron.d/fr24feed_updater and reboot. I will now do this until my confidence in FR24's capabilities is restored.

                          Best,
                          Andreas

                          Comment


                          • #28
                            Originally posted by AndreasWarby View Post
                            There may be multiple issues that people are experiencing, but I encountered similar symptoms at some point and in my case I narrowed it down to being correlated with the timing of FR24's daily automatic update attempts. Given the recent troubles that scores of feeders are having as a result of two problematic updates beginning last week, I have revisited this matter. See /etc/cron.d/fr24feed_updater. Each day at 7am GMT (which is 2am in my local time), an update attempt gets made.
                            I had the same idea, that it could be related. I never had the problem myself, but also I don't allow automated updates and have now disabled the autoupdater.

                            https://forum.flightradar24.com/thre...eed_updater-sh

                            For those who have this problem, it is worth a try.

                            /M
                            F-ESDF1, F-ESGG1, F-ESGP1, F-ESNK1, F-ESNV2, F-ESNV3 F-ESSL4, F-LFMN3
                            P-ESGR, P-ESIA, P-ESIB, P-ESGF
                            mrmac (a) fastest.cc

                            Comment


                            • #29
                              I could solve the problem using this after the auto-updater messsed up everything, for a lot of people including me, in these last days.

                              sudo dpkg --configure -a

                              cd /usr/lib/fr24
                              sudo ./install_dump1090.sh

                              Taken from this thread: -> forum.flightradar24.com/threads/11589-dump1090-issues-in-latest-feeder-package?p=100375

                              Fix for the missing stats issue: sudo chown -R dump1090:nogroup /run/dump1090-mutability

                              Thread to disable the autoupdater, given our past experiences it might be the best for the time being: -> forum.flightradar24.com/threads/11448-How-to-disable-fr24feed_updater-sh

                              A new version that supposedly doesn't mess up everything will be deployed soon, acording to some replies from FR24 staff by email to some forum members in those threads.

                              Comment


                              • #30
                                Hows the cron update failure looking with the latter versions?

                                Just as bad I take it? (have to wonder if some regions are triggering the CDN firewall being all the same time UTC)
                                Posts not to be taken as official support representation - Just a helpful uploader who tinkers

                                Comment

                                Working...
                                X