Announcement

Collapse
No announcement yet.

Raspberry PI installation made too easy with extra feature.

Collapse
This topic is closed.
X
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Originally posted by Winap View Post
    abcd567
    So if I have FlightRadar img. its not problem feed other sites?

    No problem. You can feed other sites also from Pi24 image


    Or I must delete it, install Linux, install FlightRadar, FlightAware..?

    You can, but not necessary.


    You have following 4 options. All are good.
    1. Write PI24 image (from FR24) to microSD card, set receiver=dvbt (with this setting, the integral dump1090-mutability ver 1.14 will be started), then install all other feeders.
      Note: MLAT feed back from Flightaware cannot be handled properly by dump1090-mutability ver 1.14. Therefore for display of Flightaware MLAT feedback on map, use option 2 or 3 or 4

    2. Write PI24 image (from FR24) to microSD card, set receiver=beast-tcp, then install either dump1090-mutability ver 1.15~dev OR dump1090-fa. Then install other feeders.
      Caution: with this option, when configuring fr24feed, do NOT use receiver=dvbt. Use receiver=beast-tcp

    3. Write Raspbian Lite image (from raspberrypi.org/downloads/raspbian ) to microSD card, then install either dump1090-mutability ver1.15~dev OR dump1090-fa, then install all feeders.
      Caution: with this option, when configuring fr24feed, do NOT use receiver=dvbt. Use receiver=beast-tcp

    4. Write Piaware image (from Flightaware) to microSD card (this has integral dump1090-fa and flightaware data feeder). Then install all other feeders.
      Caution: with this option, when configuring fr24feed, do NOT use receiver=dvbt. Use receiver=beast-tcp
    Last edited by abcd567; 2019-04-07, 21:08.

    Comment


    • Originally posted by abcd567 View Post
      I am feeding from RPi since beginning of 2015, i.e. 4 years, 24/7 continously, and the original 8 Gb, Class10 microSD card is still surviving & healthy. Further, I dont feed only fr24. I feed all the following sites from same RPi / microSD card:
      • FlightRadar24
      • FlightAware
      • Planefinder
      • RadarBox24
      • Open Sky Network
      • Adsbexchange
      Hi abcd567.

      First i wanna say that i love to read your post, and it's really help me get some info about "what is raspberry pi"
      i'm coming from "IT for PC" so it's a bit helpful, but still i have to learn raspberry pi from scratch.
      i have just one question.
      wouldn't be easy to make an iso image (like in pc) and upload it for everyone use ?
      is it possible, or each unit is unique, and you need to do the all installation from scratch ?
      thanks you for all your help here.

      Comment


      • Originally posted by ramimz View Post
        i have just one question.
        wouldn't be easy to make an iso image (like in pc) and upload it for everyone use ?
        is it possible, or each unit is unique, and you need to do the all installation from scratch ?
        Yes, such an image exists. It is .img, not .iso, but it is equally good.

        The first post of this thread gives the link to download this image, and detailed instructions to install.

        Comment


        • As someone who is totally new to this thank you for putting this post together. However even though I've followed your instructions regarding downloading and burning the image every time I put it in my Pi it won't boot (flashing red light). I've downloaded it several times on different pc's and burned the image to 3 different cards but still the same issue. Every other image I've burned is fine so am I missing something?

          Comment


          • I had never problem with image..
            Just download, unRAR image..
            In Rufus just open this image
            Rufus automaticaly format your micro SD card into 2 partitions.
            Then insert to PI..if will not boot after few second to 1 minute, try Off PI and ON..(restart)
            It must function..But rufus is good for that.
            Last edited by Winap; 2019-05-03, 16:02. Reason: mistake in word

            Comment


            • Which RPi version are you using?

              The image is most likely too old to support the 3A+ for example, not sure about other hardware versions.

              If you want an image that comes with a current version of dump1090, try for example OPTION 4 mention in this post:
              https://forum.flightradar24.com/thre...ll=1#post64528

              You can also just start with a Raspbian Stretch Lite and install dump1090-fa like mentioned in OPTION 3 of above link.
              dump1090-fa is the continuation of the dump1090-mutability development.

              Comment


              • I'm using a 3B+ so possibly that's the reason, thanks for mentioning it as it wouldn't have occurred to me.

                I've started following a guide so hopefully it will all go well considering I've got no Linux experience.

                Once I've got FR up and running I might see about feeding to more than one site.

                Comment


                • @theredguy
                  I personally prefer to use Raspbian image (OPTION- 3).

                  Both Pi24 image and Piaware image are stripped down and customised to one specific use: "To feed data to their site".

                  OPTION-3, i.e. using Raspbian Lite image from http://www.raspberrypi.org/downloads/raspbian , and installing the dump1090 of your choice (mutability or fa), and then installing only those data feeders which you want, is the most flexible and powerful install.

                  After burning the Raspbian image, and while the microSD card is still in card reader of your Desktop/Laptop, click on the drive letter of microSD card (will show as "boot"), and in opened folder, create a new text file, and name it ssh. This is necessary to enable SSH.
                  Last edited by abcd567; 2019-05-03, 17:50.

                  Comment


                  • I'm currently doing that one but am having an issue with building the dump 1090 mutability package at the moment.

                    I've followed the guide and got no error messages or issues till now, apparently there's something wrong with librtlsdr-dev and libusb-1.0-0-dev so it wont build.

                    Going to see if downloading them again helps.

                    Edit

                    Seems that librtlsdr didin't install correctly, seems to be ok now.
                    Last edited by theredguy; 2019-05-03, 17:52.

                    Comment


                    • If you don't want to compile dump1090-mutability you can just install dump1090-fa: (this doesn't include another feeder, it's just another dump1090 version)

                      Code:
                      wget http://flightaware.com/adsb/piaware/files/packages/pool/piaware/p/piaware-support/piaware-repository_3.6.3_all.deb
                      sudo dpkg -i piaware-repository_3.6.3_all.deb
                      sudo apt update
                      sudo apt upgrade -y
                      sudo apt remove -y dump1090-mutability dump1090
                      sudo lighty-disable-mod dump1090
                      sudo apt install -y dump1090-fa

                      Comment


                      • Thank you for the idea however everything is now done and I'm feeding to FR again along with the ability to view the dump feed like I wanted to.

                        I'll have a bash at some other feeds tomorrow along with making a four leg spider antenna.

                        Comment


                        • Originally posted by theredguy View Post
                          I'm currently doing that one but am having an issue with building the dump 1090 mutability package at the moment.

                          I've followed the guide and got no error messages or issues till now, apparently there's something wrong with librtlsdr-dev and libusb-1.0-0-dev so it wont build.

                          Going to see if downloading them again helps.

                          Edit

                          Seems that librtlsdr didin't install correctly, seems to be ok now.
                          I experienced this on a pi zero w build last week, I copy and pasted all the lines to get the dependencies and librtlsdr-dev and libusb-1.0-0-dev needed a second try guess Id have seen it if I did one at a time :-)


                          Sent from my iPhone using Tapatalk

                          Comment


                          • Hi, I have been working on this raspberry pi thing all week. Trying so hard to work around the drop of support for windows. Anyways..currently my problem is trying to boot from this image (or the pi24 one). I get this "light bolt error", which going by the card insert in the raspberry pi kit, I am not using Pi 3 B+ compatible software. Is there something I am missing?
                            thanks!

                            Comment


                            • @catsartcox

                              Use OPTION (B) of this thread:

                              How to Feed Data to Multiple Sites - A Brief Guide

                              Comment


                              • I've just had to approve another 4 posts the forum prevented because they keep replying to you when you use @s.

                                PLEASE STOP
                                Posts not to be taken as official support representation - Just a helpful uploader who tinkers

                                Comment

                                Working...
                                X