Announcement

Collapse
No announcement yet.

Raspberry PI installation made too easy with extra feature.

Collapse
This topic is closed.
X
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • #31
    Originally posted by AndreasWarby View Post
    Hi there,

    I use the OpenADSB iOS app fairly frequently, and like it very much. For the "local" Track Source, I use http:/ myRPiHostName.local/dump1090/ as the Base URL.

    Best,
    Andreas
    Thanks I was over thinking and didnít realise it was as easy as putting in myRPiHostName.local/dump1090/ to the source :-) it didnít need the http as it then added it to the url

    Really like the way the app allows that and can switch between multiple sources ie adsb-exchange or my own pi :-)

    Iím not sure if I feed adsb-exchange at present will look at back at the 1st post and consider adding the package :-)


    Sent from my iPhone using Tapatalk

    Comment


    • #32
      I have another one of those dumb questions ! It looks to me like the range rings are set to 25km and therefore the settings are km and not miles as I want. I have looked and changed every config.js file i can find on the Pi but nothing changes. I have also tried to change the colour of the rings but they also never change. I have edited all these files and have also tried changing the clock just in case I'm missing something. Any help appreciated.

      /usr/lib/fr24/public_html/config.js
      /usr/share/dump1090-mutability/html/config.js
      /usr/share/dump1090-mutability/orig-html/config.js
      /root/adsb-receiver/build/portal/html/dump978/config.js
      /root/adsb-receiver/build/dump1090-mutability/dump1090/public_html/config.js
      /root/adsb-receiver/build/dump1090-mutability/dump1090/debian/dump1090-mutability/usr/share/dump1090-mutability/html/config.js
      /var/www/html/dump978/config.js

      Comment


      • #33
        hoppo1

        (1) Open file config.js for editing:
        Code:
        sudo nano /usr/share/dump1090-mutability/html/config.js
        (2) In the file opened, scroll down till you see the following line:

        Metric=“false;”

        (3) Remove the quotes " " around false;
        Removing quotes " " will make it like below:

        Metric=false;

        (4) Save file (Ctrl+o) and close it (Ctrl+x)

        (5) Open map in browser, clear browser cache (Ctrl+Shift+Delete) then reload browser.

        Range Circles diameters will now be in nautical miles.

        Comment


        • #34
          Thanks for the reply, I have already amended that. The issue is no matter what I set in that particular file is not reflected on the dump1090 page. I have even deleted that file and the site still loads ok.

          I have edited every single config.js I can find but it does not change. Its like its getting its config elsewhere but i cannot find it.

          /usr/lib/fr24/public_html/config.js
          /usr/share/dump1090-mutability/html/config.js
          /usr/share/dump1090-mutability/orig-html/config.js
          /root/adsb-receiver/build/portal/html/dump978/config.js
          /root/adsb-receiver/build/dump1090-mutability/dump1090/public_html/config.js
          /root/adsb-receiver/build/dump1090-mutability/dump1090/debian/dump1090-mutability/usr/share/dump1090-mutability/html/config.js
          /var/www/html/dump978/config.js

          Comment


          • #35
            hoppo1

            This may be due to browser.

            Browsers use saved old files in their cache, instead of downloading the files from source everytime. As a result whatever editing you do to config.js, wont show.

            (1) Clear browser cache (press Ctrl+Shift+Delete keys togather) and Reload (press Ctrl+F5 keys togather)

            (2) Some browsers are stubborn, and dont delete all cached file even when cache is cleared. If clearing cache dont solve the problem, use another browser, for example if you are using Firefox, try Google Chrome or Internet Explorer.
            Last edited by abcd567; 2018-09-07, 11:44.

            Comment


            • #36
              Originally posted by abcd567 View Post
              hoppo1

              This may be due to browser.

              Browsers use saved old files in their cache, instead of downloading the files from source everytime. As a result whatever editing you do to config.js, wont show.

              (1) Clear browser cache (press Ctrl+Shift+Delete keys togather) and Reload (press Ctrl+F5 keys togather)

              (2) Some browsers are stubborn, and dont delete all cached file even when cache is cleared. If clearing cache dont solve the problem, use another browser, for example if you are using Firefox, try Google Chrome or Internet Explorer.
              Ahhh I feel daft now. That was the issue... Once cleared it all started working.

              Comment


              • #37
                What did do wrong ?

                I extract the BIN File to the Micro SD Card but i just git a 20 MB Partition with some OS Files and a Empty 2nd Partition with 1.4 GB
                And of course nothing is working on my Rasberry.

                Comment


                • #38
                  Originally posted by Damianiw View Post
                  Thanks I was over thinking and didnít realise it was as easy as putting in myRPiHostName.local/dump1090/ to the source :-) it didnít need the http as it then added it to the url

                  Really like the way the app allows that and can switch between multiple sources ie adsb-exchange or my own pi :-)

                  Iím not sure if I feed adsb-exchange at present will look at back at the 1st post and consider adding the package :-)


                  Sent from my iPhone using Tapatalk
                  Hi dump1090 has stopped working returning an Ajax error, planefinder and fr24 are still feeding and local plane finder map is working Iím going to try an apt-get update anyone seen similar ?


                  Sent from my iPhone using Tapatalk

                  Comment


                  • #39
                    Originally posted by vielflieger View Post
                    What did do wrong ?

                    I extract the BIN File to the Micro SD Card but i just git a 20 MB Partition with some OS Files and a Empty 2nd Partition with 1.4 GB
                    And of course nothing is working on my Rasberry.
                    You need to write the image to the sd-card with a tool like Win32DiskImager or Etcher if you're on a windows pc.

                    Comment


                    • #40
                      Raspberry PI installation made too easy with extra feature.

                      Originally posted by Damianiw View Post
                      Hi dump1090 has stopped working returning an Ajax error, planefinder and fr24 are still feeding and local plane finder map is working Iím going to try an apt-get update anyone seen similar ?


                      Sent from my iPhone using Tapatalk
                      Hi Iím still not able to resolve this error, flight aware and itís map is running as is flight radar so I think I need to look into dump1090

                      I noted the ipv6 issues and made the amendments recommended but still the same could anyone help point me in the right direction - I documented the steps I took to install so will work back through them


                      Sent from my iPhone using Tapatalk

                      Comment


                      • #41
                        Originally posted by SlashbNL View Post
                        You need to write the image to the sd-card with a tool like Win32DiskImager or Etcher if you're on a windows pc.
                        This i did ..but why is the file 1,x Gig and after write to the SD Card i just got a small MB Drive (around 20) and a 2nd 1,4 GB empty Drive on the SD Card.
                        If i use the SD Card i just see a rainbow on my blackberry. Screen

                        Flightware BIN is working fine withy my Rasberry.

                        Comment


                        • #42
                          Originally posted by vielflieger View Post
                          This i did ..but why is the file 1,x Gig and after write to the SD Card i just got a small MB Drive (around 20) and a 2nd 1,4 GB empty Drive on the SD Card.
                          If i use the SD Card i just see a rainbow on my blackberry. Screen

                          Flightware BIN is working fine withy my Rasberry.
                          2 separate SD cards, or using the same?

                          'Rainbow' as everyone puts it is the screen test. It remains on screen if no valid OS boots
                          https://elinux.org/R-Pi_Troubleshoot..._splash_screen

                          Commonly, bad SD card, wrongly formatted (and then imaged SD), or incompatibility
                          Posts not to be taken as official support representation - Just a helpful uploader who tinkers

                          Comment


                          • #43
                            Hi firstly thanks for this guide I followed it a while ago and got my original rpi model b up and running unfortunately Iím now seeing this error

                            Itís feeding everywhere ok just the map has got this Ajax error so I canít use it or the open Adsb iOS app

                            Iím thinking of grabbing a spare SD and starting again in case itís a corruption issue, Iíve tried updating and rebooting and also saw the threads about ipv6 and tried those suggestions just in case as I notice the fr24 monitor page is listing my ipv4 but also ipv6 addresses - Iím with BT and I think they issued a router update in August which they are now Ďtestingí or more correctly Ďfiddlingí as my router will sometimes say ipv6 enabled and other times not - could be just coincidence but I changed nothing before it stopped working so something external changed possibly isp, or open street maps / google

                            The piaware page works but complains about something on google maps hence my adding google above

                            Should I be looking to start with the image on the first thread or should I download a fresh base image for raspian lite on a newer release ?


                            Sent from my iPhone using Tapatalk

                            Comment


                            • #44
                              Damianiw

                              (1) Give command: sudo systemctl restart dump1090-mutability

                              Alternatively reboot Pi.

                              (2) Clear Browser Cache: Press (Ctrl+Shift+Delete) Keys simultaneously

                              (3) Reload Browser: Press (Ctrl+F5) Keys simultaneously

                              IF all above does not work, check if your Dongle is plugged-in firmly. Un-plug and Re-plug it. If dongle is connected using a USB extender cable, remove cable and connect directly, or try another cable.

                              If all that does not work, then it seems your installation is broken. In this case the best solution is a fresh install:

                              EITHER:
                              Download and write image as shown in first post of this thread

                              OR
                              Do following:
                              - Download Raspbian Stretch LITE image from http://raspberrypi.org/downloads/raspbian/
                              - Write downloaded Raspbian image to your microSD Card.
                              - FIRST software you should install is dump1090-mutability ver 1.15~dev.
                              - Feeders should be installed AFTER dump1090-mutability has been installed.
                              - Do NOT select option "Receiver = DVBT" in FR24 feeder configuration, otherwise your dump1090-mutability will be downgraded from ver 1.15 to ver 1.14

                              Comment


                              • #45
                                Thanks I've started a fresh install and have map working now to setup feeders

                                Sent from my SM-G900F using Tapatalk

                                Comment

                                Working...
                                X