Announcement

Collapse
No announcement yet.

FR24feed only on a Raspberry Pi using a FlightAware Pro Stick Plus ADS-B USB Receiver

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • FR24feed only on a Raspberry Pi using a FlightAware Pro Stick Plus ADS-B USB Receiver

    hi I am trying to set up a RPi 3 Model B with the FR24feed software including dump1090 included with FR24 and a FlightAware Pro Stick Plus ADS-B USB Receiver with Built-in Filter. Everything is running except the link with the FA dongle. I am getting
    Found 1 device(s):
    0: Realtek, RTL2832U, SN: 00001000

    Using device 0: Generic RTL2832U
    rtlsdr_demod_write_reg failed with -1
    rtlsdr_demod_read_reg failed with -1
    rtlsdr_demod_write_reg failed with -1
    rtlsdr_demod_read_reg failed with -1
    rtlsdr_demod_write_reg failed with -1
    rtlsdr_demod_read_reg failed with -1
    rtlsdr_demod_write_reg failed with -1
    rtlsdr_demod_read_reg failed with -1
    rtlsdr_demod_write_reg failed with -1
    rtlsdr_demod_read_reg failed with -1
    rtlsdr_demod_write_reg failed with -1
    rtlsdr_demod_read_reg failed with -1
    rtlsdr_demod_write_reg failed with -1
    rtlsdr_demod_read_reg failed with -1
    rtlsdr_demod_write_reg failed with -1
    rtlsdr_demod_read_reg failed with -1
    rtlsdr_demod_write_reg failed with -1
    rtlsdr_demod_read_reg failed with -1
    rtlsdr_demod_write_reg failed with -1
    rtlsdr_demod_read_reg failed with -1
    rtlsdr_demod_write_reg failed with -1
    rtlsdr_demod_read_reg failed with -1
    rtlsdr_demod_write_reg failed with -1
    rtlsdr_demod_read_reg failed with -1
    rtlsdr_demod_write_reg failed with -1
    rtlsdr_demod_read_reg failed with -1
    rtlsdr_demod_write_reg failed with -1
    rtlsdr_demod_read_reg failed with -1
    rtlsdr_read_reg failed with -1
    rtlsdr_write_reg failed with -1
    rtlsdr_read_reg failed with -1
    rtlsdr_write_reg failed with -1
    rtlsdr_read_reg failed with -1
    rtlsdr_write_reg failed with -1
    rtlsdr_read_reg failed with -1
    rtlsdr_write_reg failed with -1
    No supported tuner found
    rtlsdr_demod_write_reg failed with -1
    rtlsdr_demod_read_reg failed with -1
    rtlsdr_demod_write_reg failed with -1
    rtlsdr_demod_read_reg failed with -1
    rtlsdr_demod_write_reg failed with -1
    rtlsdr_demod_read_reg failed with -1
    rtlsdr_demod_write_reg failed with -1
    rtlsdr_demod_read_reg failed with -1
    Enabled direct sampling mode, input 1
    rtlsdr_demod_write_reg failed with -1
    rtlsdr_demod_read_reg failed with -1
    rtlsdr_demod_write_reg failed with -1
    rtlsdr_demod_read_reg failed with -1
    rtlsdr_demod_write_reg failed with -1
    rtlsdr_demod_read_reg failed with -1
    rtlsdr_demod_write_reg failed with -1
    rtlsdr_demod_read_reg failed with -1
    Supported gain values (1): 0.0
    rtlsdr_demod_write_reg failed with -1
    rtlsdr_demod_read_reg failed with -1
    rtlsdr_demod_write_reg failed with -1
    rtlsdr_demod_read_reg failed with -1
    rtlsdr_demod_write_reg failed with -1
    rtlsdr_demod_read_reg failed with -1
    rtlsdr_demod_write_reg failed with -1
    rtlsdr_demod_read_reg failed with -1
    rtlsdr_demod_write_reg failed with -1
    rtlsdr_demod_read_reg failed with -1
    rtlsdr_demod_write_reg failed with -1
    rtlsdr_demod_read_reg failed with -1
    WARNING: Failed to set sample rate.
    No E4000 tuner found, aborting.
    rtlsdr_write_reg failed with -1

    I used the instructions on the website wiganpi.online as a guide to installing the DVBT RTL SDR software ONLY the rest was from FR24 guide. Can someone help me resolve this issue? Best Regards pizzapilot

  • #2
    I don't think you can class that as 'everything is running...'

    That is the core component to receive data not going.

    What method did you install.

    Pi24 image
    Separate Install guide
    FR24feed install script?

    That looks like commands from just RTL_Test or similar? New units don't have E4000 tuners, but Rafael R8210T/T2. Which tells me whatever is connecting there is rather old

    Which guide on that site did you follow?

    More info required to point you in the right direction. However a few linux commands and tests.. https://forum.flightradar24.com/thre...-FAQs-and-Info
    Last edited by Oblivian; 2017-06-22, 12:15.
    Posts not to be taken as official support representation - Just a helpful uploader who tinkers

    Comment


    • #3
      And a quick google also points to potential power supply issues not starting the USB device.

      What power supply is being used? Standard USB is not enough, but an external PSU needed
      Posts not to be taken as official support representation - Just a helpful uploader who tinkers

      Comment


      • #4
        PSU and Install

        Originally posted by Oblivian View Post
        And a quick google also points to potential power supply issues not starting the USB device.

        What power supply is being used? Standard USB is not enough, but an external PSU needed
        Hi and thanks for responding. I used a clean SD card and built a NOOBS image and then updated it and installed fr24feed using the instructions and download on the FR24 website. I noticed it was not feeding from the dongle and the fr24 software so I found a posting on the website wiganpi.online that worked on another RPI that I am using in a different location but is using a NoElec dongle.

        The power is being provided by a official Official Raspberry Pi power supply rated at 2.5 amps. The Raspberry Pi is a Model B not a 2 or 3 Model B.

        Best Regards

        pizzapilot

        Comment


        • #5
          These are the instructions I followed, not allowed to post the link as a new member of the forum

          4. Setting up the DVB-T dongle

          Unlike Windows computers, software for RPi computers is regularly updated. It is also usually compiled from source code rather than just being installed and run. Don’t worry if this doesn’t make any sense – all it means is that there’s a few extra steps to take !

          We need to install the software which will allow us to compile programs from source code. To do that enter:

          cd ~
          sudo apt-get install git-core

          If you get a message telling you that it’s already installed that’s fine otherwise it’ll install it.

          Now we need to get the code to recognise the USB dongle as it’s not automatically recognised. If you’re asked any questions, just accept the default option. To get started enter:


          sudo apt-get install git
          sudo apt-get install cmake
          sudo apt-get install libusb-1.0-0-dev
          sudo apt-get install build-essential

          Once that’s done, we can actually get the code to communicate with the dongle:


          git clone git://git.osmocom.org/rtl-sdr.git
          cd rtl-sdr
          mkdir build
          cd build
          cmake ../ -DINSTALL_UDEV_RULES=ON
          make
          sudo make install
          sudo ldconfig

          The last command should produce no output. If that’s the case then you’ve got the dongle installed so now we can tell it what it’s allowed to do:


          cd ~
          sudo cp ./rtl-sdr/rtl-sdr.rules /etc/udev/rules.d/
          sudo reboot

          The RPi will reboot so log back in as before and then enter the command:

          rtl_test -t

          If you get an error message like this:

          Using device 0: Generic RTL2832U OEM
          Kernel driver is active, or device is claimed by second instance of librtlsdr.
          In the first case, please either detach or blacklist the kernel module
          (dvb_usb_rtl28xxu), or enable automatic detaching at compile time.
          usb_claim_interface error -6
          Failed to open rtlsdr device #0.
          Here’s the fix:

          sudo nano /etc/modprobe.d/no-rtl.conf

          Add the following lines to the file:

          blacklist dvb_usb_rtl28xxu
          blacklist rtl2832
          blacklist rtl2830
          And save it as before. Reboot once again:

          sudo reboot and log in and then issue the command to test the dongle again:

          rtl_test -t

          If all is well then you should see something like this:

          Found 1 device(s):
          0: Realtek, RTL2838UHIDIR, SN: 00000001
          Using device 0: Generic RTL2832U OEM
          Found Rafael Micro R820T tuner
          Supported gain values (29): 0.0 0.9 1.4 2.7 3.7 7.7 8.7 12.5 14.4 15.7 16.6 19.7 20.7 22.9 25.4 28.0 29.7 32.8 33.8 36.4 37.2 38.6 40.2 42.1 43.4 43.9 44.5 48.0 49.6
          Sampling at 2048000 S/s.
          No E4000 tuner found, aborting.

          Comment


          • #6
            The majority of that is done as part of the fr24 script. It's made to be fire and forget.

            Use some of the fr24 feed visual outputs (dump1090) to check if the e4000 message is false, out due to the rtl lib version changed after appropriate aptget updates

            Sent from my XT1092 using Tapatalk
            Posts not to be taken as official support representation - Just a helpful uploader who tinkers

            Comment


            • #7
              @PizzaPilot,

              I'm running a FA Pro+ on a Pi3 with the Pi3's standard 2.0A power supply and no powered USB hub, and it works flawlessly. In fact, i've got two SDRs plugged in. But you've said that you're using an older pi, and I have no idea whether they can supply enough power to drive the SDR properly. Here's what I'd suggest:

              First, just as a sanity check, make sure fr24feed is running as root. Either start it manually with sudo or, once running in the usual way, invoke

              Code:
              ps faux|grep fr24feed
              You may see two lines of output, including the grep process itself. The first element on each line is the username who owns the process, make sure that's root for fr24feed.

              If you've got a powered USB hub, try that also just to eliminate the question of the power supply.

              Assuming that's all correct, eliminate the FA stick itself as a problem by attaching it to a computer. if it's windows, you'll have to faff about with replacing the driver with zadog or whatever it is. Try SDR# and try tuning into a really strong local FM radio station. It will have to be powerful enough to be picked up post the bandpass filter. You might have to fool around with the gain settings a bit because of the possibility of intermod noise from the auxiliary LNA that the Pro and Pro+ has.

              If that works, then reattach the FA Pro+ to the pi and start working the problem from the rtl_sdr library. It's possible that libusb is not working properly, but that's not so easy to test.

              Use rtl_test to make sure baseline is happy. Try rtl_tcp or rtl_fm (more complicated to set up) and repeat the exercise of tuning into an FM station although, in truth, static would do equally well by this point because all we care about is whether there are problems with register writes. If you use rtl_tcp, you need to set SDR# to use a fairly small bandwidth unless you're using wired Ethernet.

              Be sure to do everything as root just to eliminate the possibility of permissions problems. Many RTL_SDR applications work as unprivileged users, but some (like rtl_airband) do not even on a correctly configured system.

              If you have problems with the basic rtl_sdr tools (as root) and yet the SDR works on another machine, that points to rtl_sdr library itself. I don't know how well the osmocom library is maintained these days. I don't use it; instead, I use the Keenerd's variant (git clone https://github.com/keenerd/rtl-sdr.git). You might try that.

              If all seems well at the rtl_sdr level, then see what happens when using dump1090 and not FR24's fork or build of it, either. I recommend dump1090-mutability (https://github.com/mutability/dump1090.git) because that has a fairly decent web interface that will let you see planes moving about, plus it has more sophisticated signal processing in it than most other variants (though these need to be turned on explicitly).

              -mutability provides installation instructions. I'd suggest not doing the final 'make install' step unless you plan to switch from fr24's dump1090 instance to -mutability (which I recommend, but it's not straight forward to do). Instead, run it from the build directory. Make sure you first shut down fr24feed and its own dump1090 instance as well, if that runs as a separate daemon. Note that you'll have to examine the dump1090 arguments and set them accordingly. The JSON output required by the web server is not enabled by default, and you'll have to manually mkdir the directory in question. For reference, here's my full dump1090-mutability command line, but note that the init script gets its settings from /etc/default/dump1090-mutability rather than being specified directly.

              Code:
              $ sudo cat /proc/$(cat /run/dump1090-mutability.pid)/cmdline | tr '\0' ' '; echo
              
              /usr/local/bin/dump1090-mutability --net --gain 25 --fix --lat [x.xxx] --lon [y.yyy] --max-range 300 --net-ri-port 30001 --net-ro-port 30002 --net-bi-port 30004 --net-bo-port 30005 --net-sbs-port 30003 --net-buffer 0 --write-json /run/dump1090-mutability --write-json-every 0.75 --json-location-accuracy 2 --quiet --phase-enhance --oversample --aggressive --mlat
              The first line shows how I get that output, and it depends on locating the right PID file. That's correct for my instance, but it may not be for yours. You can always substitute the $(cat ...) bit for the numeric PID from the output of ps faux|grep dump1090, or else just examine the output of that grep line (which will also contains the command line).

              In order to get the web interface, you'll have to install lighttpd and the associated configuration file from -mutability's repo.

              If that all works, then you know the problem is with your fr24feed installation. However, one solution may be to install -mutability properly, get it running as a service, make sure it starts up properly in preference to fr24feed's, and then reconfigure fr24feed to use AVR-TCP to talk to dump1090-mutability.

              Be sure to include the --mlat flag to dump1090 if you want to contribute MLAT data. There is other stuff you might need to tweak, including gain. For some, autogain (ie gain set -10) works well on the FA Pro+, but it doesn't for me because I get a lot of intermod noise even despite the Pro+'s bandpass filter. (One of these days, I'll invest in a good quality cavity or ceramic filter.) But all such problems will manifest in poor plane counts, not in error messages of the type you described.

              Comment


              • #8
                Strix technical - Thank-you for your detail response and help. I am a complete novice to LINUX so forgive my ignorance. I tried the "ps faux|grep fr24feed" and got the following response "pi@raspberrypi:~ $ ps faux|grep fr24feed
                pi 9556 0.0 1.0 4268 1872 pts/0 S+ 11:51 0:00 \_ grep --color=auto fr24feed
                root 634 0.1 2.0 73156 3832 ? Sl Jun22 1:50 /usr/bin/fr24feed -- --monitor-file=/dev/shm/fr24feed.txt --write-pid=/var/run/fr24feed.pid --quiet --log-base=/var/log/fr24feed --log-rotate=2
                pi@raspberrypi:~ $ "

                So it appears that the second line is using "pi" rather than root. I always sign on as user "pi" should I be signing on differently? When I start and stop the fr24feed manually I use sudo service fr24feed stop and sudo service fr24feed start should I be using "service" in the command? It appears whatever I am doing does not always stop the processes

                Best Regards

                pizzapilot

                Comment


                • #9
                  Originally posted by pizzapilot View Post
                  Strix technical - Thank-you for your detail response and help. I am a complete novice to LINUX so forgive my ignorance. I tried the "ps faux|grep fr24feed" and got the following response "pi@raspberrypi:~ $ ps faux|grep fr24feed
                  pi 9556 0.0 1.0 4268 1872 pts/0 S+ 11:51 0:00 \_ grep --color=auto fr24feed
                  root 634 0.1 2.0 73156 3832 ? Sl Jun22 1:50 /usr/bin/fr24feed -- --monitor-file=/dev/shm/fr24feed.txt --write-pid=/var/run/fr24feed.pid --quiet --log-base=/var/log/fr24feed --log-rotate=2
                  pi@raspberrypi:~ $ "

                  So it appears that the second line is using "pi" rather than root. I always sign on as user "pi" should I be signing on differently? When I start and stop the fr24feed manually I use sudo service fr24feed stop and sudo service fr24feed start should I be using "service" in the command? It appears whatever I am doing does not always stop the processes

                  Best Regards

                  pizzapilot
                  Nooo. Run commands 'as' root. 'sudo'. Never as root.

                  Hence all the mention onf [i[sudo[/i] xxx this and that.

                  If you ever run 'service' it runs in background. not foreground. So if you consequently start it again - collisions of hardware access. Likewise if you install 1 providers program that connects to the USB device. Nothing else can.

                  https://forum.flightradar24.com/thre...ll=1#post74834
                  Posts not to be taken as official support representation - Just a helpful uploader who tinkers

                  Comment


                  • #10
                    Originally posted by pizzapilot View Post
                    So it appears that the second line is using "pi" rather than root. I always sign on as user "pi" should I be signing on differently? When I start and stop the fr24feed manually I use sudo service fr24feed stop and sudo service fr24feed start should I be using "service" in the command? It appears whatever I am doing does not always stop the processes
                    That output says that fr24feed is running as root, so you're alright there. The problem is somewhere else.

                    And as Oblivian said, you're doing the right thing by logging in as 'pi' and using 'sudo' to execute commands as root.

                    Go through the other debugging steps to ensure that your receiver is okay and that dump1090 is working properly.

                    s.

                    PS: (it's 'technica', not 'technical'. My nick is a play on Linnaean taxonomy of species; 'Strix' is the genus of many species of owl.)

                    Comment


                    • #11
                      I also use Flightaware's Pro Stick, and Raspbian Jessie Lite.
                      After going through this thread, I decided to install fr24feed on NOOBS
                      NOTE
                      I did NOT install any software other than:

                      (1) NOOBS
                      (2) FR24 FEEDER by bash script sudo bash -c "$(wget -O - http://repo.feed.flightradar24.com/install_fr24_rpi.sh)"
                      It seems pizzapilot's problem is caused by following instructions on website wiganpi.online

                      This is what I have done
                      (1) Formatted microSD Card
                      (2) Downloaded and installed NOOBS
                      (3) Installed, signedup, and configured fr24feed using bash script:
                      sudo bash -c "$(wget -O - http://repo.feed.flightradar24.com/install_fr24_rpi.sh)"

                      #updated noobs
                      sudo apt-get update

                      #installed fr24feed
                      sudo bash -c "$(wget -O - http://repo.feed.flightradar24.com/install_fr24_rpi.sh)"

                      #above install completed and automatically started signup
                      #completed signup as below

                      Step 1.1 - Enter your email address (username@domain.tld)
                      $:xxxx@yyyyyy.com

                      Step 1.2 - If you used to feed FR24 with ADS-B data before enter your sharing key.
                      If you don't remember your sharing key, pelase use the retrival form:
                      http://feed.flightradar24.com/forgotten_key.php

                      Otherwise leave this field empty and continue.
                      $:xxxxxxxxxxxxxxxx

                      Verifying sharing key...OK



                      Step 1.3 - Would you like to participate in MLAT calculations? (yes/no)$:yes

                      IMPORTANT: For MLAT calculations the antenna's location should be entered very precise!

                      Step 3.A - Enter antenna's latitude (DD.DDDD)
                      $:43.5xxx

                      Step 3.B - Enter antenna's longitude (DDD.DDDD)
                      $:-79.6xxx

                      Step 3.C - Enter antenna's altitude above the sea level (in feet)
                      $:4xx

                      Using latitude: 43.5xxx, longitude: -79.6xxx, altitude: 4xxft above sea level

                      Step 4.1 - Receiver selection (in order to run MLAT please use DVB-T stick with dump1090 utility bundled with fr24feed):

                      1 - DVBT Stick (USB)
                      -----------------------------------------------------
                      2 - SBS1/SBS1er (USB/Network)
                      3 - SBS3 (USB/Network)
                      4 - ModeS Beast (USB/Network)
                      5 - AVR Compatible (DVBT over network, etc)
                      6 - microADSB (USB/Network)
                      7 - SBSx via Basestation (localhost:30006)


                      Enter your receiver type (1-7)$: 1
                      Checking for dump1090...FOUND

                      Step 4.3 - Enter your additional dump1090 arguments or leave empty
                      $:--net --net-http-port 8080 --net-bo-port 30005 --gain 30

                      Step 5.1 - Would you like to enable RAW data feed on port 30002 (yes/no)$:no

                      Step 5.2 - Would you like to enable Basestation data feed on port 30003 (yes/no)$:no

                      Step 6A - Please select desired logfile mode:
                      0 - Disabled
                      1 - 48 hour, 24h rotation
                      2 - 72 hour, 24h rotation
                      Select logfile mode (0-2)$:0


                      Step 6B - Please enter desired logfile path (/var/log):
                      $:/var/log

                      Submitting form data...OK

                      Congratulations! You are now registered and ready to share ADS-D data with Flightradar24.
                      + Your radar id is T-CYYZ21, please include it in all email communication with us.
                      + Please make sure to start sharing data within the next 3 days as otherwise your ID/KEY will be deleted.

                      Thank you for supporting Flightradar24! We hope that you will enjoy our Premium services that will be available to you when you become an active feeder.

                      To start sending data now please execute:
                      sudo service fr24feed start

                      Saving settings to /etc/fr24feed.ini...OK
                      Settings saved, please run "sudo service fr24feed restart" to use new configuration.
                      Installation and configuration completed!


                      (4) Checked status in browser at address http://<IP of Pi>:8754, it shows:

                      FR24 Link: Connected via UDP
                      FR24 Radar Code: T-CYYZ21
                      Aircraft Tracked (ModeS & ADS-B): 123
                      Aircraft Uploaded: 81
                      Receiver: dvbt, Connected
                      MLAT running: YES



                      (5) checked fr24feed
                      #IMPORTANT: First stop fr24feed currently running in background
                      sudo service fr24feed stop

                      #Now start fr24feed manually to run in foreground, displaying all interactions
                      sudo fr24feed

                      ______ _ _ _ _ _ _____ ___
                      | ___|| |(_) | | | | | | / __ \ / |
                      | |_ | | _ __ _ | |__ | |_ _ __ __ _ __| | __ _ _ __`' / /' / /| |
                      | _| | || | / _` || '_ \ | __|| '__|/ _` | / _` | / _` || '__| / / / /_| |
                      | | | || || (_| || | | || |_ | | | (_| || (_| || (_| || | ./ /___\___ |
                      \_| |_||_| \__, ||_| |_| \__||_| \__,_| \__,_| \__,_||_| \_____/ |_/
                      __/ |
                      |___/
                      2017-06-28 11:00:50 | [main][i]FR24 Feeder/Decoder
                      2017-06-28 11:00:50 | [main][i]Version: 1.0.18-9/generic
                      2017-06-28 11:00:50 | [main][i]Built on Apr 20 2017 09:25:30 (T201704200925/Linux/static_arm)
                      2017-06-28 11:00:50 | [main][i]Copyright 2012-2017 Flightradar24 AB
                      2017-06-28 11:00:50 | [main][i]http://flightradar24.com
                      2017-06-28 11:00:50 | [main][i]DNS mode: PING
                      2017-06-28 11:00:50 | [main][i]Automatic updates are DISABLED
                      2017-06-28 11:00:50 | ERROR
                      2017-06-28 11:00:50 | [httpd][i]Server started, listening on 0.0.0.0:8754
                      2017-06-28 11:00:50 | [master][i]Starting processing thread
                      2017-06-28 11:00:50 | [main][i]Reader thread started
                      2017-06-28 11:00:50 | [reader][i]Initializing reader
                      2017-06-28 11:00:50 | [reader][i]Connecting to DVBT receiver via (exe:///usr/lib/fr24/dump1090 --net --net-http-port 8080 --net-bo-port 30005 --gain 30 --raw --mlat)
                      2017-06-28 15:00:50 | [main][i]MLAT data feed started
                      2017-06-28 11:00:50 | [reader][i]Connected to the receiver, configuring
                      2017-06-28 11:00:50 | [reader][i]Configured, processing messages
                      2017-06-28 11:00:50 | [mlat][i]Waiting for MLAT configuration
                      Found 1 device(s):
                      0: Realtek, RTL2832UFA, SN: 00001000 (currently selected)
                      Found Rafael Micro R820T tuner
                      Setting gain to: 30.00
                      Exact sample rate is: 2000000.052982 Hz
                      Gain reported by device: 30.00
                      2017-06-28 11:00:51 | [reader][w]Setting new UTC offset: 0!
                      2017-06-28 11:00:51 | [time][i]Synchronizing time via NTP
                      2017-06-28 11:01:22 | [time][i]Time synchronized correctly, offset -0.0016 seconds
                      2017-06-28 11:01:22 | [main][i]Feed Network client started
                      2017-06-28 11:01:22 | [feed][i]Downloading configuration
                      2017-06-28 11:01:23 | [feed][c]Interval: 5s
                      2017-06-28 11:01:23 | [feed][c]Latitude: 43.5xxx
                      2017-06-28 11:01:23 | [feed][c]Longitude: -79.6xxx
                      2017-06-28 11:01:23 | [feed][c]GND: YES
                      2017-06-28 11:01:23 | [feed][c]NonADSB: YES
                      2017-06-28 11:01:23 | [feed][c]Timestamps: optional
                      2017-06-28 11:01:23 | [feed][c]Max range AIR: 350.0nm
                      2017-06-28 11:01:23 | [feed][c]Max range GND: 100.0nm
                      2017-06-28 11:01:23 | [feed][i]defined 5 servers
                      2017-06-28 11:01:23 | [stats][i]Stats thread started
                      2017-06-28 11:01:23 | [feed][n]CYYZ21@83.140.21.112:28099/UDP
                      2017-06-28 11:01:23 | [feed][n]connecting
                      2017-06-28 11:01:23 | [feed][n]connected via UDP (fd 7)
                      2017-06-28 11:01:23 | [feed][n]working
                      2017-06-28 11:01:23 | [feed][i]sent 1,0 AC
                      2017-06-28 11:01:23 | [mlat][i]MLAT configuration received, service ENABLED
                      2017-06-28 11:01:23 | [mlat][i]Starting MLAT with preconfigured position: 43.5x,-79.6x,xxx
                      2017-06-28 11:01:23 | [mlat][i]MLAT bandwidth reduction active, level 1
                      2017-06-28 11:01:23 | [mlat][i]Configuring UDP connection udp://usa-2.fr24.com:19788
                      2017-06-28 11:01:27 | [feed][i]removed 2 of 30 AC
                      2017-06-28 11:01:28 | [feed][i]sent 20,0 AC
                      2017-06-28 11:01:33 | [feed][i]sent 20,0 AC
                      2017-06-28 11:01:33 | [mlat][i]Registering MLAT station
                      2017-06-28 11:01:33 | [mlat][i]Registering MLAT station: SUCCESS
                      2017-06-28 11:01:35 | [feed][i]removed 1 of 38 AC
                      2017-06-28 11:01:35 | [mlat][i]Received ADS-B time references AC:
                      2017-06-28 11:01:35 | [mlat][i] A16E42
                      2017-06-28 11:01:35 | [mlat][i] C01734
                      2017-06-28 11:01:35 | [mlat][i] C02EB9
                      2017-06-28 11:01:35 | [mlat][i] C060B9
                      2017-06-28 11:01:35 | [mlat][i]Pinging the server
                      2017-06-28 11:01:35 | [mlat][i]Stats 83838693/83838693
                      2017-06-28 11:01:38 | [feed][i]sent 28,0 AC



                      #stop manually started fr24feed by pressing Ctrl+C

                      ^C 2017-06-28 11:01:41 | [main][i]Terminating on user request
                      2017-06-28 11:01:41 | [main][i]Terminating worker threads
                      2017-06-28 11:01:42 | [reader][i]Connection terminated
                      2017-06-28 11:01:42 | [main][i]Terminating child process 1509 with SIGTERM
                      2017-06-28 11:01:42 | [reader][i]Terminating on request
                      2017-06-28 11:01:45 | [master][i]Terminating on request
                      2017-06-28 11:01:45 | [feed][n]busy
                      2017-06-28 11:01:45 | [feed][n]disconnected
                      2017-06-28 11:01:45 | [feed][x]Feeding thread terminated
                      2017-06-28 11:01:46 | [httpd][d]Client handler thread terminated
                      2017-06-28 11:01:46 | [httpd][d]Client handler thread terminated
                      2017-06-28 11:01:47 | [httpd][d]Master thread terminated


                      #now start fr24feed to run in background, as is normal
                      sudo service fr24feed restart
                      Last edited by abcd567; 2017-06-28, 17:19.

                      Comment


                      • #12
                        I have set process arguments of fr24feed as follows:
                        --net --net-http-port 8080 --net-bo-port 30005 --gain 30

                        --net enables connection to other software (browser, other data feeders) through network

                        --net-http-port 8080 enables map display in browser at port 8080 using address http://<IP of Pi>:8080. You can use a port number different from 8080 if you desire.

                        --gain 30 sets gain of Pro Stick to 30 dB. Due to built-in amplifier and strong RF noise at my location, I had to use a reduced gain value (30 dB), instead of maximum value (49.6 dB)

                        --net-bo-port 30005 makes available Beast format data on 127.0.0.1 port 30005. This will enable using other datafeeders like Planefinder, Flightaware, Radarbox24. All these Data Feeders listen to integral dump1090 of fr24feed, on 127.0.0.1 port 30005, format Beast.

                        NOTE: Flightaware will feedback mlat data to dump1090 at port 30104. The integral dump1090 of fr24feed can be configured to receive this feedback (--net-bi-port 30104), but is not configurable to keep mlat feed back separate from data picked by antenna, and mixes them together. Flightaware feeder recognizes this mixture as two feeds with different time stamps, and mlat is finally disabled automatically.

                        The solution for Flightaware mlat problem is to install either dump1090-mutability or dump1090-fa, as both are capable to prevent mlat feedback from going to output ports 30003 and 30005. The mlat feedback is combined with normal adsb feed only for display on map.

                        If dump1090-mutability or dump1090-fa is installed:
                        Settings of fr24feed should be changed. Changes can be made in any one of the two following methods:

                        (a) By SSH:
                        sudo fr24feed --reconfigure

                        (b) In a browser of desktop/laptop/tablet/phone by going to following address:
                        http://<IP of Pi>:8754/settings.html


                        Settings should be changed to:
                        Receiver: AVR(TCP) (chose "5 - AVR Compatible" if using "fr24feed --reconfigure" procedure by SSH)
                        Host/IP & Port: 127.0.0.1:30002
                        Last edited by abcd567; 2017-06-29, 14:58.

                        Comment


                        • #13
                          Hi All
                          I need to put this project on hold as I think I need to rebuild the Pi from the beginning and unfortunately the box resides in our vacation home in the US and we are in the UK for three months. I will give the clean install as suggested in the recent post a try when I get back there. I also have antenna issues, great antenna that I have not figured out where I can install it as not to get the local HOA upset. On the positive side I have another Pi running in my home with a different brand of dongle and it appears to be stable. Thank-you to everyone for your help.

                          pizzapilot

                          Comment

                          Working...
                          X