Announcement

Collapse
No announcement yet.

How to Feed Data to Multiple Sites - A Brief Guide

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • #16
    MX-Linux on Intel PC

    dump1090-mutability ver 1.15~dev
    Fr24 Feeder
    Planefinder Client

    MX-Linux-1.png . MX-Linux-2.png . MX-Linux-3.png

    Comment


    • #17
      fabulous.
      So the feeders can share sucking data from port 30005 ?

      Comment


      • #18
        Originally posted by galenthurber View Post
        fabulous.
        So the feeders can share sucking data from port 30005 ?
        Most outputs are multi client connect capable.

        Sent from my XT1092 using Tapatalk
        Posts not to be taken as official support representation - Just a helpful uploader who tinkers

        Comment


        • #19
          Originally posted by galenthurber View Post
          So the feeders can share sucking data from port 30005 ?
          YES

          From my Pi, I feed following 6 feeder from dump1090-mutability ver 1.15~dev on IP 127.0.0.1, Port 30005:

          (1) FlightRadar24
          (2) RadarBox24
          (3) FlightAware
          (4) Planefinder
          (5) Adsbexchange
          (6) Opensky-network

          Comment


          • #20
            Installed Piaware Data Feeder on MX-Linux on Intel PC

            MX-Linux-Piaware.png


            As the Piaware's deb package available at Flightaware site is built for RPi (armh architecture) it failed to install on i386 / amd64 PC.
            I therefore built the Piaware deb package on i386 computer from the source code.


            STEP-BY-STEP METHOD

            STEP-1:
            Install packages necessary to build and necessary to fulfil dependencies
            Code:
            sudo apt update
            sudo apt install git devscripts build-essential debhelper tcl8.6-dev
            sudo apt install autoconf python3-dev python3-venv virtualenv dh-systemd
            sudo apt install zlib1g-dev tclx8.4 tcllib tcl-tls itcl3 net-tools
            STEP-2:
            Clone source code from GitHub
            Code:
            cd
            
            git clone https://github.com/flightaware/piaware_builder.git
            STEP-3:
            Build .deb package for i386 machine

            First find name of distro
            Code:
            cat /etc/os-release
            
            PRETTY_NAME="Debian GNU/Linux 9 (stretch)"
            OK, found it is "stretch"

            The build commands will use the name found above, i.e. "stretch"
            NOTE:
            If name found was "jessie", then "stretch" in following 2 commands should be replaced by "jessie"
            If name found was "xenial", then "stretch" in following 2 commands should be replaced by "xenial"
            Code:
            cd
            
            cd piaware_builder
            ./sensible-build.sh stretch
            cd package-stretch
            dpkg-buildpackage -b
            The last command above will result in huge output. Large number of lines will scroll in the terminal. It will take considerable time to finish. Please be patient and give the process time to complete,

            STEP-4:
            After the build process is completed, install the deb package
            Code:
            cd ../
            sudo dpkg -i piaware_*.deb

            STEP-5:
            Configure Receiver
            (a) If you are feeding Flightaware for the first time, go to this page and claim your receiver
            https://flightaware.com/adsb/piaware/claim

            (b) If you already have a feeder-id (UUID), give following commands
            (Replace xxxxxxxx-xxxx-xxxx-xxxx-xxxxxxxxxxxx by your actual feeder-id/UUID)
            Code:
            sudo piaware-config feeder-id xxxxxxxx-xxxx-xxxx-xxxx-xxxxxxxxxxxx 
            sudo service piaware restart
            STEP-6:
            Check Installation Status
            Code:
            apt-cache policy piaware
            piaware:
              Installed: 3.6.3
              Candidate: 3.6.3
              Version table:
             *** 3.6.3 100
                    100 /var/lib/dpkg/status
            Check Logs
            Wait for 5 minutes, then check log

            Code:
            cat /var/log/piaware.log
            
            2018-10-27 08:36:26Z creating pidfile /run/piaware/piaware.pid
            2018-10-27 08:36:26Z ****************************************************
            2018-10-27 08:36:26Z piaware version 3.6.3 is running, process ID 16960
            2018-10-27 08:36:26Z your system info is: Linux mx 4.15.0-1-amd64 #1 SMP Debian 4.15.4-1~mx17+1 (2018-02-23) x86_64 GNU/Linux
            2018-10-27 08:36:27Z Connecting to FlightAware adept server at piaware.flightaware.com/1200
            2018-10-27 08:36:28Z Connection with adept server at piaware.flightaware.com/1200 established
            2018-10-27 08:36:28Z TLS handshake with adept server at piaware.flightaware.com/1200 completed
            2018-10-27 08:36:28Z FlightAware server certificate validated
            2018-10-27 08:36:28Z encrypted session established with FlightAware
            .................
            .................
            .................
            2018-10-27 08:36:30Z mlat-client(17001): Input connected to localhost:30005
            2018-10-27 08:36:30Z mlat-client(17001): Input format changed to BEAST, 12MHz clock
            2018-10-27 08:36:30Z mlat-client(17001): Beast-format results connection with ::1:30104: connection established
            2018-10-27 08:37:00Z 10 msgs recv'd from dump1090-muta; 10 msgs sent to FlightAware

            Go to this page (while logged-in to your flightaware account) to see status of your feed
            https://flightaware.com/adsb/stats/user/

            .
            Last edited by abcd567; 2018-10-28, 05:39.

            Comment


            • #21
              Installed OpenSky Network Data Feeder on MX-Linux on Intel PC

              OpenSky-feeder Map+Max Range.png . Opensky-network-1000.png

              STEP-BY-STEP METHOD

              STEP-1

              Code:
              wget https://opensky-network.org/files/firmware/opensky-feeder_latest_i386.deb
              
              sudo dpkg --install opensky-feeder_latest_i386.deb
              The 2nd command above will install opensky-feeder. and then open a dialogue to configure it (latitude, longitude, height of antenna, opensky user name etc).

              You should sign-up with opensky-network.org and obtain a user name before starting installation.


              If at any srtage you want to make changes to settings, give foillowing command and enter new values.

              Code:
              sudo dpkg-reconfigure opensky-feeder

              STEP-2
              Although MX-Linux is shipped with both systemd and sysvinit, by default systemd is disabled. The developers of MX-Linux recommend to keep systemd disabled, and use sysvinit.

              Dump1090-mutability, FR24Feeder, Plane Finder Feeder, and FlightAware Feeder detect that systemd has been disabled, and install startup files in /etc/init.d folder for sysvinit. Unfortunately Opensky network feeder does not install the init file needed by sysvinit. It installs only .service files for systemd. As a result, Opensky feeder does not start at boot, and cannot be started manually as well by command "sudo service opensky start". This situation can be overcome either by enabling systemd OR manually creating init file.

              The systemd can be enabled at boot when Grub is displayed. Choose advanced boot option, and in that option enable systemd.

              Since the MX-Linux team recommends NOT to enable systemd and instead use sysvinit, I did NOT enable systemd. Instead I created
              an init file inside folder /etc/init.d. The details are as follows:

              Code:
              #Create a blank file in folder /etc/init.d
              sudo touch /etc/init.d/opensky
              
              
              #Make this new file Executeable
              sudo chmod +x /etc/init.d/opensky
              
              
              #Open new blank file in nano to edit it
              sudo nano /etc/init.d/opensky
              In the file opened above, copy-paste following code
              NOTE: Full code is not directly visible in the window below. Please scroll down to see full code.

              Code:
              #!/bin/bash
              ### BEGIN INIT INFO
              # Provides:          opensky
              # Required-Start:    $remote_fs $network
              # Required-Stop:     $remote_fs $network
              # Default-Start:     2 3 4 5
              # Default-Stop:      0 1 6
              # Short-Description: opensky daemon
              # Description:       Receives ADS-B messages from a decoder like dump1090
              #                    and sends to opensky network via internet
              ### END INIT INFO
              
              # Do NOT "set -e"
              
              # PATH should only include /usr/* if it runs after the mountnfs.sh script
              PATH=/sbin:/usr/sbin:/bin:/usr/bin
              DESC="opensky-feeder daemon"
              NAME=opensky
              DAEMON=/usr/bin/openskyd-dump1090
              ARGS=""
              PIDFILE=/var/run/$NAME.pid
              SCRIPTNAME=/etc/init.d/$NAME
              OSUSER=openskyd
              LOGFILE=/var/log/opensky.log
              
              # Exit if the package is not installed
              [ -x "$DAEMON" ] || exit 0
              
              
              # Load the VERBOSE setting and other rcS variables
              . /lib/init/vars.sh
              
              # Define LSB log_* functions.
              # Depend on lsb-base (>= 3.2-14) to ensure that this file is present
              # and status_of_proc is working.
              . /lib/lsb/init-functions
              
              #
              # Function that starts the daemon/service
              #
              do_start()
              {
                      # Return
                      #   0 if daemon has been started
                      #   1 if daemon was already running
                      #   2 if daemon could not be started
              
              
                      start-stop-daemon --start --pidfile $PIDFILE --user "$OSUSER" --exec $DAEMON --test > /dev/null \
                              || return 1
              
              
                      # create logfile with the appropriate permissions if not already there
                      touch $LOGFILE
                      chown "$OSUSER":root $LOGFILE
              
                      start-stop-daemon --start  --pidfile $PIDFILE --user "$OSUSER" --chuid "$OSUSER" --make-pidfile --background --no-close --exec $DAEMON -- \
                               >$LOGFILE 2>&1 \
                              || return 2
                      sleep 1
              }
              
              #
              # Function that stops the daemon/service
              #
              do_stop()
              {
                      # Return
                      #   0 if daemon has been stopped
                      #   1 if daemon was already stopped
                      #   2 if daemon could not be stopped
                      #   other if a failure occurred
                      start-stop-daemon --stop --retry=TERM/30/KILL/5 --pidfile $PIDFILE --user "$OSUSER" --exec $DAEMON
                      RETVAL="$?"
                      [ "$RETVAL" = 2 ] && return 2
                      sleep 1
                      # Many daemons don't delete their pidfiles when they exit.
                      rm -f $PIDFILE
                      return "$RETVAL"
              }
              
              case "$1" in
                start)
                      [ "$VERBOSE" != no ] && log_daemon_msg "Starting $DESC" "$NAME"
                      do_start
                      case "$?" in
                              0|1) [ "$VERBOSE" != no ] && log_end_msg 0 ;;
                              2) [ "$VERBOSE" != no ] && log_end_msg 1 ;;
                      esac
                      ;;
                stop)
                      [ "$VERBOSE" != no ] && log_daemon_msg "Stopping $DESC" "$NAME"
                      do_stop
                      case "$?" in
                              0|1) [ "$VERBOSE" != no ] && log_end_msg 0 ;;
                              2) [ "$VERBOSE" != no ] && log_end_msg 1 ;;
                      esac
                      ;;
                status)
                      status_of_proc "$DAEMON" "$NAME" && exit 0 || exit $?
                      ;;
                restart|force-reload)
                      log_daemon_msg "Restarting $DESC" "$NAME"
                      do_stop
                      case "$?" in
                        0|1)
                              do_start
                              case "$?" in
                                      0) log_end_msg 0 ;;
                                      1) log_end_msg 1 ;; # Old process is still running
                                      *) log_end_msg 1 ;; # Failed to start
                              esac
                              ;;
                        *)
                              # Failed to stop
                              log_end_msg 1
                              ;;
                      esac
                      ;;
                *)
                      echo "Usage: $SCRIPTNAME {start|stop|status|restart|force-reload}" >&2
                      exit 3
                      ;;
              esac
              
              :
              
              #
              Save file (Ctrl+o) and close (Ctrl+x)

              Enable opensky init script to start at boot, and reboot computer
              Code:
              sudo update-rc.d opensky defaults
              
              sudo reboot

              During normal use, you can use following commands

              Code:
              sudo service opensky start
              
              sudo service opensky restart
              [ ok ] Restarting opensky-feeder daemon: opensky.
              
              sudo service opensky status
              [ ok ] opensky is running.
              
              sudo service opensky stop
              LOG:

              Code:
              cat /var/log/opensky.log
              
              [INFO] [COMP] Initialize STAT
              [INFO] [COMP] Initialize POS
              [INFO] [COMP] Initialize DEVTYPE
              [INFO] [COMP] Initialize NET
              [INFO] [COMP] Initialize TB
              [INFO] [COMP] Initialize SERIAL
              [INFO] [COMP] Initialize BUF
              [INFO] [COMP] Initialize RELAY
              [INFO] [COMP] Initialize RC
              [INFO] [COMP] Initialize FILTER
              [INFO] [COMP] Initialize RECV
              [INFO] [COMP] Start STAT
              [INFO] [COMP] Start POS
              [INFO] [COMP] Start DEVTYPE
              [INFO] [COMP] Start NET
              [INFO] [COMP] Start TB
              [INFO] [COMP] Start SERIAL
              [INFO] [COMP] Start RELAY
              [INFO] [COMP] Start RC
              [INFO] [COMP] Start FILTER
              [INFO] [COMP] Start RECV
              [WARN] [NET] Could not resolve host 'collector.opensky-network.org': System error
              [WARN] [NET] Tried all addresses of 'collector.opensky-network.org': could not connect
              [INFO] [INPUT] Trying to connect to 'localhost': [::1]:30005
              [WARN] [INPUT] Could not connect: Connection refused (111)
              [INFO] [INPUT] Trying to connect to 'localhost': [127.0.0.1]:30005
              [WARN] [INPUT] Could not connect: Connection refused (111)
              [WARN] [INPUT] Tried all addresses of 'localhost': could not connect
              [WARN] [NET] Could not resolve host 'collector.opensky-network.org': System error
              [WARN] [NET] Tried all addresses of 'collector.opensky-network.org': could not connect
              [INFO] [INPUT] Trying to connect to 'localhost': [::1]:30005
              [INFO] [INPUT] connected to 'localhost'
              [INFO] [NET] Trying to connect to 'collector.opensky-network.org': [194.209.200.6]:10004
              [INFO] [NET] connected to 'collector.opensky-network.org'
              [INFO] [LOGIN] Sending Device ID 5, Version 2.1.7
              [INFO] [LOGIN] Sending Serial Number 1000
              [INFO] [GPS] Sending position +43.xxxx°, -79.xxxx°, +150m
              [INFO] [LOGIN] Sending Username 'abcd567'
              [INFO] [TB] Setting sync filter: 0
              [INFO] [TB] Setting ext squitter only filter: 0
              Last edited by abcd567; 2018-11-17, 22:59.

              Comment


              • #22
                Independent of that, you really want dump1090-mutability 1.15:

                Code:
                sudo bash -c "$(wget -O - https://raw.githubusercontent.com/abcd567a/dump1090/master/PI24_replace_dump1090_v1.14_by_v1.15.sh)"
                (as discussed here: https://forum.flightradar24.com/thre...l=1#post122259)

                Otherwise you can't for example feed flightaware and take part in their MLAT because version 1.14 can't handle MLAT results.
                Generally version 1.15 is better.

                Or you might even like dump1090-fa some day, but let's stick with 1.15 for now.

                Comment


                • #23
                  You might want to take a look at this:
                  https://github.com/wiedehopf/adsb-wi...for-dump1090fa

                  and maybe this:
                  https://github.com/wiedehopf/graphs1090#graphs1090

                  Comment


                  • #24
                    Originally posted by wiedehopf
                    The bundle i made is an alternative to dump1090-mutability 1.15.

                    The bundle will remove 1.15 and install dump1090-fa.
                    But the dump1090-mutability map is still offered using the data from dump1090-fa.

                    Upon using the uninstall for the bundle it will go back to dump1090-mutability 1.14.
                    (Or to 1.15 if you installed it via the method i linked before)

                    Doesn't matter when you install the bundle, it should install and remove cleanly, pretty much no matter what you did before
                    Yesterday I have tested wiedehopf's bundle on PI24 image, first install and then later uninstall.
                    Both worked perfectly well. emoji-3.png


                    (1) PI24 image - After running Install
                    wiedehopf-1.14-to-3.7.1.png


                    (2) PI24 image - After running Uninstall - Back to normal
                    wiedehopf-3.7.1-to-1.14.png

                    Comment


                    • #25
                      Originally posted by arash
                      Which one is ok for VM?

                      This thread is for Raspberry Pi, and NOT for VM on Windows PC or Mac.

                      For VM, please see this thread:

                      Feed options for depreciated windows feeder
                      Last edited by abcd567; 2019-07-09, 19:31.

                      Comment


                      • #26
                        i am trying to install piaware as additional feeder, but i cannot get it running
                        i think because its listening on port 30005?
                        no ADS-B data program seen listening on port 30005 for 10 seconds, next check in 60s

                        I have dump1090 mutability running, because i wanted to have openstreetmap in fr24 map. Maybe thats the problem?

                        pi@raspberrypi:~/ dump1090 $ sudo service piaware status
                        ● piaware.service - FlightAware ADS-B uploader
                        Loaded: loaded (/ lib/systemd/system/piaware.service; enabled; vendor preset: enabled)
                        Active: active (running) since Sun 2019-09-01 13:20:11 UTC; 14min ago
                        Main PID: 1263 (piaware)
                        CGroup: /system.slice/piaware.service
                        └─1263 /usr/bin/piaware -p /run/piaware/piaware.pid -plainlog -statusfile /run/piaware/status.json

                        Sep 01 13:32:40 raspberrypi piaware[1263]: attempting to start dump1090..
                        Sep 01 13:32:40 raspberrypi piaware[1263]: can't start dump1090, no services that look like dump1090 found
                        Sep 01 13:32:50 raspberrypi sudo[1507]: piaware : TTY=unknown ; PWD=/ ; USER=root ; COMMAND=/bin/netstat --program --tcp --wide --all --nume
                        Sep 01 13:32:50 raspberrypi sudo[1507]: pam_unix(sudo:session): session opened for user root by (uid=0)
                        Sep 01 13:32:50 raspberrypi sudo[1507]: pam_unix(sudo:session): session closed for user root
                        Sep 01 13:32:50 raspberrypi piaware[1263]: no ADS-B data program seen listening on port 30005 for 10 seconds, next check in 60s
                        Sep 01 13:33:50 raspberrypi sudo[1516]: piaware : TTY=unknown ; PWD=/ ; USER=root ; COMMAND=/bin/netstat --program --tcp --wide --all --nume
                        Sep 01 13:33:50 raspberrypi sudo[1516]: pam_unix(sudo:session): session opened for user root by (uid=0)
                        Sep 01 13:33:51 raspberrypi sudo[1516]: pam_unix(sudo:session): session closed for user root
                        Sep 01 13:33:51 raspberrypi piaware[1263]: no ADS-B data program seen listening on port 30005 for 71 seconds, next check in 60s

                        Comment


                        • #27
                          Hi
                          I have an armbian orange pi with dump1090-mutability v1.15 + fr24 + Flightaware + Planefinder + OpenSky Network data feeders
                          Everything used to work smooth for about 2 years until a week ago that i decide to install Radarbox24 feeder.
                          After installation all feeders stop to send data and only Radarbox24 feeder works.
                          Any suggestions?

                          Thanks in advance.
                          Last edited by panosig; 2019-10-11, 16:34.

                          Comment


                          • #28
                            panosig:

                            Sometimes RB24 feeder wrongly sets itself to use its integral dump1090. The integral dump1090 of RB24 grabs the DVB-T, because of which there is no DVB-T dongle left fo use by dump1090-mutability and it fails. Also as RB24's dump1090 does not output data on port 30005 from which other feeders can get it, all other feeders fail.


                            Please open file rbfeeder.ini

                            Code:
                            sudo nano /etc/rbfeeder.ini
                            Check that network_mode is set to true, and port & host are set as shown below in red
                            Code:
                            [client]
                            network_mode=true
                            log_file=/var/log/rbfeeder.log
                            key=aaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaa
                            sn=EXTRPI000nnn
                            
                            [network]
                            mode=beast
                            external_port=30005
                            external_host=127.0.0.1
                            

                            If different from above, edit the file to make red entries as shownabove. Alternatively instead of editing the file /etc/rbfeeder.ini, you can fix the wrong & missing entries by commands shown below:

                            Give following 4 commands one by one:

                            Code:
                            sudo rbfeeder --set-network-mode on --no-start   
                            
                            sudo rbfeeder --set-network-host 127.0.0.1 --no-start   
                            
                            sudo rbfeeder --set-network-port 30005 --no-start   
                            
                            sudo rbfeeder --set-network-protocol beast --no-start
                            After above 4 commands you must restart rbfeeder by following command:

                            Code:
                            sudo systemctl restart rbfeeder
                            After restart, give following command and post its output:

                            Code:
                            cat /etc/rbfeeder.ini
                            Last edited by abcd567; 2019-10-11, 22:15.

                            Comment


                            • #29
                              Originally posted by abcd567 View Post
                              panosig:

                              Sometimes RB24 feeder wrongly sets itself to use its integral dump1090. The integral dump1090 of RB24 grabs the DVB-T, because of which there is no DVB-T dongle left fo use by dump1090-mutability and it fails. Also as RB24's dump1090 does not output data on port 30005 from which other feeders can get it, all other feeders fail.


                              Please open file rbfeeder.ini

                              Code:
                              sudo nano /etc/rbfeeder.ini
                              Check that network_mode is set to true, and port & host are set as shown below in red
                              Code:
                              [client]
                              network_mode=true
                              log_file=/var/log/rbfeeder.log
                              key=aaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaa
                              sn=EXTRPI000nnn
                              
                              [network]
                              mode=beast
                              external_port=30005
                              external_host=127.0.0.1
                              

                              If different from above, edit the file to make red entries as shownabove. Alternatively instead of editing the file /etc/rbfeeder.ini, you can fix the wrong & missing entries by commands shown below:

                              Give following 4 commands one by one:

                              Code:
                              sudo rbfeeder --set-network-mode on --no-start   
                              
                              sudo rbfeeder --set-network-host 127.0.0.1 --no-start   
                              
                              sudo rbfeeder --set-network-port 30005 --no-start   
                              
                              sudo rbfeeder --set-network-protocol beast --no-start
                              After above 4 commands you must restart rbfeeder by following command:

                              Code:
                              sudo systemctl restart rbfeeder
                              After restart, give following command and post its output:

                              Code:
                              cat /etc/rbfeeder.ini

                              Hi again

                              i follow the instructions and everything seems to be ok.

                              Below you can see the log you asked for

                              log_file=/var/log/rbfeeder.log

                              key=***********************************

                              sn=EXTRPI00******

                              [network]
                              mode=beast
                              external_port=30005
                              external_host=127.0.0.1

                              [mlat]

                              I am thankful for your help.

                              Comment

                              Working...
                              X