Announcement

Collapse
No announcement yet.

New user, FR24 says I'm offline, getting nowhere... help?!

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • New user, FR24 says I'm offline, getting nowhere... help?!

    Hi all,

    Sorry to say but I'm another newbie who is having a horrible time trying to set up a tracker using raspberry pi + dvb-t usb stick (completely standard setup as recommended on their page). Flightradar made it out to be so easy, but once I install everything to the SD card (following FR24's instructions to a T), my raspberry pi isn't detected by their auto-detection page, which I understand is common.

    So, I go through ssh instead, and successfully set up my pi. I'm given a key, a radar code and everything. Only issue is, while I show as connected on my feeder status page (:8754), fr24 shows my radar as offline, and I can't track anything. I've tried to troubleshoot, but unfortunately, this is my first foray into raspberry pi and linux, so most stuff is extremely over my head. I've tried switching my reciever type and while AVR *does* work in that it connects, fr24 still shows as offline.


    I'm really dumbfounded, because despite reinstalling 2x now, every guide I've seen... the setup takes 15 mins. Here I am 5 hours later, with no clue what's going on.


    Basically, I'm hoping someone here would be willing to just hold my hand and walk me through the process from start to finish, tell me what settings to use and which buttons to press, because I'm at my wits end. Help would be much appreciated.

    Attached are my config pages, maybe I'm missing something obvious?

    config1.PNGconfig2.jpg

    Thank you!

  • #2
    sudo service fr24feed stop

    sudo fr24feed start

    WAtch the start log and report back what it does when detecting the USB stick

    (assuming you got a good one.. or itll be another case of incorrectly marketed Fitpower chipset)


    [main][i]Version: 1.0.16-7/generic
    Connecting to Generic receiver via (exe://mr-dump1090.exe --raw --net --net-http-port 8080)
    Found 1 device(s):
    0: Realtek, RTL2838UHIDIR, SN: 00000001 (currently selected)
    Found Rafael Micro R820T tuner
    Max available gain is: 49.60 dB
    Setting gain to: 49.60 dB
    Exact sample rate is: 2000000.052982 Hz
    Gain reported by device: 49.60 dB
    https://forum.flightradar24.com/thre...ll=1#post74834
    Posts not to be taken as official support representation - Just a helpful uploader who tinkers

    Comment


    • #3
      Hi Oblivian,

      Thanks for the response.

      Here's the relevant output I got:

      2017-05-25 09:24:21 | [reader][i]Connecting to DVBT receiver via (exe:///usr/lib/fr24/dump1090 --raw)
      2017-05-25 09:24:21 | [reader][i]Connected to the receiver, configuring
      2017-05-25 09:24:21 | [reader][i]Configured, processing messages
      Found 1 device(s):
      0: Realtek, RTL2838UHIDIR, SN: 00000001 (currently selected)
      Found Rafael Micro R820T tuner
      Max available gain is: 49.60
      Setting gain to: 49.60
      Exact sample rate is: 2000000.052982 Hz
      Gain reported by device: 49.60

      Comment


      • #4
        Better than I was expecting.

        The next thing would be to check reception. Keep an eye on that for a while when you know there are flights in the area and see if it picks them up.

        Server will only show as online when data is being sent
        Posts not to be taken as official support representation - Just a helpful uploader who tinkers

        Comment


        • #5
          Good and neutral news,

          I woke up this morning and my pi had gone inactive overnight, a bit after I went to bed.

          Active: inactive (dead) since Thu 2017-05-25 09:24:21 UTC; 5h 23min ago
          Any idea how to keep it awake through the night?


          Good news though, once I woke up and woke up my pi, the morning rush to seatac (I am right under the approach) had started, and within 10 minutes or do I had 1 aircraft tracked! Side note, do you know how long it takes for the premium subscription to activate once you start tracking planes?


          Glad to hear my setup was okay. I guess it came down to being unlucky enough to set things up with no planes around, and then not realizing "online" is only while planes are not being tracked. I had thought it was more like "online and ready", not "online and tracking" which is why I kept fighting the system so long

          Comment


          • #6
            Hi again,

            My other post is currently awaiting moderator approval, but I found some new info/issues, so I had to double post before I leave for class for the day.

            I'm getting a lot of hits on mode s this morning, but no positions reported to my receiver, nor any uploads except for the first one I mentioned. Furthermore, when I run any commands like "fr24feed start" as I did last night, I now get lots of errors relating to my usb stick. Here's a full print out of what I'm seeing. The last usb_open error -3 will repeat continuously until I terminate it.

            2017-05-25 16:03:58 | [main][i]FR24 Feeder/Decoder
            2017-05-25 16:03:58 | [main][i]Version: 1.0.18-9/generic
            2017-05-25 16:03:58 | [main][i]Built on Apr 20 2017 09:25:30 (T201704200925/Linux/static_arm)
            2017-05-25 16:03:58 | [main][i]Copyright 2012-2017 Flightradar24 AB
            2017-05-25 16:03:58 | [main][i]DNS mode: PING
            2017-05-25 16:03:58 | [main][i]Automatic updates are DISABLED
            2017-05-25 16:03:58 | ERROR
            2017-05-25 16:03:58 | [httpd][e]bind function failed, errno: 98
            2017-05-25 16:03:58 | [httpd][d]Master thread terminated
            2017-05-25 16:03:58 | [master][i]Starting processing thread
            2017-05-25 16:03:58 | [main][i]Reader thread started
            2017-05-25 16:03:58 | [time][i]Synchronizing time via NTP
            2017-05-25 16:03:58 | [reader][i]Initializing reader
            2017-05-25 16:03:58 | [reader][i]Connecting to DVBT receiver via (exe:///usr/lib/fr24/dump1090 --raw)
            2017-05-25 16:03:58 | [reader][i]Connected to the receiver, configuring
            2017-05-25 16:03:58 | [reader][i]Configured, processing messages
            Found 1 device(s):
            0: ▒▒~, c, SN: ▒▒▒v (currently selected)
            usb_open error -3
            Please fix the device permissions, e.g. by installing the udev rules file rtl-sdr.rules
            Error opening the RTLSDR device: Permission denied
            2017-05-25 16:03:58 | [reader][i]Connection terminated
            2017-05-25 16:03:58 | [main][i]Terminating child process 6593 with SIGTERM
            2017-05-25 16:04:04 | [reader][i]Connecting to DVBT receiver via (exe:///usr/lib/fr24/dump1090 --raw)
            2017-05-25 16:04:04 | [reader][i]Connected to the receiver, configuring
            2017-05-25 16:04:04 | [reader][i]Configured, processing messages
            So it's telling me to fix device permissions, but I'm somewhat clueless on how to do so. Tried looking on google real quick, but no luck so far. It's connected through an Asus RT-AC66U router by the way, if that means anything.


            Thank you again for your help

            Comment


            • #7
              I have no idea why mine isnt working....but I can post anywhere so I have to make up 3 posts...sorry

              Comment


              • #8
                Originally posted by kcvt View Post
                Hi again,

                My other post is currently awaiting moderator approval, but I found some new info/issues, so I had to double post before I leave for class for the day.

                I'm getting a lot of hits on mode s this morning, but no positions reported to my receiver, nor any uploads except for the first one I mentioned. Furthermore, when I run any commands like "fr24feed start" as I did last night, I now get lots of errors relating to my usb stick. Here's a full print out of what I'm seeing. The last usb_open error -3 will repeat continuously until I terminate it.



                So it's telling me to fix device permissions, but I'm somewhat clueless on how to do so. Tried looking on google real quick, but no luck so far. It's connected through an Asus RT-AC66U router by the way, if that means anything.


                Thank you again for your help
                2017-05-25 16:03:58 | [httpd][e]bind function failed, errno: 98
                usb_open error -3

                Indicates it has crashed in background. Or the USB stick has 'dropped off'. This happens if not enough power is supplied among some reasons. What power source is used? 1A, .5A?


                Be sure to do the blacklisting to ensure its not the cause.

                http://www.satsignal.eu/raspberry-pi...-after-upgrade

                Linked to from

                https://forum.flightradar24.com/thre...ll=1#post74834
                Posts not to be taken as official support representation - Just a helpful uploader who tinkers

                Comment

                Working...
                X