Announcement

Collapse
No announcement yet.

Multiple feeding on RPi

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Multiple feeding on RPi

    Hi everyone!
    I'm new to the forum..
    I'd like to know if it's possible to use a Raspberry Pi to feed on both FR24 and Flightaware simultaneoulsy.
    I have a RPi3 with Raspbian Jessie (pixel) and a NooElec NESDR Mini 2.

    Thanks.

  • #2
    Welcome to the forum.

    Yes, You can feed all those ADS-B flight tracking sites & planeplotter network from one Raspberry Pi3.
    Brian

    www.RadarSpotters.eu
    [ Feeder Station List ][ Map ][ Latest Feeders Rank Stats ][ ImRadarFeeder.com Radar Feeders WorldWide Map ][ VRS Feeder List ] (NEW)

    Comment


    • #3
      Welcome to the forum.
      Yes, You can feed all those ADS-B flight tracking sites & planeplotter network from one Raspberry Pi3.
      ok, thanks for the answer!
      I have installed both "clients" on my RBPi but only Flightaware works properly, Fr24feeder remains connected to the "service" (the site shows it connected H24) but it doesn't feed anything. Do i have to do something particular in order to get them working correctly??
      Thanks in advance.

      Comment


      • #4
        My advice is to stay with a "neutral" distribution image, install latest dump1090 mutability, and then just add the feeders that you like.


        I use DietPi for a very lean distribution, but NOOBS / Raspbian should work just as well.

        Then install dump1090-mutability, check that it works and provides raw data on port 30005.

        Now you can install all the different feeders you like. Don't let any one of them take over the decoding, just direct them to localhost:30005 for data. On this port, the data is in Beast/RAW format.

        This will provide the most flexible receiver setup, without too much dependencies on the different sites own software.

        /M
        F-ESDF1, F-ESGG1, F-ESGP1, F-ESNK1, F-ESNV2, F-ESNV3 F-ESSL4, F-LFMN3
        P-ESGR, P-ESIA, P-ESIB, P-ESGF
        mrmac (a) fastest.cc

        Comment


        • #5
          Help please, confused newbie here. I already had a Pi feeding to FR24 having downloaded their image. However as I also wish to use FA, I couldn't get it to work. I have now installed FA's dump8080 and it's working fine.
          Please can someone give me an idiots guide to adding a feed to my FR24 account, and how will it pick up with my existing account please?

          Comment


          • #6
            Originally posted by Paul Drawmer View Post
            Help please, confused newbie here. I already had a Pi feeding to FR24 having downloaded their image. However as I also wish to use FA, I couldn't get it to work. I have now installed FA's dump8080 and it's working fine.
            Please can someone give me an idiots guide to adding a feed to my FR24 account, and how will it pick up with my existing account please?
            Do a fresh install in following order:
            (1) Format microSD card
            (2) Write Raspbian Jessie image (download from raspberrypi.org) to microSD card
            (3) Install dump1090-mutability from instructions on this page: How to Install dump1090-mutability_1.15~dev on RPi

            IMPORTANT: Dump1090-mutability should be installed BEFORE any of the data feeders are installed


            (4) Install Flightaware feeder from instructions on this page (STEP 2 ONLY): http://flightaware.com/adsb/piaware/install

            (5) Install FR24 feeder from instructions on this page: https://www.flightradar24.com/raspberry-pi using command
            Code:
            sudo bash -c "$(wget -O - http://repo.feed.flightradar24.com/install_fr24_rpi.sh)"

            (6) REBOOT the Pi

            (7) ENJOY!!!
            Last edited by abcd567; 2017-02-22, 19:27.

            Comment


            • #7
              Originally posted by Penaz View Post
              ok, thanks for the answer!
              I have installed both "clients" on my RBPi but only Flightaware works properly, Fr24feeder remains connected to the "service" (the site shows it connected H24) but it doesn't feed anything. Do i have to do something particular in order to get them working correctly??
              Thanks in advance.
              (1) Go to page: http://<IP of your RPi>:8754/settings.html

              (2) Make settings as shown in the screenshot below.

              (3) Click "Save" and "Restart" buttons on bottom right of the page.

              (4) Reboot Pi

              FR24 settings.png

              Comment


              • #8
                Originally posted by abcd567 View Post
                (2) Make settings as shown in the screenshot below.
                It's better to use TCP - Raw/Beast - 30005.

                In fr24feed.ini it then looks like this:

                receiver="beast-tcp"
                fr24key="yourfeederkey"
                host="127.0.0.1:30005"

                /M
                F-ESDF1, F-ESGG1, F-ESGP1, F-ESNK1, F-ESNV2, F-ESNV3 F-ESSL4, F-LFMN3
                P-ESGR, P-ESIA, P-ESIB, P-ESGF
                mrmac (a) fastest.cc

                Comment


                • #9
                  Originally posted by MrMac View Post
                  It's better to use TCP - Raw/Beast - 30005.
                  In fr24feed.ini it then looks like this:
                  receiver="beast-tcp"
                  fr24key="yourfeederkey"
                  host="127.0.0.1:30005"
                  The ModeS Beast (TCP), port 30005, can also be set from page http://<IP of RPi>:8754/settings.html, as shown in screenshot below.

                  FR24 Settings-Beast (TCP)-30005.png

                  After changing, saving, and restarting settings.html page, if you check the file /etc/fr24feed.ini, you will see these settings are saved there.

                  pi@raspberrypi:~ $ cat /etc/fr24feed.ini
                  receiver="beast-tcp"
                  fr24key="xxxxxxxxxxxxxxxxxxx"
                  host="127.0.0.1:30005"
                  bs="no"
                  raw="no"
                  logmode="0"
                  windowmode="0"
                  mpx="no"
                  mlat="yes"
                  mlat-without-gps="yes"


                  Alternatively, you can directly edit the file /etc/fr24feed.ini to enter desired settings, as suggested by MrMac
                  Last edited by abcd567; 2017-02-23, 18:21.

                  Comment


                  • #10
                    Did (1) through (4), works fine (although I found this post after doing 1-4).
                    executed the step (5) command (with dump1090 & piaware running) - didn't work.
                    In a previous NOOBS 2.1.0 & FR24 install (but no dump1090-mutability installed) I had to install FR24 manually as the step (5) script didn't work there either.

                    I redid the install (1-5) to get a clean install of dump1090-mutability.

                    The FR24 manual install instructions don't have the command sequence for installing FR24 if a dump1090 has been installed prior to attempting to install FR24:

                    h t t p :// forum.flightradar24.com/threads/8908-New-Flightradar24-feeding-software-for-Raspberry-Pie

                    any idea what the modifications are to the above link's manual install if a dump1090 is installed prior to installing FR24?

                    Thanks

                    Comment


                    • #11
                      @inoc:
                      What receiver and port did you set on settings pages http://<IP of RPi>:8754/settings.html (or in file fr24feed.ini)?

                      If no version of dump1090 is installed separately, then Fr24 Feeder uses its integral dump1090 and receiver should be set as "dvb-t".

                      Fr24feeder-Settings-Integral-dump1090.png


                      If any other version of dump1090 is installed (dump1090 MR, dump1090-fa, or dump1090-mutability), then receiver type should be either "avr(tcp), port 30002" or "beast(tcp) port 30005".

                      Fr24feeder settings Beast(TCP) dump1090 mutability.png

                      Fr24feeder Settings AVR(TCP) External dump1090.png
                      Last edited by abcd567; 2017-02-23, 23:52.

                      Comment


                      • #12
                        Just got through re-executing the fr24 script in order to post the results of its not installing - this time it worked ??, no changes from the previous failed attempt, other than the failed attempt.

                        ;however, (ain't it always the way) when I attempted to manually configure the FR24 interface to dump1090-mutability I chose " 4 - ModeS Beast (USB/Network)" thinking that must be the recommended 3005 port -
                        although I also selected to participate in MLAT and FR24 stted to participate I must select: " 1 - DVBT Stick (USB)".
                        anyway after selecting "4" it stumped with: "Step 4.3A - Please enter your receiver's COM port number/device path"

                        - so I ^Ced (canceled) and reran the script, this time selecting: "Would you like to use autoconfig (*yes*/no)$:yes"

                        ...restarted FR24 and it's apparently running.

                        I don't have a clue as to what's going on, this is like DOS on steroids - or hemorrhoids.

                        But thanks for your help

                        Comment


                        • #13
                          @inoc:
                          When running the script, you have to choose as follows:

                          The "1 - DVB-T (USB)" should be chosen if the DVB-T stick is plugged into the same RPi on which you are installing the FR24 feeder.

                          The "USB/Network" is chosen only if the DVB-T Stick is plugged into another Pi or Laptop or Desktop, connected through LAN to the RPi on which you are installing FR24 feeder.

                          The settings page http://<IP of RPi>:8754/settings.html is for configuration AFTER the script has run successfully. Then in that page, choices to be made as shown in my post #11 above.
                          Last edited by abcd567; 2017-02-24, 02:33.

                          Comment


                          • #14
                            Are these directions current?

                            Still trying to get FR and FA installed on Raspian using NOOBs. These instructions look like they are what i need. Are they still current? If so, I will make this my last attempt tonight.

                            Thanks!!


                            Originally posted by abcd567 View Post
                            Do a fresh install in following order:
                            (1) Format microSD card
                            (2) Write Raspbian Jessie image (download from raspberrypi.org) to microSD card
                            (3) Install dump1090-mutability from instructions on this page: How to Install dump1090-mutability_1.15~dev on RPi

                            IMPORTANT: Dump1090-mutability should be installed BEFORE any of the data feeders are installed


                            (4) Install Flightaware feeder from instructions on this page (STEP 2 ONLY): http://flightaware.com/adsb/piaware/install

                            (5) Install FR24 feeder from instructions on this page: https://www.flightradar24.com/raspberry-pi using command
                            Code:
                            sudo bash -c "$(wget -O - http://repo.feed.flightradar24.com/install_fr24_rpi.sh)"

                            (6) REBOOT the Pi

                            (7) ENJOY!!!

                            Comment


                            • #15
                              @port107
                              YES, these are still valid.

                              If you are using Raspbian STRETCH:

                              (1) Two workarounds reqired as detailed here:

                              https://forum.flightradar24.com/thre...ll=1#post96279


                              AND

                              (2) One workaround here:

                              https://forum.flightradar24.com/thre...allation-issue

                              BETTER USE JESSIE. NO WORKAROUND REQUIRED FOR JESSIE
                              Last edited by abcd567; 2018-01-27, 04:27.

                              Comment

                              Working...
                              X