Announcement

Collapse
No announcement yet.

fr24feed service running but account shows as offline

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • fr24feed service running but account shows as offline

    I've been feeding fr24 data for a while now without issue, using an RTL dongle attached to a Pi and using the fr24feed service. I've been tweaking some html and js code within the public_html directories, which has been just cosmetic changes to suit my needs. Anyway, a few hours ago I noticed that my status in my account settings is now showing as "offline". I stopped the fr24feed service, restarted and still no different. I then ran fr24feed --signup and entered in my existing information, and still I'm showing as offline. My receiver is working however and picking up messages.

    Any ideas why my account is still showing offline despite the service running as per normal on my box?

  • #2
    Issue appears to have resolved - perhaps I was being too impatient. \_(ツ)_/

    Comment


    • #3
      Me too! Thanks!

      Comment


      • #4
        So, i'm offline very often and long. I can't explain why! The result is now that i don't have gold status... Thats massiv odd... What can i do to fix this?

        Edit: After days and again searching for issue on my part i found the solution:

        Edit fr24feed.ini as following:

        receiver="beast-tcp"
        fr24key="yourkey"
        host="127.0.0.1:30005"
        bs="no"
        raw="no"
        logmode="0"
        logpath="/var/log/fr24feed"
        mlat="yes"
        mlat-without-gps="yes"

        Restart. You can check this by: http://192.168.179.59:8754/

        It seems for piaware user that fr24feeder will be configuration wrong on installation part of the script and set AVR localhost:30002 and the error log say that frfeeder cant connect to beast localhost:30005 but normally via nc that looks fine...

        Hope that will help anyone out there.
        Last edited by Swen; 2018-02-05, 19:12.

        Comment


        • #5
          image1 (1).jpg

          My status is offline on FR24 site, in "My DataSharing". But my feeder its running on PC (WIN7), like ONLINE. The icon it"s GREEN.
          Why my status it's offline on FR24 site??

          Comment


          • #6
            I dont know but your software looks outdated... it must be something like this:

            tTT9pGv.png

            Which software are u using?

            EG Greenshot is a nice screen capture tool...

            Comment


            • #7
              Im using "FR24 Feeder/Decoder
              File version: 1.0.19.6 (for WIN7)
              Whats your version? Its for Linux, right?
              thanks
              Last edited by DaniJS; 2018-02-05, 21:54.

              Comment


              • #8
                Originally posted by Swen View Post
                It seems for piaware user that fr24feeder will be configuration wrong on installation part of the script and set AVR localhost:30002 and the error log say that frfeeder cant connect to beast localhost:30005 but normally via nc that looks fine...
                This. I believe there's a bug for a while now in fr24feeder, that causes it to go cuckoo whenever there is anything running on port 30005 and assume it's BEAST receiver and it absolutely has to connect to it. Except it fails to. Luckily it only does this check up on the startup, and restart in my case seems to fix it (I believe because fr24feeder starts before mutability does and waits for connection on proper port 30002), and once dump1090 is up, everything works. But if fr24feeder restarts afterwards (which it does when there's eg. and update to the software), it will fail. The same if I restart it manually:

                Code:
                root@raspberrypi:~# service fr24feed restart
                (wait)
                root@raspberrypi:~# fr24feed-status 
                [ ok ] FR24 Feeder/Decoder Process: running.
                [ ok ] FR24 Stats Timestamp: 2018-02-06 01:40:05.
                [ ok ] FR24 Link: connected [UDP].
                [ ok ] FR24 Radar: T-KSJC47.
                [ ok ] FR24 Tracked AC:.
                [FAIL] Receiver: down ... failed!
                [FAIL] FR24 MLAT: not running ... failed!
                And that's it. If you ran fr24feed manually at this point, you'll see it's connection to tcp://localhost:30005 regardless of what config file says it should do. You can fix this by turning off dump1090 AND piaware and starting fr24feed first, like:
                Code:
                root@raspberrypi:~# service piaware stop
                root@raspberrypi:~# service dump1090-mutability stop
                root@raspberrypi:~# service fr24feed restart
                root@raspberrypi:~# service dump1090-mutability start
                root@raspberrypi:~# service piaware start
                (wait)
                root@raspberrypi:~# fr24feed-status 
                [ ok ] FR24 Feeder/Decoder Process: running.
                [ ok ] FR24 Stats Timestamp: 2018-02-06 01:42:08.
                [ ok ] FR24 Link: connected [UDP].
                [ ok ] FR24 Radar: T-KSJC47.
                [ ok ] FR24 Tracked AC:.
                [ ok ] Receiver: connected (2 MSGS/0 SYNC).
                [ ok ] FR24 MLAT: ok [UDP].
                [ ok ] FR24 MLAT AC seen: 0.
                Unfortunately, that will only last until fr24feed decides to restart itself and then manual intervention is needed again. Any help is appreciated how to make this permanent. But it should probably be reported to fr24feed guys somewhere.

                Comment


                • #9
                  Im using "FR24 Feeder/Decoder
                  File version: 1.0.19.6 (for WIN7)
                  Whats your version? Its for Linux, right?
                  thanks
                  Yes i'm using linux... I don't have a clue about windows and flightradar... that is light years i way i do that...

                  Unfortunately, that will only last until fr24feed decides to restart itself and then manual intervention is needed again. Any help is appreciated how to make this permanent. But it should probably be reported to fr24feed guys somewhere.
                  Yes that is what i thing also. The Feeder ignore totally rawdata and will try everytime to Beast. The config seems to be ignored at this point and work only with Beast settings...
                  Last edited by Swen; 2018-02-06, 12:06.

                  Comment


                  • #10
                    There's a discussion in this thread about this too: https://forum.flightradar24.com/thre...erminating-BUG. One thing mentioned there that I am trying now is to switch receiver type to beast-tcp and address to 127.0.0.1:30005. My file now looks like this:
                    Code:
                    pi@raspberrypi:~ $ cat /etc/fr24feed.ini
                    receiver="beast-tcp"
                    host="127.0.0.1:30005"
                    (...)
                    That seems to survive restarts, since for some reason, that will connect properly to beast output of dump1090-mutability. So far, that's been working for me as a workaround, although some people in that thread complained about this dying on them anyway. Maybe it's just avr-tcp mode that is affected.

                    Comment

                    Working...
                    X