Announcement

Collapse
No announcement yet.

Automated Installation of Dump1090-Mutability, Data Feeders, and Performance Graphs

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • #16
    Outstanding script!!! Install worked like a charm. I do have a slight problem though...

    I am live and feeding to Flightaware, no issue there.

    I am offline on Flightradar24 and not sending any aircraft position, although my uptime is showing high percentage (seems I am connected, but not feeding any aircraft position). fr24feed status tells me it is running.

    Can someone point me in the right direction to troubleshoot this problem? I installed dump1090-mutability during the installation (there were 2 options). I might have missed an option during the install?

    Comment


    • #17
      @cjacques
      If you installed dump1090-mutabilty, you can feed data to various sites (like flightradar24, flightaware, planefinder etc) by installing their data feeder software.

      The other option (dump1090-fa) is Flightaware's fork of dump1090-mutability. With dump1090-fa, you can still feed data to various sites by installing their data feeders, but I personally prefer to install dump1090-mutability, as it is not aligned to any particular site.
      Last edited by abcd567; 2016-10-25, 02:00.

      Comment


      • #18
        Here's the code. I assume it is FR's blend?

        cd ~
        git clone git://github.com/flightradar24/dump1090
        cd dump1090
        make
        ./dump1090 --interactive --net --net-http-port 8080

        They both seem to be working fine for now, I'll leave my install alone and start looking antennas and installation

        Comment


        • #19
          What is the address to access the graphs?

          Comment


          • #20
            The main dump1090 graphs are on port 80 of the IP address assigned to your Raspberry Pi. The FR24 configuration can be found on port 8754, and the PlaneFinder map/config is on port 30053.

            I think that the FlightAware map/config is supposed to show up on port 8080, but I can't seem to get into it on my setup. I'm wondering if there might be something going on with the script turning the FA web interface off or something, but I'm not experienced enough with it yet to see what I've got wrong. I do know that I'm feeding to FA just fine.

            I've also noticed that automatic updates are disabled for the FlightAware feeder bundled with the script. Is it safe to turn on automatic updates for FA after using this scripted install, or is there a good reason that they're turned off?

            Also, does the ADS-B Exchange feeder have a web interface or something? I can't seem to find any info on it and the ADS-B Exchange site is not set up to tell you if you are feeding them properly, so I don't know if my feed to them is working or not.

            Comment


            • #21
              To check your current settings of time & date:
              Code:
              sudo date
              If time zone is not correctly set, you can set it by:
              Code:
              sudo dpkg-reconfigure tzdata
              If the time setting is not accurate, synchronize it with ntp server:
              Code:
              sudo ntpd -gq
              
              #wait for few seconds then restart ntp
              cd ~
              sudo /etc/init.d/ntp restart
              To check/set your latitude and longitude in dump1090-mutability:
              Code:
              sudo dpkg-reconfigure dump1090-mutability
              
              #when settings window opens, press Enter key, and setting will jump to next item
              #keep pressing the Enter key till you reach latitude setting.
              #pressing once more will display longitude setting
              #if these settings are not correct or accurate to 4 places of decimal, enter correct values
              #continue oressing Enter key till you reach last setting
              #the settings window will close itself
              
              
              #now reboot
              sudo reboot

              To change latitude and longitude setting in FR24, repeat sign-up:
              Code:
              sudo fr24feed --signup
              
              #after completing sign up, reboot
              sudo reboot
              Last edited by abcd567; 2016-10-25, 21:17.

              Comment


              • #22
                Originally posted by milo
                According to Google I live at

                48.7856988N,9.1639473E how do I set this into the system?
                First configure dump1090-mutability:
                Code:
                sudo dpkg-reconfigure dump1090-mutability
                A configuration window will appear.
                Keep pressing Enter key till you reach the screen which asks Latitude.
                Type 48.7857 and press Enter
                The screen will change and now it will ask Longitude
                Type 9.1639 and press Enter key. Keep pressing Enter key till the configuration window closes.
                At some point pressing Enter key will not change screen. Press "Tab" key to make the "OK" on screen red, then press Enter key.

                dump1090-Latitude.png dump1090-Longitude.png



                Now configure FR24 Feeder:
                Code:
                sudo fr24feed --signup
                It will ask you to enter your email, sharing key, etc.
                When it asks Latitude, type 48.7857 and press Enter key
                When it asks Longitude, type 9.1639 and press Enter key
                When it asks for MLAT, type yes
                When it asks Height of antenna above sea level enter 953 + Height of antenna above ground in feet
                (The 953 feet is ground height above sea level for latitude/longitude you have provided).
                When it asks "Would you like to use autoconfig (*yes*/no)$:" type yes
                Now answer about log file, and then confiuration will complete and confirmation message will come.
                When confirmation message is displayed, restart fr24feed
                Code:
                sudo service fr24feed restart
                fr24feed configuration.png antenna elevation.png
                Last edited by abcd567; 2016-10-26, 08:17.

                Comment


                • #23
                  Originally posted by abcd567 View Post
                  The dump1090-mutability and Piaware are NOT installed by "apt-get install". Insted source code is downloaded and .deb package is built in the Pi. Hence "apt-get upgrade" will not upgrade to latest version. The update/upgrade is to be done as follows:

                  Code:
                  cd ~/adsb-receiver
                  git fetch --all
                  git reset --hard origin/master
                  ./install.sh
                  That will indeed rebuild/upgrade dump1090-mutability if I tell it to. But it won't do anything for piaware as far as I can tell. It ignores the feeders once they are installed. I assume I could use flightaware web site to send upgrade command to piaware, if I configure it to do automatic updates?

                  Comment


                  • #24
                    Originally posted by jarda View Post
                    That will indeed rebuild/upgrade dump1090-mutability if I tell it to. But it won't do anything for piaware as far as I can tell. It ignores the feeders once they are installed. I assume I could use flightaware web site to send upgrade command to piaware, if I configure it to do automatic updates?
                    Please see Flightaware forums regarding Piaware upgrade.
                    I have raised this issue there. Please see my post linked below, and a number of response posts after it:
                    http://discussions.flightaware.com/p...2.html#p199942

                    Some user have reported successfully upgrading Piaware data feeder using method described by Flightawre
                    http://flightaware.com/adsb/piaware/upgrade
                    Last edited by abcd567; 2016-10-26, 15:05.

                    Comment


                    • #25
                      Originally posted by milo
                      Flightradar webpage shows that I am online but there is no data uploaded. But planefinder shows a lot of ads-b uploads.


                      Any help?
                      Your FR24 settings are:
                      receiver="dvbt"
                      host="127.0.0.1:30005"

                      Try settings I use for my Pi/dvb-t, which is feeding FR24 successfully. These are:
                      receiver="AVR(TCP)"
                      host="127.0.0.1:30002"


                      On a computer on same LAN as your Pi, type in the address bar of browser:
                      (1) IP of Pi:8754 - see if upload is shown
                      (2) IP of Pi:8754/settings.html - see/change your settings.


                      See my settings below

                      FR24 status.png FR24 settings.png

                      NOTE: If on your Flightradar24 statistics page it says "Current upload rate: 0 KB/s", but your graphs are showing data, just ignore it.

                      See my stats page below. It also shows "Current upload rate: 0 KB/s", but graphs show data.

                      FR24 stats CYYZ-9.png


                      If the problem is still not solved, ask in the relevant thread for FR24 feeder help.

                      .
                      Last edited by abcd567; 2016-10-27, 19:57.

                      Comment


                      • #26
                        Originally posted by Flieger28
                        Maybe a dumb question. I used the script and it worked perfekt. Right now i would like to change my Rasbian from SD-Card to HD to use the advanced features. My question is, how can i switch to the advanced features. Do i have to install all again or is there a feature to switch from basic.

                        Regards
                        Eike
                        I myself did not know how to do it, so I decided to try.

                        FIRST ATTEMPT - Failed
                        Code:
                        #run the installation script
                        cd ~/adsb-receiver
                        ./install.sh
                        
                        #Installation process started
                        #I said No to everything till reached option to install web portal, and said yes to it. 
                        #The portal installation started, checked and found all components of web portal are already installed, 
                        #and completed WITHOUT offering option for Advance
                        SECOND ATTEMPT - Success
                        Code:
                        #First emptied html folder
                        sudo rm -rf /var/www/html/*
                        
                        #Now run the installation script 
                        cd ~/adsb-receiver
                        ./install.sh
                        
                        #Installation process started
                        #I said No to everything till reached option to install web portal, and said yes to it. 
                        #The portal installation started, and asked if I want to install Advanced option
                        #I chose SQL Lite, and it went ahead and installed the advanced option.

                        Comment


                        • #27
                          While updating the required packages list during the installation process I get this message:
                          plymouth.JPG
                          What should I do?
                          Thanks

                          Edit:
                          Installation works fine after just entering "q".
                          But what kind of a software/service is that?
                          Last edited by majo; 2016-11-22, 17:51.

                          Comment


                          • #28
                            @majo

                            This message is from Debian, on which Raspbian Jessies is based. It happened with me when I last upgraded, and I just ignore it and pressed q to quit this message.

                            Comment


                            • #29
                              Originally posted by codename062
                              Awesome, worked like a charm on my rpi connected with the usb tuner. This is exactly what I was trying to get working using various other scripts and web based monitoring tools.
                              Is there an option to get it working on an rpi connected with mode-s beast to USB and what additional steps needs to be to done?
                              (1) Mode-S Beast to dump1090

                              (2) What is Easiest Way To Install Dump1090-Mutability

                              (3) Using a Raspberry Pi with The Mode-S Beast
                              Last edited by abcd567; 2016-12-01, 14:39.

                              Comment


                              • #30
                                What's the best way to get into the ADS-B Exchange feeder settings? I don't seem to be showing up on their coverage map, so I'd like to fix that feeder without breaking the other three (working) feeders.

                                Comment

                                Working...
                                X