No announcement yet.

Raspberry + dvb-t dongle error No Devices Found

  • Filter
  • Time
  • Show
Clear All
new posts

  • Raspberry + dvb-t dongle error No Devices Found

    I have a raspberry pi + dvb-t dongle and raspbian Jessie light. I did automatic installation with the command on the web page of flightradar24.
    The problem is that i can't activate the rapberry in my account and the error result is "no devices found".
    The dongle is working perfectly in windows in the usb port of my pc.
    I tried all kind of solutions but without success.
    Someone had the same problem?
    Thank you

  • #2
    Run command
    See the output. Is dvb-t listed there?


    • #3
      Hi abcd567!

      Here the output after the fresh installation of raspian and fr24feed

      Saving settings to /etc/fr24feed.ini...OK
      Settings saved, please run "sudo service fr24feed restart" to use new configuration.
      Installation and configuration completed!
      pi@raspberrypi:~ $ sudo service fr24feed restart
      pi@raspberrypi:~ $ lsusb
      Bus 001 Device 004: ID 0bda:2838 Realtek Semiconductor Corp. RTL2838 DVB-T
      Bus 001 Device 003: ID 0424:ec00 Standard Microsystems Corp. SMSC9512/9514 Fast Ethernet Adapter
      Bus 001 Device 002: ID 0424:9512 Standard Microsystems Corp. LAN9500 Ethernet 10/100 Adapter / SMSC9512/9514 Hub
      Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

      the tv sticks is listed.


      • #4
        seems like drivers for adsb doongle are not installed, or blacklist is not configured

        Sent from my SM-N910F using Tapatalk


        • #5
          This is the trouble with the device activation. It seems to only work when using the all-in-one FR24 IMAGE. Seperated installs do not get found.

          Ignore the activation process, use the other commands at your disposal (and web config page) to check the status. And online with your account details
          Posts not to be taken as official support representation - Just a helpful uploader who tinkers


          • #6
            Procedure recomended by Oblivian in his above post is given below in detail:

            (A) Try activation by following command
            sudo fr24feed --signup

            (B) Check following 2 pages:

            (1) Status:
            http://<local IP of your Ras Pi>:8754
            Wait for few minutes for page to bring up status. If page does not update in few minutes, try refresh the page.

            (2) View/Enter/Change Settings:
            http://<local IP of Ras Pi>:8754/settings.html
            Refresh page if settings are blank. Change settings if you want, click save button on bottom right, and click restart button next to save button.
            Last edited by abcd567; 2016-08-03, 01:41.


            • #7
              Dumb question but when I open the setting page, I can make changes but there is no SAVE button or anything similar...


              • #8
                Originally posted by petercr View Post
                Dumb question but when I open the setting page, I can make changes but there is no SAVE button or anything similar...
                If you dont see the save button, refresh/reload the page. The save button is at bottom-right corner of the settings page. Please see the image below:

                2016-08-20 09.41.25.jpg


                • #9
                  That's what I tried about 5 mins after posting... (which worked sort of)

                  Still get 'no devices found' when I log in though.

                  Checking the Rasp Pi shows a message that suggests it's working however if I try to view the stats page in my browser, it just sits there thinking...

                  I used the package available on the 'Add Raspberry Pi' link and successfully installed it on to my Pi (can't recall what vintage) and entered my email address, sharing key, lat/long and the IP address. Anything else I should do?
                  Last edited by petercr; 2016-08-20, 23:09.


                  • #10
                    I'm very sorry to grave-dig this thread, but I'm having trouble finding one more recent with the same problem and I'm having the same issue.

                    Did you manage to resolve the issue somehow?