Announcement

Collapse
No announcement yet.

Active Display with RPi

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Oblivian
    replied
    Originally posted by Responder View Post
    Thanks Oblivian but I'm not too brilliant with command lines in Linux. Where would I put either of these?
    I appear to have not got the notification to replies of this thread.

    You don't put those anywhere. Assuming you are on a pi and have the '--net' variable put into the parameters field of the FR24 configuration page, it will instate those ports active.

    From there any programs requiring data can use those output listen ports

    IE AVR format on 30002
    Basestation on 30003
    And beast format on 30005

    Leave a comment:


  • Responder
    replied
    Hi Oblivia,

    I seem to have got it to work, albeit unstable and have to keep pressing Play.

    I installed a program called BaseStation.exe, then used VRS to rebroadcast BaseStation on Port 33001.

    Put in my Local IP and Port into Active Display and it runs but have to keep pressing the Run button on AD.

    Fingers crossed :-)

    Leave a comment:


  • Responder
    replied
    Originally posted by Oblivian View Post
    30002 might not be the right BS format.

    Can try some of these..

    --net-ri-port <port> TCP raw input listen port (default: 30001)
    --net-ro-port <port> TCP raw output listen port (default: 30002)
    --net-sbs-port <port> TCP BaseStation output listen port (default: 30003)
    --net-bi-port <port> TCP Beast input listen port (default: 30004)
    --net-bo-port <port> TCP Beast output listen port (default: 30005)
    Thanks Oblivian but I'm not too brilliant with command lines in Linux. Where would I put either of these?

    Leave a comment:


  • Oblivian
    replied
    30002 might not be the right BS format.

    Can try some of these..

    --net-ri-port <port> TCP raw input listen port (default: 30001)
    --net-ro-port <port> TCP raw output listen port (default: 30002)
    --net-sbs-port <port> TCP BaseStation output listen port (default: 30003)
    --net-bi-port <port> TCP Beast input listen port (default: 30004)
    --net-bo-port <port> TCP Beast output listen port (default: 30005)

    Leave a comment:


  • Responder
    replied
    Originally posted by Oblivian View Post
    If you have it set to do live updates, it samples the received data. Looks up the details. Populates. So needs to find where the local data is.

    I use it in more of a manual form. Where I see new registrations I add them manually via HEX so don't have those sorts of functions
    I can't get Active Display to do anything at all. In the settings\receiver of Active Display, there are three areas. IP addy, TCP (not changeable) and Port. If I do the following:

    1. Pi addy, Port 30002 - Active Display says: BaseStation not running. or,
    2. Pi addy, Port 33001 - Active Display says: SBS Connection cannot be established.

    Not even sure if I emailed GAS, they would be able to assist either.

    Leave a comment:


  • Oblivian
    replied
    Originally posted by Responder View Post
    Hi Oblivian,

    Thank you for your reply.

    I assume that the --net would already be included in the command file. As I am able to view Dump1090 on a web page using my Pi IP xxx.xxx.0.5:8080 and also my Virtual Radar Server on my PC IP xxx.xxx.0.6.

    Why does Active Display need an IP and Port anyway, as it's only supposed to be Populating the .sqb file that is written to by the VRS on my PC?

    Why oh why did they stop using SBS Populate. Which still works but no longer updates the sqb file
    Ahhh yes, if you have some web services already that is likely. Dump1090 uses 30002 for 30003 equivalent output unless you use another command from memory.

    If you have it set to do live updates, it samples the received data. Looks up the details. Populates. So needs to find where the local data is.

    I use it in more of a manual form. Where I see new registrations I add them manually via HEX so don't have those sorts of functions

    Leave a comment:


  • Responder
    replied
    Originally posted by Oblivian View Post
    So close. As long as it has --net running in the command, port 30002 on Pi
    Hi Oblivian,

    Thank you for your reply.

    I assume that the --net would already be included in the command file. As I am able to view Dump1090 on a web page using my Pi IP xxx.xxx.0.5:8080 and also my Virtual Radar Server on my PC IP xxx.xxx.0.6.

    Why does Active Display need an IP and Port anyway, as it's only supposed to be Populating the .sqb file that is written to by the VRS on my PC?

    Why oh why did they stop using SBS Populate. Which still works but no longer updates the sqb file

    Leave a comment:


  • Oblivian
    replied
    Originally posted by Responder View Post
    Hello all,

    Does anyone use the GAS Active Display Software?

    I ask because, I just used to feed FR24, using RTL1090, FR24 Feeder, Virtual Radar Server and Active Display, all running and working perfectly from my PC.

    However, now I am using an RPi, I am able to use Virtual Radar Server without any problems but I cannot configure Active Display to work. I've tried my RPi ISP address, I've tried my NTWRK address, I've also tried the local address (127.0.0.1) and all ports between 30000 and 30003 but nothing seems to be working.

    What I am attempting to achieve, is to Auto Populate my Basestation.sql file that is being written to by the Virtual Radar Server.

    Any ideas?

    Thanks :-)
    So close. As long as it has --net running in the command, port 30002 on Pi

    Leave a comment:


  • Responder
    started a topic Active Display with RPi

    Active Display with RPi

    Hello all,

    Does anyone use the GAS Active Display Software?

    I ask because, I just used to feed FR24, using RTL1090, FR24 Feeder, Virtual Radar Server and Active Display, all running and working perfectly from my PC.

    However, now I am using an RPi, I am able to use Virtual Radar Server without any problems but I cannot configure Active Display to work. I've tried my RPi ISP address, I've tried my NTWRK address, I've also tried the local address (127.0.0.1) and all ports between 30000 and 30003 but nothing seems to be working.

    What I am attempting to achieve, is to Auto Populate my Basestation.sql file that is being written to by the Virtual Radar Server.

    Any ideas?

    Thanks :-)
Working...
X