Page 1 of 61 1231151 ... LastLast
Results 1 to 10 of 607

Thread: Linux feeder software for Flightradar24

  1. #1
    Administrator Mike's Avatar
    Join Date
    Feb 2010
    Location
    Sweden
    Posts
    2,755

    Exclamation Linux feeder software for Flightradar24

    We have prepared a beta version of our Linux feeding software.

    Builds for different architectures can be downloaded using links below:

    x86/i386, dynamically linked (23/04/2014):
    https://dl.dropbox.com/u/66906/fr24feed_x86_242.tgz
    Use "fr24feed_x86_242 --fr24key=YOUR_SHARING_KEY" to run the software.

    x64, dynamically linked (23/04/2014):
    https://dl.dropbox.com/u/66906/fr24feed_x64_242.tgz
    Use "fr24feed_x86_242 --fr24key=YOUR_SHARING_KEY" to run the software.

    ARM LE, dynamically linked (23/04/2014):
    https://dl.dropbox.com/u/66906/fr24feed_arm-le_242.tgz
    Use "fr24feed_arm-le_242 --fr24key=YOUR_SHARING_KEY" to run the software.

    ARM Raspberry-Pi, dynamically linked (07/05/2014):
    https://dl.dropboxusercontent.com/u/...rm-rpi_242.tgz
    Use "fr24feed_arm-rpi_242 --fr24key=YOUR_SHARING_KEY" to run the software.

    ARM LE, statically linked (23/04/2014):
    https://dl.dropbox.com/u/66906/fr24feed_arm-le_242s.tgz

    Use "FR24AUTHIP=83.140.247.20 ./fr24feed_arm-le_241s --fr24key=YOUR_SHARING_KEY" to run the software. - Use only if it fails to connect with errno=111!

    1. You can now overwrite basestation host/ip with --bs-ip=HOSTNAME/IP --bs-port=NNNNN
    2. If you want the application to terminate after there's no data for 15 minutes, please add --self-kill=yes to the argument list
    3. The FR24AUTHIP environmental variable is no longer necessary for static builds
    4. Floating point compatibility issues should be resolved across ARM platforms, please try --test=math to verify.
    5. Starting from version 242 you can use self-registration, just use --signup on startup and follow the instructions.

    ----------------------

    FR24feed for Linux works just as the Windows software, it connects to Basestation stream (localhost:30003 by default) and processes the output. That means that you need to decode the data from your receiver before fr24feed can upload the data. If you need to change ip or port, please contact us, as it is changed server side. If you have a receiver and don't know how to decode the data, we can provide you with a special version that includes decoding. Please send an e-mail with information about your receiver and setup. Please note that special software requests may take 1-4 weeks to handle as we are quite heavily loaded with tasks.

    If you have any questions, comments or just manage to get it working, please let us know.
    Last edited by piopawlu; 2014-04-23 at 08:21. Reason: new version, 242 ARM, x86

  2. #2
    Passenger
    Join Date
    Jun 2012
    Posts
    15
    Hi Mike,
    Can you build this software for ARM9-based processor (ARM926EJ-S for example)?
    Thanks.

  3. #3
    Passenger
    Join Date
    Sep 2012
    Location
    near EDDK (Cologne airport, Germany)
    Posts
    30
    Hi Mike,

    my raspberry PI shows the following:

    # cat /proc/cpuinfo
    Processor : ARMv6-compatible processor rev 7 (v6l)

    on debian 6 (squeeze) ARM.

    Best regards

    Willi

  4. #4
    Passenger
    Join Date
    May 2012
    Posts
    8
    Hi, Mike

    Thanks for the linux version 222.
    I downloaded it and tried it using the indicated command line ./fr24feed_x8x_222 --fr24key=XXX
    I keep getting the same error when it starts :

    [i]Downloading configuration...ERROR
    []:

    I'm currently successfully using version fr24feed_x8x_210_2.6 with the following params : --net-ip=83.140.247.21 --net-email=MYAIRORT --net-pass=MYPASS/SHARINGKEY --bs-ip=127.0.0.1 --bs-port=30003 --latitude=MYLAT --longitude=-0.42280

    My box is running the 2.6.32-41-generic kernel

    Thanks

  5. #5
    Administrator Mike's Avatar
    Join Date
    Feb 2010
    Location
    Sweden
    Posts
    2,755
    Walt/whz: Do you need decoder as well, or upload only? In case you need decoder, what receiver do you have?

  6. #6
    Administrator Mike's Avatar
    Join Date
    Feb 2010
    Location
    Sweden
    Posts
    2,755
    Quote Originally Posted by perefouras View Post
    Hi, Mike

    Thanks for the linux version 222.
    I downloaded it and tried it using the indicated command line ./fr24feed_x8x_222 --fr24key=XXX
    I keep getting the same error when it starts :

    [i]Downloading configuration...ERROR
    []:

    I'm currently successfully using version fr24feed_x8x_210_2.6 with the following params : --net-ip=83.140.247.21 --net-email=MYAIRORT --net-pass=MYPASS/SHARINGKEY --bs-ip=127.0.0.1 --bs-port=30003 --latitude=MYLAT --longitude=-0.42280

    My box is running the 2.6.32-41-generic kernel

    Thanks
    Please try this updated version
    https://dl.dropbox.com/u/66906/fr24feed_x86_222b2.tgz

  7. #7
    Passenger
    Join Date
    Jun 2012
    Posts
    15
    Mike,
    I need upload only.

  8. #8
    Passenger
    Join Date
    May 2012
    Posts
    8
    Quote Originally Posted by Mike View Post
    Thanks Mike for the quick reply !
    Version 222b2 works much better... I've switched to it and it's feeding right now.

    Are the old command line params (--latitude --longitude...) deprecated, or are there new ones that I could/should use ?

  9. #9
    Passenger
    Join Date
    Sep 2012
    Location
    near EDDK (Cologne airport, Germany)
    Posts
    30
    Quote Originally Posted by Mike View Post
    Walt/whz: Do you need decoder as well, or upload only? In case you need decoder, what receiver do you have?
    Hello Mike,

    I have a microADSB. Decoder would be nice.

    Regards

    Willi

  10. #10
    Passenger
    Join Date
    Sep 2012
    Location
    near EDDK (Cologne airport, Germany)
    Posts
    30
    Quote Originally Posted by Walt View Post
    Mike,
    I need upload only.
    Hello Walt,

    how are you going to decode?

    -- Willi

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •